Modify

Opened 10 years ago

Closed 10 years ago

#3095 closed defect (fixed)

portmap on NSLU2 must not use PIE

Reported by: openwrt_trac@… Owned by: nico
Priority: high Milestone: Kamikaze 7.09
Component: packages Version:
Keywords: portmap Cc:

Description

When attempting to execute portmap on NSLU2 (ARM arch), the result is Segmentation fault:

# uname -a
Linux slug 2.6.21.6 #1 Fri Dec 28 11:04:49 UTC 2007 armv5teb unknown

# ls -al portmap
-rwxr-xr-x    1 root     root        13400 Oct  1 00:16 portmap

#portmap
Segmentation fault

This can be rectified by disabling PIE in the portmap Makefile, around line 128:

CPPFLAGS += $(HOSTS_ACCESS)
# portmap: CFLAGS   += -fpie
portmap: LDLIBS   += $(WRAP_LIB)
# portmap: LDFLAGS  += -pie
portmap: portmap.o pmap_check.o from_local.o

The resulting executable is smaller and functions as intended:

# ls -al portmap
-rwxr-xr-x    1 root     root        12952 Jan 28 19:51 portmap

# portmap

# ps
  PID  Uid     VmSize Stat Command
 ...
 4321 nobody      300 S   portmap

Attachments (1)

portmap-Makefile.patch (682 bytes) - added by anonymous 10 years ago.

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by anonymous

comment:1 Changed 10 years ago by anonymous

Same problem on x86, suggested fix wrapped up as a patch against the package feed.

comment:2 Changed 10 years ago by nico

  • Owner changed from developers to nico
  • Status changed from new to assigned

comment:3 Changed 10 years ago by nico

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in [11001], thanks!

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.