Modify

Opened 10 years ago

Closed 5 years ago

Last modified 4 years ago

#3047 closed defect (worksforme)

r10141; "eth0: rx dma ring overrun"

Reported by: nabcore Owned by: matteo
Priority: normal Milestone: Barrier Breaker 14.07
Component: kernel Version:
Keywords: AR7 Cc:

Description

Regularly getting this dmesg:

eth0: rx dma ring overrun
eth0: rx dma ring overrun
eth0: rx dma ring overrun
eth0: rx dma ring overrun

Occurs usually when playing World of Warcraft (WoW) on a PC that the AR7 unit is NATing for. Since I've only seen this recently, it may be related to a recently patch in WoW ( 2.3.2 : http://www.worldofwarcraft.com/patchnotes/ ) in which the Nagle algorithm within the game was turned off to reduce network latency. Therefore, this may have increased the in game network traffic by 40 times.

Attachments (1)

cpmac_rx_ring_size_128.patch (428 bytes) - added by Chris Humbert <openwrt@…> 6 years ago.
increase default cpmac rx ring size from 64 to 128

Download all attachments as: .zip

Change History (16)

comment:1 Changed 10 years ago by frop

same problem on a 502t (AR7DB) with revision 10594

comment:2 Changed 10 years ago by matteo

  • Owner changed from developers to matteo

comment:3 Changed 10 years ago by matteo

I can easily reproduce it with:
sudo hping3 router -d 1472 -1 --flood
and I get:

printk: 374 messages suppressed.
eth0: rx dma ring overrun
printk: 372 messages suppressed.
eth0: rx dma ring overrun
printk: 367 messages suppressed.
eth0: rx dma ring overrun
printk: 373 messages suppressed.
eth0: rx dma ring overrun
printk: 372 messages suppressed.
eth0: rx dma ring overrun
printk: 369 messages suppressed.
eth0: rx dma ring overrun

comment:4 Changed 9 years ago by florian

Is that fixed now ?

comment:5 follow-up: Changed 9 years ago by Unaimed

No, i'm still receiving these errors on DSL-G624T.

comment:6 in reply to: ↑ 5 Changed 9 years ago by anonymous

I am also receiving this on my Linksys AG300. However, I don't play WoW so the problem is more wide spread.

The AG300 is doing NAt for a single network. The only thing special I can think of is that I also have a wireless bridge plugged in to the AG300.

The problem seems to occur from me during large file transfers (SCP).

comment:7 Changed 9 years ago by mark@…

sorry forgot to login. The above comment was made by me.

comment:8 Changed 8 years ago by joe.a.burmeister@…

I've got a G624T too (with openwrt) and I'm also seeing this. I loose internet, when I ssh in and do dmesg I see:

eth0: rx dma ring overrun 119 times
DSL out of sync
DSL in Sync
eth0: rx dma ring overrun 28 times
DSL out of sync
DSL in Sync
DSL out of sync
DSL in Sync
DSL out of sync
DSL in Sync
etc etc for 55 times

then the internet is back.

Has anyone found out any more about this and how to solve it?

comment:9 Changed 8 years ago by joe.a.burmeister@…

Could this be related to:

/ticket/2569.html

?

comment:10 Changed 8 years ago by luka12345.linux@…

I'm also geting this error in revision r18431 on D-link 584T ar7.

dmesg
...
DSL in Sync
DSL out of sync
DSL in Sync
eth0: rx dma ring overrun
eth0: rx dma ring overrun
eth0: rx dma ring overrun
...

comment:11 Changed 8 years ago by thepeople

  • Status changed from new to assigned

comment:12 Changed 8 years ago by Steven Ellis <steven@…>

I'm seeing "eth0: rx dma ring overrun" on 10.03 r20728, but since upgrading to 10.03 I'm seeing the DSL Sync issue a lot less so it might not be related now.

I'm running on AR7 hardware with wireless disabled and limited packages. I found if I was running collectd I'd have more stability issues so I haven't installed it since upgrading to 10.3

My current package list is

atm-tools - 2.5.1-1
base-files - 42-r20728
br2684ctl - 20040226-1
busybox - 1.15.3-2
ddns-scripts - 1.0.0-6
dnsmasq - 2.52-2
dropbear - 0.52-4
firewall - 1-10
hotplug2 - 1.0-beta-1
iptables - 1.4.6-2
iptables-mod-conntrack - 1.4.6-2
iptables-mod-conntrack-extra - 1.4.6-2
iptables-mod-filter - 1.4.6-2
iptables-mod-imq - 1.4.6-2
iptables-mod-ipopt - 1.4.6-2
iptables-mod-nat - 1.4.6-2
kernel - 2.6.32.10-1
kmod-atm - 2.6.32.10-1
kmod-crc-ccitt - 2.6.32.10-1
kmod-ipt-conntrack - 2.6.32.10-1
kmod-ipt-conntrack-extra - 2.6.32.10-1
kmod-ipt-core - 2.6.32.10-1
kmod-ipt-filter - 2.6.32.10-1
kmod-ipt-imq - 2.6.32.10-1
kmod-ipt-ipopt - 2.6.32.10-1
kmod-ipt-nat - 2.6.32.10-1
kmod-ipt-nathelper - 2.6.32.10-1
kmod-ppp - 2.6.32.10-1
kmod-pppoa - 2.6.32.10-1
kmod-pppoe - 2.6.32.10-1
kmod-sangam-atm-annex-a - 2.6.32.10+D7.04.03.00-R1
kmod-sched - 2.6.32.10-1
kmod-textsearch - 2.6.32.10-1
libc - 0.9.30.1-42
libgcc - 4.3.3+cs-42
libiptc - 1.4.6-2
liblua - 5.1.4-6
libuci - 12012009.5-1
libuci-lua - 12012009.5-1
libxtables - 1.4.6-2
linux-atm - 2.5.1-1
lua - 5.1.4-6
luci - 0.9.0-1
luci-admin-core - 0.9.0-1
luci-admin-full - 0.9.0-1
luci-admin-mini - 0.9.0-1
luci-app-ddns - 0.9.0-1
luci-app-firewall - 0.9.0-1
luci-app-initmgr - 0.9.0-1
luci-app-qos - 0.9.0-1
luci-cbi - 0.9.0-1
luci-core - 0.9.0-1
luci-http - 0.9.0-1
luci-i18n-english - 0.9.0-1
luci-ipkg - 0.9.0-1
luci-lmo - 0.9.0-1
luci-nixio - 0.9.0-1
luci-sgi-cgi - 0.9.0-1
luci-sys - 0.9.0-1
luci-theme-base - 0.9.0-1
luci-theme-openwrt - 0.9.0-1
luci-uci - 0.9.0-1
luci-uvl - 0.9.0-1
luci-web - 0.9.0-1
mtd - 12
openntpd - 3.9p1-3
opkg - 513-2
ppp - 2.4.4-5
ppp-mod-pppoa - 2.4.4-5
ppp-mod-pppoe - 2.4.4-5
qos-scripts - 1.2.1-2
tc - 2.6.29-1-2
uci - 12012009.5-1
udevtrigger - 106-1
uhttpd - 7

Changed 6 years ago by Chris Humbert <openwrt@…>

increase default cpmac rx ring size from 64 to 128

comment:13 Changed 6 years ago by Chris Humbert <openwrt@…>

cpmac's default rx ring size is 64 Ethernet frames, using 104 KiB memory when the link is up. Setting the ring size to 128 (208 KiB) eliminated "rx dma ring overrun" in my environment for the past 24 hours. A maximum ring size of 1024 frames (1664 KiB) is allowed. To change the rx ring size at runtime:

ifconfig eth0 down; ethtool --set-ring eth0 rx 128; ifconfig eth0 up

comment:14 Changed 5 years ago by florian

  • Resolution set to worksforme
  • Status changed from assigned to closed

Since this can be done manually when anyone needs to, I am closing the ticket.

comment:15 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.