Modify

Opened 10 years ago

Closed 10 years ago

#3034 closed defect (duplicate)

ixp4xx svn 10203 dnsmasq or ipcalc.sh issue?

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Kamikaze 8.09 RC1
Component: packages Version:
Keywords: svn 10203 dnsmasq ipcalc.sh no addresses Cc:

Description

svn10203 ixp4xx: ipcalc.sh doesn't calc the netmask correctly, it calcs 0.0.0.0 and i think that is what is jacking up dnsmasq. when i do "ipcalc.sh 10.0.0.1 255.255.255.0 100 50" it yields: IP=10.0.0.1 NETMASK=0.0.0.0. The checking /proc/PIDOFDNSMASQ/cmdline i can see this for the IP info:
/usr/sbin/dnsmasq-K-D-y-Z-b-E-slan-S/lan/-l/tmp/dhcp.leases-r/tmp/resolv.conf.auto--dhcp-range=lan,10.0.0.10,10.0.0.20,0.0.0.0,12h-Ieth0
looks like the netmask is wrong. Can this be causing dnsmasq to fail to hand out IP's?

Attachments (0)

Change History (3)

comment:1 Changed 10 years ago by agb

brcm-2.4: 7.07 and r10678 work properly.
ixp4xx: r10391 bug confirmed. firing off a new build, will test tomorrow.

comment:2 Changed 10 years ago by GLR

Kamikaze ixp4xx r11765 : ipcalc.sh still returns wrong values :

# ipcalc.sh 192.168.1.1
IP=0.0.0.1
NETMASK=0.0.0.0
BROADCAST=0.0.0.255
NETWORK=0.0.0.0
PREFIX=16

Therefore or also (?) syslogd remote logging doesn't work and certainly dnsmasq too.

Same ipcalc.sh and /usr/lib/common.awk code work correctly on bcm-2.4 platform.

comment:3 Changed 10 years ago by florian

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #3751

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.