Modify

Opened 10 years ago

Closed 10 years ago

Last modified 7 years ago

#3033 closed defect (worksforme)

glib2 fails to build

Reported by: michu-at-neophobdotcom Owned by: developers
Priority: normal Milestone:
Component: packages Version:
Keywords: Cc:

Description

I tried to build glib2, without success. I'm using r10204 on brcm47xx-2.6.

michux@fwpiercer:/home/openwrt/trunk$ make package/libs/glib2-clean
 make[1] package/libs/glib2-clean
 make[2] -C feeds/packages/libs/glib2 clean
michux@fwpiercer:/home/openwrt/trunk$ make package/libs/glib2-compile V=99
make[1]: Entering directory `/home/openwrt/trunk'
make[2]: Entering directory `/home/openwrt/trunk/package/libtool'
WARNING: skipping libltdl -- package not selected
make[2]: Leaving directory `/home/openwrt/trunk/package/libtool'
make[2]: Entering directory `/home/openwrt/trunk/feeds/packages/libs/libiconv'
make[2]: Leaving directory `/home/openwrt/trunk/feeds/packages/libs/libiconv'
make[2]: Entering directory `/home/openwrt/trunk/feeds/packages/libs/gettext'
make[2]: Leaving directory `/home/openwrt/trunk/feeds/packages/libs/gettext'
make[2]: Entering directory `/home/openwrt/trunk/feeds/packages/libs/glib2'
gzip -dc /home/openwrt/trunk/dl/glib-2.12.12.tar.gz | /bin/tar -C /home/openwrt/trunk/build_dir/mipsel/glib-2.12.12/.. -xf -

Applying ./patches/001-no_docs_and_tests.patch using plaintext:
patching file Makefile.in

Applying ./patches/002-libtool_fixes.patch using plaintext:
patching file glib/Makefile.in
patching file glib/gnulib/Makefile.in
patching file gmodule/Makefile.in
patching file gobject/Makefile.in
patching file gthread/Makefile.in
patching file glib/libcharset/Makefile.in
Hunk #1 succeeded at 287 with fuzz 1.
touch /home/openwrt/trunk/build_dir/mipsel/glib-2.12.12/.prepared_386ab9ec2e6b32c054b28d2a83cb8a81
if [ -f "/home/openwrt/trunk/build_dir/mipsel/glib-2.12.12/./libtool" -a -e "/home/openwrt/trunk/staging_dir/mipsel/host/bin/libtool" ]; then rm -f /home/openwrt/trunk/build_dir/mipsel/glib-2.12.12/./libtool; ln -s /home/openwrt/trunk/staging_dir/mipsel/host/bin/libtool /home/openwrt/trunk/build_dir/mipsel/glib-2.12.12/./; fi
if [ -f "/home/openwrt/trunk/build_dir/mipsel/glib-2.12.12/./ltmain.sh" -a -e "/home/openwrt/trunk/staging_dir/mipsel/host/share/libtool/ltmain.sh" ]; then rm -f /home/openwrt/trunk/build_dir/mipsel/glib-2.12.12/./ltmain.sh; ln -s /home/openwrt/trunk/staging_dir/mipsel/host/share/libtool/ltmain.sh /home/openwrt/trunk/build_dir/mipsel/glib-2.12.12/./; fi
if [ -f "/home/openwrt/trunk/build_dir/mipsel/glib-2.12.12/./libtool.m4" -a -e "/home/openwrt/trunk/staging_dir/mipsel/host/share/aclocal/libtool.m4" ]; then rm -f /home/openwrt/trunk/build_dir/mipsel/glib-2.12.12/./libtool.m4; ln -s /home/openwrt/trunk/staging_dir/mipsel/host/share/aclocal/libtool.m4 /home/openwrt/trunk/build_dir/mipsel/glib-2.12.12/./; fi
if [ -f "/home/openwrt/trunk/build_dir/mipsel/glib-2.12.12/./configure" ]; then /home/openwrt/trunk/staging_dir/host/bin/sed -i -e 's,pardus_ltmain_version=.*,pardus_ltmain_version="$pardus_lt_version",' /home/openwrt/trunk/build_dir/mipsel/glib-2.12.12/./configure; fi
mkdir -p /home/openwrt/trunk/build_dir/mipsel/glib-2.12.12/build/i486-linux-gnu
( cd /home/openwrt/trunk/build_dir/mipsel/glib-2.12.12; CONFIG_SITE= ./configure --target=i486-linux-gnu --host=i486-linux-gnu --build=i486-linux-gnu --prefix=/home/openwrt/trunk/build_dir/mipsel/glib-2.12.12/build/i486-linux-gnu --disable-shared --enable-static --enable-debug=no );
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking build system type... i486-pc-linux-gnu
checking host system type... i486-pc-linux-gnu
checking for the BeOS... no
checking for Win32... no
checking whether to enable garbage collector friendliness... no
checking whether to disable memory pools... no
checking for i486-linux-gnu-gcc... i486-linux-gnu-gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether i486-linux-gnu-gcc accepts -g... yes
checking for i486-linux-gnu-gcc option to accept ISO C89... none needed
checking for style of include used by make... GNU
checking dependency style of i486-linux-gnu-gcc... gcc3
checking for c++... c++
checking whether we are using the GNU C++ compiler... yes
checking whether c++ accepts -g... yes
checking dependency style of c++... gcc3
checking for i486-linux-gnu-gcc option to accept ANSI C... none needed
checking for a BSD-compatible install... /usr/bin/install -c
checking for special C compiler options needed for large files... no
checking for _FILE_OFFSET_BITS value needed for large files... 64
checking for _LARGE_FILES value needed for large files... no
checking for pkg-config... /home/openwrt/trunk/staging_dir/host/bin/pkg-config
checking for gawk... (cached) gawk
checking for perl5... no
checking for perl... perl
checking for indent... no
checking for perl... /usr/bin/perl
checking for iconv_open... yes
checking how to run the C preprocessor... i486-linux-gnu-gcc -E
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking whether we are using the GNU C Library 2.1 or newer... yes
checking Whether to cache iconv descriptors... no
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking locale.h usability... yes
checking locale.h presence... yes
checking for locale.h... yes
checking for LC_MESSAGES... yes
checking libintl.h usability... yes
checking libintl.h presence... yes
checking for libintl.h... yes
checking for ngettext in libc... yes
checking for dgettext in libc... yes
checking for bind_textdomain_codeset... yes
checking for msgfmt... no
configure: error:
*** You must have either have gettext support in your C library, or use the
*** GNU gettext library. (http://www.gnu.org/software/gettext/gettext.html

make[2]: *** [/home/openwrt/trunk/build_dir/mipsel/glib-2.12.12/.configured] Error 1
make[2]: Leaving directory `/home/openwrt/trunk/feeds/packages/libs/glib2'
make[1]: *** [package/libs/glib2/compile] Error 2
make[1]: Leaving directory `/home/openwrt/trunk'
make: *** [package/libs/glib2-compile] Error 2

Attachments (0)

Change History (4)

comment:1 Changed 10 years ago by michu-at-neophobdotcom

guess this ticked can be closed...

comment:2 Changed 10 years ago by florian

  • Resolution set to worksforme
  • Status changed from new to closed

comment:3 Changed 8 years ago by mike

FYI, this was probably caused by a lack of gettext on the machine that was compiling OpenWRT.

comment:4 Changed 7 years ago by anonymous

Yup, worked for me after installing gettext on build machine. Failed prior to that.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.