Modify

Opened 10 years ago

Closed 10 years ago

#3013 closed defect (fixed)

wireless-tools package in Kamikaze trunk contains duplicate binaries (patch attached)

Reported by: anonymous Owned by: agb
Priority: normal Milestone:
Component: packages Version:
Keywords: Cc:

Description

I noticed a significant increase in the wireless-tools package size, also leading to a noticably incresaed firmware image file size.

Currently, five identical copies of the (rather large) iwconfig binary are included in the generated package, one for each alias name. To make it worse, squashfs does not seem to detect that these files are identically, increasing the generated image size significantly.

This was probably caused by an unexpected side effect when changing a $(CP) within the packages Makefile to an $(INSTALL_BIN) - while $(CP) had preserved symlinks generated by the upstream build system, $(INSTALL_BIN) explodes these into copies of the files pointed to by the links.

I attached a possible solution which creates a working package which only includes one binary and several alias links, as it was before the Makefile change.

Attachments (1)

wireless_tools_fix_redundant_binaries.patch (856 bytes) - added by anonymous 10 years ago.

Download all attachments as: .zip

Change History (3)

Changed 10 years ago by anonymous

comment:1 Changed 10 years ago by agb

  • Owner changed from developers to agb
  • Status changed from new to assigned

comment:2 Changed 10 years ago by agb

  • Resolution set to fixed
  • Status changed from assigned to closed

Thanks, fixed in [10188]

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.