Modify

Opened 10 years ago

Closed 10 years ago

#2971 closed defect (worksforme)

make package/symlinks : fails

Reported by: anonymous Owned by: developers
Priority: highest Milestone: Kamikaze 7.09
Component: packages Version:
Keywords: Cc:

Description

By doing steps:
cd ~
rm -rf ~/kamikaze_7.09/
svn -q checkout https://svn.openwrt.org/openwrt/tags/kamikaze_7.09/ kamikaze_7.09/
cd ~/kamikaze_7.09/
make defconfig package/symlinks menuconfig
make world


make package/symlinks creates errors

make -C package symlinks
make[1]: Entering directory `/home/spawn/Desktop/kamikaze_7.09/package'
make[1]: Leaving directory `/home/spawn/Desktop/kamikaze_7.09/package'
make[1]: Entering directory `/home/spawn/Desktop/kamikaze_7.09/package'
../scripts/feeds.sh "https://svn.openwrt.org/openwrt/packages/" ""
At revision 10113.
Updated to revision 10113
ln: creating symbolic link `/home/spawn/Desktop/kamikaze_7.09/package/files' to `/home/spawn/Desktop/kamikaze_7.09/feeds/https_svn.openwrt.org_openwrt_packages_/skels/files': File exists
ln: creating symbolic link `/home/spawn/Desktop/kamikaze_7.09/package/bzip2' to `/home/spawn/Desktop/kamikaze_7.09/feeds/https_svn.openwrt.org_openwrt_packages_/utils/bzip2': File exists
make[1]: *** [symlinks] Error 1
make[1]: Leaving directory `/home/spawn/Desktop/kamikaze_7.09/package'
make: *** [package/symlinks] Error 2

Attachments (2)

kamikaze_709_feeds_fix.patch (801 bytes) - added by jhalfmoon@… 10 years ago.
A patch to fix scripts/feeds.sh
kamikaze_709_feeds_fix.2.patch (540 bytes) - added by anonymous 10 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 10 years ago by jhalfmoon@…

Same problem here on Kamikaze 7.09. The cause of this bug is

/changeset/9622.html

It breaks "make package/symlinks" because bzip2 was split into 2 packages, both in a different category, but with the same package name. The script feeds.sh is called by package/Makefile. It downloads the current packagelist (called a feed) using svn into the directory 'feeds' and then parses the list into a single flat directory 'packages' containing symlinks to the downloaded packages. This last step fails because it will try to symlink bzip2 twice. A fix for this bug is attached.

Changed 10 years ago by jhalfmoon@…

A patch to fix scripts/feeds.sh

Changed 10 years ago by anonymous

comment:2 Changed 10 years ago by anonymous

Oops. Use kamikaze_709_feeds_fix.2.patch and not the other one.

To the Trac admins: Can you please delete kamikaze_709_feeds_fix.patch? I have no such rights.

comment:3 Changed 10 years ago by zioproto@…

I strongly believe this ticket does not make sense because there is not a tag for the packages folder tagged at 7.09.

You should compile trunk version if you need also packages.

Note that with r10252 it is deprecated to do

make package/symlinks 

and you should do:

./scripts/feeds install -a
./scripts/feeds install -a -p xwrt

Please for 7.10 tag also make a tag of the packages folder!

comment:4 Changed 10 years ago by nbd

  • Resolution set to worksforme
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.