Modify

Opened 10 years ago

Closed 9 years ago

Last modified 6 years ago

#2919 closed defect (worksforme)

libcurl fails to compile on mips expecting little endian libncurses

Reported by: bart dot polot at gmail dot com Owned by: developers
Priority: normal Milestone:
Component: packages Version:
Keywords: libcurl, libncurses Cc:

Description

Hi,

It's my first time reporting a problem, so if anything is wrong, please don't be mad!
I'm using revision 10051, for Atheros.

make:

 make[3] -C /home/n0rdik0/fonera/openwrt/packages/libs/curl compile
make -r world: build failed. Please re-run make with V=99 to see what's going on
make: *** [world] Error 1

make V=99:

configure: creating ./config.status
/bin/sh: error while loading shared libraries: /home/n0rdik0/fonera/openwrt/kamikaze/staging_dir/mips/usr/lib/libncurses.so.5: ELF file data encoding not little-endian
make[3]: *** [/home/n0rdik0/fonera/openwrt/kamikaze/build_dir/mips/curl-7.17.1/.configured] Error 1
make[3]: Leaving directory `/home/n0rdik0/fonera/openwrt/packages/libs/curl'
make[2]: *** [package/curl/compile] Error 2
make[2]: Leaving directory `/home/n0rdik0/fonera/openwrt/kamikaze'
make[1]: *** [/home/n0rdik0/fonera/openwrt/kamikaze/staging_dir/mips/stamp/.package_compile] Error 2
make[1]: Leaving directory `/home/n0rdik0/fonera/openwrt/kamikaze'
make: *** [world] Error 2

If you need any more info just tell :)

Attachments (0)

Change History (11)

comment:1 Changed 10 years ago by bart dot polot at gmail dot com

I've tried to remove selection on php-curl and libcurl (curl wasn't selected at all) but it keeps trying to compile it:

make[3]: Entering directory `/home/n0rdik0/fonera/openwrt/packages/net/openntpd'
make[3]: Leaving directory `/home/n0rdik0/fonera/openwrt/packages/net/openntpd'
make[3]: Entering directory `/home/n0rdik0/fonera/openwrt/packages/libs/radiusclient-ng'
WARNING: skipping radiusclient-ng -- package not selected
make[3]: Leaving directory `/home/n0rdik0/fonera/openwrt/packages/libs/radiusclient-ng'
make[3]: Entering directory `/home/n0rdik0/fonera/openwrt/packages/net/openser'
make[3]: Leaving directory `/home/n0rdik0/fonera/openwrt/packages/net/openser'
make[3]: Entering directory `/home/n0rdik0/fonera/openwrt/packages/net/openssh'
make[3]: Leaving directory `/home/n0rdik0/fonera/openwrt/packages/net/openssh'
make[3]: Entering directory `/home/n0rdik0/fonera/openwrt/kamikaze/package/openswan'
make[3]: Leaving directory `/home/n0rdik0/fonera/openwrt/kamikaze/package/openswan'
make[3]: Entering directory `/home/n0rdik0/fonera/openwrt/packages/net/openvpn'
make[3]: Leaving directory `/home/n0rdik0/fonera/openwrt/packages/net/openvpn'
make[3]: Entering directory `/home/n0rdik0/fonera/openwrt/packages/net/peerguardian'
make[3]: Leaving directory `/home/n0rdik0/fonera/openwrt/packages/net/peerguardian'
make[3]: Entering directory `/home/n0rdik0/fonera/openwrt/packages/lang/perl'
make[3]: Leaving directory `/home/n0rdik0/fonera/openwrt/packages/lang/perl'
make[3]: Entering directory `/home/n0rdik0/fonera/openwrt/packages/libs/curl'
WARNING: skipping curl -- package not selected
bzcat /home/n0rdik0/fonera/openwrt/kamikaze/dl/curl-7.17.1.tar.bz2 | /bin/tar -C /home/n0rdik0/fonera/openwrt/kamikaze/build_dir/mips/curl-7.17.1/.. -xf -

Applying ./patches/510-no_sslv2.patch using plaintext:
patching file lib/ssluse.c
Hunk #1 succeeded at 1282 (offset 138 lines).
patching file src/main.c
Hunk #1 succeeded at 733 with fuzz 2 (offset 308 lines).
Hunk #2 succeeded at 1986 (offset 313 lines).
touch /home/n0rdik0/fonera/openwrt/kamikaze/build_dir/mips/curl-7.17.1/.prepared_5b8e2e5a540311ce8a8735f53a832e53
if [ -f "/home/n0rdik0/fonera/openwrt/kamikaze/build_dir/mips/curl-7.17.1/./libtool" -a -e "/home/n0rdik0/fonera/openwrt/kamikaze/staging_dir/mips/host/bin/libtool" ]; then rm -f /home/n0rdik0/fonera/openwrt/kamikaze/build_dir/mips/curl-7.17.1/./libtool; ln -s /home/n0rdik0/fonera/openwrt/kamikaze/staging_dir/mips/host/bin/libtool /home/n0rdik0/fonera/openwrt/kamikaze/build_dir/mips/curl-7.17.1/./; fi
[continues and fails]

Deleting dl/curl* doesn't help:

make[3]: Entering directory `/home/n0rdik0/fonera/openwrt/packages/libs/radiusclient-ng'
WARNING: skipping radiusclient-ng -- package not selected
make[3]: Leaving directory `/home/n0rdik0/fonera/openwrt/packages/libs/radiusclient-ng'
make[3]: Entering directory `/home/n0rdik0/fonera/openwrt/packages/net/openser'
make[3]: Leaving directory `/home/n0rdik0/fonera/openwrt/packages/net/openser'
make[3]: Entering directory `/home/n0rdik0/fonera/openwrt/packages/net/openssh'
make[3]: Leaving directory `/home/n0rdik0/fonera/openwrt/packages/net/openssh'
make[3]: Entering directory `/home/n0rdik0/fonera/openwrt/kamikaze/package/openswan'
make[3]: Leaving directory `/home/n0rdik0/fonera/openwrt/kamikaze/package/openswan'
make[3]: Entering directory `/home/n0rdik0/fonera/openwrt/packages/net/openvpn'
make[3]: Leaving directory `/home/n0rdik0/fonera/openwrt/packages/net/openvpn'
make[3]: Entering directory `/home/n0rdik0/fonera/openwrt/packages/net/peerguardian'
make[3]: Leaving directory `/home/n0rdik0/fonera/openwrt/packages/net/peerguardian'
make[3]: Entering directory `/home/n0rdik0/fonera/openwrt/packages/lang/perl'
make[3]: Leaving directory `/home/n0rdik0/fonera/openwrt/packages/lang/perl'
make[3]: Entering directory `/home/n0rdik0/fonera/openwrt/packages/libs/curl'
WARNING: skipping curl -- package not selected
mkdir -p /home/n0rdik0/fonera/openwrt/kamikaze/dl
/home/n0rdik0/fonera/openwrt/kamikaze/scripts/download.pl "/home/n0rdik0/fonera/openwrt/kamikaze/dl" "curl-7.17.1.tar.bz2" "1fa635d1dfde8337c98c82749d75c1de" http://curl.haxx.se/download/ http://www.mirrorspace.org/curl/ http://curl.mirror.internet.tp/download/ ftp://ftp.sunet.se/pub/www/utilities/curl/ ftp://ftp.planetmirror.com/pub/curl/ http://www.mirrormonster.com/curl/download/ http://curl.mirrors.cyberservers.net/download/
--07:08:34--  http://curl.haxx.se/download/curl-7.17.1.tar.bz2
           => `-'
Resolving curl.haxx.se... 91.191.140.28
Connecting to curl.haxx.se|91.191.140.28|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1,721,551 (1.6M) [application/x-bzip2]

100%[================================================================================================================>] 1,721,551    216.37K/s    ETA 00:00

07:08:42 (233.62 KB/s) - `-' saved [1721551/1721551]

bzcat /home/n0rdik0/fonera/openwrt/kamikaze/dl/curl-7.17.1.tar.bz2 | /bin/tar -C /home/n0rdik0/fonera/openwrt/kamikaze/build_dir/mips/curl-7.17.1/.. -xf -

Applying ./patches/510-no_sslv2.patch using plaintext:
patching file lib/ssluse.c
Hunk #1 succeeded at 1282 (offset 138 lines).
patching file src/main.c
Hunk #1 succeeded at 733 with fuzz 2 (offset 308 lines).
Hunk #2 succeeded at 1986 (offset 313 lines).
touch /home/n0rdik0/fonera/openwrt/kamikaze/build_dir/mips/curl-7.17.1/.prepared_5b8e2e5a540311ce8a8735f53a832e53

I've checked ".config" twice and everything even close to "curl" is not selected. Any advice would be great.

Regards, Bart.

comment:2 Changed 10 years ago by Timot

Same problem for me, but for ixp4xx target. No curl Library selected in menuconfig, but it get compiled anyways. Error is :

/bin/bash: error while loading shared libraries: /media/RAID1_2/home/timot/OpenWRT/ixp4xx/trunk/staging_dir/armeb/usr/lib/libncurses.so.5: ELF file data encoding not little-endian

tested with svn revisions 10050 and 10082

comment:3 Changed 10 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

fixed in r10186

comment:4 Changed 10 years ago by anonymous

  • Resolution fixed deleted
  • Status changed from closed to reopened

Still not working for me, revision 10204, same error:

checking whether to enable support for cookies... yes
checking whether to enable hidden symbols in the library... no
configure: creating ./config.status
/bin/sh: error while loading shared libraries: /home/n0rdik0/fonera/openwrt/kamikaze/staging_dir/mips/usr/lib/libncurses.so.5: ELF file data encoding not little-endian
make[3]: *** [/home/n0rdik0/fonera/openwrt/kamikaze/build_dir/mips/curl-7.17.1/.configured] Error 1
make[3]: Leaving directory `/home/n0rdik0/fonera/openwrt/packages/libs/curl'
make[2]: *** [package/curl/compile] Error 2
make[2]: Leaving directory `/home/n0rdik0/fonera/openwrt/kamikaze'
make[1]: *** [/home/n0rdik0/fonera/openwrt/kamikaze/staging_dir/mips/stamp/.package_compile] Error 2
make[1]: Leaving directory `/home/n0rdik0/fonera/openwrt/kamikaze'
make: *** [world] Error 2
n0rdik0@pioneer ~/fonera/openwrt/kamikaze $ svn info
Ruta: .
URL: https://svn.openwrt.org/openwrt/trunk
Raíz del repositorio: https://svn.openwrt.org/openwrt
UUID del repositorio: 3c298f89-4303-0410-b956-a3cf2f4a3e73
Revisión: 10204
Tipo de nodo: directorio
Agendado: normal
Autor del último cambio: matteo
Revisión del último cambio: 10203
Fecha de último cambio: 2008-01-15 04:25:11 +0100 (mar, 15 ene 2008)

I made a make distclean before that, just to make sure it's not something old messing things up.

comment:5 Changed 10 years ago by Timot

Fixed it for me (ixp4xx/armeb @ rev 10211)
thanks !

comment:6 Changed 10 years ago by anonymous

Still failing for Atheros, rev 10260.

comment:7 Changed 10 years ago by anonymous

Still failing for Atheros.

comment:8 follow-up: Changed 10 years ago by bmilde@…

Dirty quickfix at /ticket/3197.html (duplicate of this bug)
Can also report that its still a problem on atheros and a big show-stopper because even if you remove curl some other packages (i.e. mysql in my case) still want curl.

comment:9 in reply to: ↑ 8 Changed 10 years ago by anonymous

Replying to bmilde@osev.de:

Dirty quickfix at /ticket/3197.html (duplicate of this bug)
Can also report that its still a problem on atheros and a big show-stopper because even if you remove curl some other packages (i.e. mysql in my case) still want curl.

PHP also wants curl as a buildtime dependence even though it doesnt need it in runtime. It was explained in another bug, but I cant find it now.

comment:10 Changed 9 years ago by florian

I still cannot reproduce it, is that still happening with you ?

comment:11 Changed 9 years ago by nbd

  • Resolution set to worksforme
  • Status changed from reopened to closed

bug timeout

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.