Modify

Opened 10 years ago

Closed 10 years ago

Last modified 4 years ago

#2877 closed defect (fixed)

Kernel Panic on rb150 (adm5120) when under heavy load

Reported by: abates@… Owned by: florian
Priority: normal Milestone: Barrier Breaker 14.07
Component: kernel Version:
Keywords: adm5120 kernel panic Cc:

Description

When the router is under heavy load (like routing from one ethernet interface to another during a file transfer) the router gets a kernel panic and reboots. The output of the kernel panic follows:

Oops[#1]:
Cpu 0
$ 0   : 00000000 10008400 810a8664 01c4e012
$ 4   : 00000019 00000000 000b8d0d 000b8cf9
$ 8   : 803c1da0 0000023a 000b8d0d 81186b80
$12   : 00000001 80270000 9e3779b9 80277dc0
$16   : 10008401 00000064 802694f8 81057000
$20   : ffffff77 00000000 80277f38 00000040
$24   : 00000000 80129484                  
$28   : 80276000 80277ef0 00000000 80129918
Hi    : 000000b0
Lo    : 0011730c
epc   : 80129888     Not tainted
ra    : 80129918 Status: 10008403    KERNEL EXL IE 
Cause : 30800008
BadVA : 00000018
PrId  : 0001800b
Modules linked in:
Process ksoftirqd/0 (pid: 3, threadinfo=80276000, task=8105d028)
Stack : 801543d4 10008401 803c1da0 00000000 8105712c 81057000 802694f8 80269508
        ffffff77 00000000 00000000 00000000 80154568 00000000 00000009 00000000
        80153c24 80153b54 0000010c 8001ad70 00000000 8025f954 00000009 00000000
        00000000 80025c04 00000000 8001ca9c 10008403 00000000 10008401 80026164
        00000000 80025ce8 00000000 00000000 00000000 00000000 80260000 800261a8
        ...
Call Trace:[<801543d4>][<80154568>][<80153c24>][<80153b54>][<8001ad70>][<80025c04>][<8001ca9c>][<80026164>][<80025ce8>][<800261a8>][<800362dc>][<800362bc>][]

Code: 02221021  04600040  8c450000 <8ca40018> 8c82002c  30420002  10400009  00000000  8ca30054 
Kernel panic - not syncing: Fatal exception in interrupt

Here is my normal process list:

root@OpenWrt:/# ps 
  PID  Uid        VSZ Stat Command
    1 root       2372 S   init       
    2 root            SW< [kthreadd]
    3 root            SW< [ksoftirqd/0]
    4 root            SW< [events/0]
    5 root            SW< [khelper]
   24 root            SW< [kblockd/0]
   27 root            SW< [kseriod]
   47 root            SW  [pdflush]
   48 root            SW  [pdflush]
   49 root            SW< [kswapd0]
   50 root            SW< [aio/0]
  579 root            SW< [mtdblockd]
 1720 root       2372 S   logger -s -p 6 -t  
 1721 root       2376 S   /bin/ash --login 
 1728 root       2384 S   syslogd -C16 
 1730 root       2364 S   klogd 
 1738 root       1120 S   /sbin/hotplug2 --override --persistent --max-children
 2003 root       2372 S   crond -c /etc/crontabs 
 2007 root       1916 S   /usr/sbin/dropbear -p 22 
 2019 quagga     2580 S   /usr/sbin/zebra -d 
 2024 quagga     3352 S   /usr/sbin/ospfd -d 
 2029 root       2296 S   /usr/sbin/watchquagga -d -z -T 60 -R /usr/sbin/quagga
 2036 root       2372 R   ps 
root@OpenWrt:/# 

And packages I have installed:

root@OpenWrt:/# ipkg list
admswconfig - 0.1-1 - 
base-files-adm5120-2.6 - 12-9632 - 
bridge - 1.0.6-1 - 
busybox - 1.8.2-1 - 
dhcp-relay - 3.0.6-1 - 
dropbear - 0.50-3 - 
hotplug2 - 0.9+r102-2 - 
iptables - 1.3.8-2 - 
kernel - 2.6.23.9-adm5120-1 - 
libgcc - 4.1.2-12 - 
libpcap - 0.9.4-1 - 
mtd - 6 - 
quagga - 0.98.6-1 - 
quagga-bgpd - 0.98.6-1 - 
quagga-libospf - 0.98.6-1 - 
quagga-libzebra - 0.98.6-1 - 
quagga-ospfd - 0.98.6-1 - 
tcpdump - 3.9.8-1 - 
uclibc - 0.9.28.2-12 - 
udevtrigger - 106-1 - 
Done.
root@OpenWrt:/# 

Attachments (0)

Change History (3)

comment:1 Changed 10 years ago by florian

  • Owner changed from developers to florian
  • Status changed from new to assigned

Seems like there is a bug in the network driver after some heavy load.

comment:2 Changed 10 years ago by florian

  • Resolution set to fixed
  • Status changed from assigned to closed

I could not reproduce the bug with rb112 and rb153 using iperf for some hours. The switch driver rewrite has probably fixed that issue.

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.