Modify

Opened 10 years ago

Closed 10 years ago

#2846 closed defect (fixed)

802.11b not working correctly on Atheros.

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Kamikaze 7.09
Component: base system Version:
Keywords: wifi atheros wi-fi 802.11b agmode madwifi Cc:

Description

Using: Kamikaze 7.09 and Meraki Mini (atheros-2.6)

The following configuration doesn't work correctly

/etc/config/wireless

config wifi-device      wifi0
        option type     'atheros'
        option channel  '1'
        option agmode '11b'
        option diversity        '1'
        option txantenna        ''
        option rxantenna        ''
        option disabled '0'

root@OpenWrt:~# iwconfig ath0
ath0      IEEE 802.11g  ESSID:"myAP"  Nickname:""

It would work in 802.11b, but it doesn't.
The next one works correctly:

The following configuration doesn't work correctly

/etc/config/wireless

config wifi-device      wifi0
        option type     'atheros'
        option channel  '0'
        option agmode '11b'
        option diversity        '1'
        option txantenna        ''
        option rxantenna        ''
        option disabled '0'

root@OpenWrt:~# iwconfig ath0
ath0      IEEE 802.11b  ESSID:"myAP"  Nickname:""

Is this a bug?

Attachments (0)

Change History (1)

comment:1 Changed 10 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

should be fixed with the latest madwifi-trunk merge

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.