Modify

Opened 10 years ago

Closed 8 years ago

Last modified 4 years ago

#2803 closed defect (obsolete)

problems with bridging on openwrt

Reported by: studioideasw@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: kernel Version: Kamikaze trunk
Keywords: Cc:

Description

creating a bridge, only the first port seem to work correctly.
brctl add bri0
ifconfig eth0 0.0.0.0 up
ifconfig eth1 0.0.0.0 up
brctl addif bri0 eth0
brctl addif bri0 eth1
ifconfig bri0 1.2.3.4/24
ifconfig bri0 up

On the port eth0 i see passing arp traffic and then icmp traffic. The port ping correctly.
On the port eth1 i see passing arp request and the corresponding arp reply. But is like the bridged port can't receive, so the arp request start again and so on.

This happen also with more than two ports.

I changed all the parameters regarding the time for topology change detection, and i checked that the learned-mac table was containing only the internal ethernet values before trying with the second port. I also deleted the arp entries on my computer.
One curious thing: when i connect solething to a bridged port the learned mac table change correctly, signaling the new mac on the correct port, but he can talk only if the port is the lowest of the bridge (ex: bridhing eth1, eth0 the port working is eth0. Bridging eth1, eth2 the port working is eth1).
I tried with stp enabled and disabled.

I esperienced the problem on a routerboard 133 and on a routerboard 532 (boards with more ethernet ports, but the problem happen also with wireless ports).
I tried changing the version of bridge-utils to 1.2, and after porting into the openwrt kernel the bridge source of new kernel 2.6.23 (is a bit different), but the problem remain.

Thanks a lot for help. Please reply also on my email.
Enrico Betti

Attachments (0)

Change History (2)

comment:1 Changed 8 years ago by spudz76

  • Resolution set to obsolete
  • Status changed from new to closed
  • Version set to Kamikaze trunk

[patchteam] Suspect member interfaces needed to be set promiscuous to obtain the expected result. Newer bridge utils probably do this automatically, as I have used bridging and not seen this issue, nor had to manually set interfaces promiscuous as they automatically were (IIRC). Therefore, closing this as obsolete - if the issue is still reproducible in a newer revision please open a new ticket.

comment:2 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.