Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#2797 closed defect (duplicate)

make fails on ADM5120

Reported by: jerryt1964@… Owned by: developers
Priority: normal Milestone:
Component: packages Version:
Keywords: Cc:

Description

I'm trying to build for the Infineon ADM5120 from the current release in trunk (3 Dec 2007) and I'm having the following errors. I have successfully compiled x86 targets and Broadcom targets from the same source. Any ideas?

[mchapman@repository trunk]$ make V=99
++ mkdir -p /home/mchapman/rb150/trunk/staging_dir/toolchain-_gcc4.1.2
++ cd /home/mchapman/rb150/trunk/staging_dir/toolchain-_gcc4.1.2
++ mkdir -p bin lib include stamp
Makefile:70: .mk: No such file or directory
make[6]: *** No rule to make target `.mk'.  Stop.
make[5]: *** [image-prereq] Error 2
make[4]: *** [prereq] Error 2
make[3]: *** [target/linux/prereq] Error 2
make[2]: *** [/home/mchapman/rb150/trunk/staging_dir//stamp/.target_prereq] Error 2
make[1]: *** [prereq] Error 2
make: *** [world] Error 2
[mchapman@repository trunk]$



Attachments (0)

Change History (3)

comment:1 Changed 10 years ago by juhosg

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #2623.

comment:2 follow-up: Changed 10 years ago by b.robert1984@…

I have the same issue:

++ mkdir -p /home/brobert/trunk/staging_dir/toolchain-_gcc4.1.2
++ cd /home/brobert/trunk/staging_dir/toolchain-_gcc4.1.2
++ mkdir -p bin lib include stamp
Makefile:83: .mk: No such file or directory
make[6]: *** No rule to make target `.mk'.  Stop.
make[5]: *** [image-prereq] Error 2
make[4]: *** [prereq] Error 2
make[3]: *** [target/linux/prereq] Error 2
make[2]: *** [/home/brobert/trunk/staging_dir//stamp/.target_prereq] Error 2
make[1]: *** [prereq] Error 2
make: *** [world] Error 2

Creating an empty .target_prereq solves this, and the build starts, but I'm not sure that this file will be empty (it is for brcm-2.4 for example).

comment:3 in reply to: ↑ 2 Changed 10 years ago by anonymous

sorry, i was too quick and haven't seen the other ticket.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.