Modify

Opened 10 years ago

Closed 10 years ago

Last modified 6 years ago

#2788 closed defect (fixed)

Fix lan/wan settings for Dell TrueMobile 2300 on Kamikaze

Reported by: oguzhane Owned by: juhosg
Priority: normal Milestone: Kamikaze 8.09 RC1
Component: packages Version:
Keywords: Cc:

Description

Previous fix for this on Changeset 9015 set the vlan configs. According to http://wiki.openwrt.org/OpenWrtDocs/Configuration#head-b62c144b9886b221e0c4b870edb0dd23a7b6acab

This device has a BCM5325MA2KQM switch and its lan is set on an actual interface (eth0) and wlan is on if eth1.

#### LAN configuration
config interface lan

option type bridge
option ifname "eth0"
option proto static
option ipaddr 192.168.1.1
option netmask 255.255.255.0

#### WAN configuration
config interface wan

option ifname "eth1"
option proto dhcp

Attachments (2)

truemobile_2300_fix_r11918.patch (2.0 KB) - added by juhosg 10 years ago.
truemobile_2300_2788.patch (2.1 KB) - added by anonymous 10 years ago.
juhosg's patch plus the vlan additions, tested and working on my TrueMobile 2300 V1

Download all attachments as: .zip

Change History (10)

comment:1 Changed 10 years ago by anonymous

It'd be nice if this got fixed completely for Kamikaze.

According to http://wiki.openwrt.org/OpenWrtDocs/Hardware/Dell/Truemobile2300#head-1ab18e9e75f0274bfc61289402c96bb4aca3d318, https://dev.openwrt.org/browser/trunk/target/linux/brcm-2.4/base-files/etc/init.d/netconfig#L69 should at least be

if (model == "Dell TrueMobile 2300") {
        c["lan_ifname"] = "eth0"
        c["wan_ifname"] = "eth1"
}

and remove changeset 9015's vlan additions/or fix them correctly since they don't seem to be needed?

comment:2 Changed 10 years ago by juhosg

  • Owner changed from developers to juhosg
  • Status changed from new to assigned

comment:3 follow-up: Changed 10 years ago by juhosg

  • Milestone set to Kamikaze 808 RC-1

Someone can try the attached patch?

Changed 10 years ago by juhosg

comment:4 in reply to: ↑ 3 ; follow-up: Changed 10 years ago by anonymous

Replying to juhosg:

Someone can try the attached patch?

Doesn't the TM2300V1 also need:

c["vlan0ports"] = "0 1 2 3 4 5u"
c["vlan1ports"] = ""

otherwise you'd still run into the VLAN problems noted at http://wiki.openwrt.org/OpenWrtDocs/Hardware/Dell/Truemobile2300#head-07817bd3f6db7a1798ef8e4fc16183352d09a201?

comment:5 in reply to: ↑ 4 Changed 10 years ago by juhosg

Replying to anonymous:

Doesn't the TM2300V1 also need:
...

Sorry i don't have a V1 hardware, to test it on. If you confirm that this setting is required, i will add it as well.

Changed 10 years ago by anonymous

juhosg's patch plus the vlan additions, tested and working on my TrueMobile 2300 V1

comment:6 Changed 10 years ago by juhosg

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed with [11935]. Thank you for the testing.

comment:7 Changed 6 years ago by Bastian Bittorf <bittorf@…>

for proofing, that it has nothing to to with the firewall,
for all above test the firewall was stopped and disabled.

root@dell:~ lsmod
root@ekuku-longshot-MESH:~ lsmod
Module                  Size  Used by    Tainted: G  
ath5k                 146546  0 
ath                    16729  1 ath5k
mac80211              275945  1 ath5k
cfg80211              150263  3 ath5k,ath,mac80211
compat                  1013  3 ath5k,mac80211,cfg80211
arc4                     848  2 
crypto_algapi          10876  1 arc4

comment:8 Changed 6 years ago by Bastian Bittorf <bittorf@…>

please delete last entry, it was a mistake/added to wrong ticket

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.