Modify

Opened 10 years ago

Closed 10 years ago

#2740 closed defect (invalid)

WRT54GL can be bricked permanently with wrong commands !!!

Reported by: wiedemann@… Owned by: developers
Priority: highest Milestone: Kamikaze 7.09
Component: base system Version:
Keywords: Cc:

Description

Hello,

we recently discovered a serious bug which is existend in 7.07 and 7.09 (tested and reproducable) maybe other releases, too.

If you log in to the System via ssh and issue the command "vi /sbin/init" which seems to have no sense the router gives "Segmentation fault". If you reboot the router after this procedure it can´t boot anymore and has to be reflashed.

Maybe there is damage to the flash by this procedure ?

Can anyone reproduce this issue, too ?

Severin Wiedemann

Attachments (0)

Change History (7)

comment:1 Changed 10 years ago by anonymous

had th same prob some time ago...

comment:2 Changed 10 years ago by florian

Though I understand it should not segfault while editing vi, do you really want to edit such file ? Does it segfault with other similar commands ?

comment:3 Changed 10 years ago by wiedemann@…

I didn´t try to edit other "binary" files via. It was just a mistake which led me to the problem described. The main problem is not the segmentation fault but the issue that the router image is damaged by that procedure so you can´t boot the router after this mistake anymore.
I will give it a try to edit other files via vi to see if it is the same problem with that.

comment:4 Changed 10 years ago by kevin@…

I suspect booting in failsafe mode would allow you to fix this

comment:5 Changed 10 years ago by anonymous

I had the same problem today. It can be fixed using failsafe:

  1. Press reset at the right moment to enter it:

http://wiki.openwrt.org/OpenWrtDocs/Troubleshooting

  1. telnet to router:

telnet 192.168.1.1

  1. mount jffs2:

/sbin/mount_root

  1. Delete busybox in jffs2 overlay blocking true busybox binary

rm /rom/jffs/bin/busybox

Reboot Router

comment:6 Changed 10 years ago by anonymous

IMHO being able to brick something with the wrong commands is a feature, not a bug! :)

comment:7 Changed 10 years ago by nbd

  • Resolution set to invalid
  • Status changed from new to closed

It's not bricked, since failsafe can bring it back.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.