Modify

Opened 10 years ago

Closed 10 years ago

#2731 closed defect (fixed)

Freeradius 1.1.6 package - Libtool header missing

Reported by: arne-jorgen@… Owned by: developers
Priority: normal Milestone: Kamikaze 7.09
Component: packages Version:
Keywords: Cc:

Description

I have had a compiler error on the Freeradius-1.1.6 package, and have patched the files freeradius-1.1.6/src/main/modules.c and freeradius-1.1.6/src/include/modpriv.h with the following:

#include "ltdl.h"

to

#include "../../libltdl/ltdl.h"

It now compiles without error.

I do not know if this is the correct way to fix this, or if it should be referenced externally in some way, so could someone please have a look at the correct way to do this and include it in the repository?

R

ajauberg

Attachments (1)

freeradius-ltdl.patch (1.2 KB) - added by netprince (at) vt (dot) edu 10 years ago.
patch to simplify original instructions

Download all attachments as: .zip

Change History (5)

comment:1 Changed 10 years ago by netprince (at) vt (dot) edu

confirmed on x86 trunk 10465

Changed 10 years ago by netprince (at) vt (dot) edu

patch to simplify original instructions

comment:2 Changed 10 years ago by anonymous

same problem on brcm2.4 trunk, netprince's patch fixed it

comment:3 Changed 10 years ago by anonymous

Looks like this is still needed even with 2.0.5, which the package should be updated to since 1.1.x is no longer being maintained.

comment:4 Changed 10 years ago by florian

  • Resolution set to fixed
  • Status changed from new to closed

Applied in [11917], thanks !

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.