Modify

Opened 10 years ago

Closed 10 years ago

Last modified 4 years ago

#2585 closed defect (fixed)

insmod /path/module.ko broken

Reported by: margrosoft@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version:
Keywords: Cc:

Description

An insmod of a module from a different location than the standard /lib/modules worked always by using the absolute path:

insmod /tmp/mymodule.ko

If I do this now with busybox 1.7, it does not work (It worked with 1.4). No error is displayed, but the module is also not loaded (checked with lsmod).

If I move my module to /lib/modules and then execute

insmod mymodule

it does work. Seems that the 470-insmod-search.patch breaks loading modules by specifying the absolute path. Without this patch the first version is working, but then all modules from /etc/modules.d/ are not loaded at startup.

Attachments (0)

Change History (2)

comment:1 Changed 10 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

fixed in [9428]

comment:2 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.