Modify

Opened 10 years ago

Closed 10 years ago

#2470 closed defect (duplicate)

bind-tools bind-dig bind-host etc packages depend on bind libraries

Reported by: milton.yates@… Owned by: florian
Priority: normal Milestone:
Component: packages Version:
Keywords: Cc:

Description

bind-tools, bind-dig and bind-host at least depend on bind libraries not present in these packages or in bind-server.

looks like there was once a bind-libs package but I don't see it anymore, my reading made me think you wanted to compile these packages static... but it's not the case:

# ldd /usr/bin/dig

liblwres.so.30 => not found
libdns.so.32 => not found
libbind9.so.30 => not found
libisccfg.so.30 => not found
libisc.so.32 => not found
libcrypto.so.0.9.8 => /usr/lib/libcrypto.so.0.9.8 (0x2aaed000)
libisccc.so.30 => not found
libnsl.so.0 => /lib/libnsl.so.0 (0x2ac2e000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x2ac6f000)
libc.so.0 => /lib/libc.so.0 (0x2acbe000)
libdl.so.0 => /lib/libdl.so.0 (0x2ad65000)
ld-uClibc.so.0 => /lib/ld-uClibc.so.0 (0x2aaa8000)

# ldd /usr/sbin/named-checkconf

libbind9.so.30 => not found
libisccfg.so.30 => not found
libdns.so.32 => not found
libisccc.so.30 => not found
libisc.so.32 => not found
libcrypto.so.0.9.8 => /usr/lib/libcrypto.so.0.9.8 (0x2aaed000)
libnsl.so.0 => /lib/libnsl.so.0 (0x2ac2e000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x2ac6f000)
libc.so.0 => /lib/libc.so.0 (0x2acbe000)
libdl.so.0 => /lib/libdl.so.0 (0x2ad65000)
ld-uClibc.so.0 => /lib/ld-uClibc.so.0 (0x2aaa8000)

Either one should make sure these packages compile static binaries, or one should provide the needed bind libraries.

I'll try to provide a fix, if I have the time, later today.

Attachments (0)

Change History (2)

comment:1 Changed 10 years ago by florian

  • Owner changed from developers to florian
  • Status changed from new to assigned

comment:2 Changed 10 years ago by florian

  • Resolution set to duplicate
  • Status changed from assigned to closed

Duplicate of #2454

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.