Modify

Opened 10 years ago

Closed 10 years ago

#2450 closed defect (fixed)

madwifi not working with dual band hardware (11a/11g)

Reported by: oryn@… Owned by: developers
Priority: normal Milestone:
Component: packages Version:
Keywords: Cc:

Description

Hi,
I have an asus wl500gp
I've removed the broadcom hardware in favor of atheros as intel support seems very lacking (but thats another story.)
It seems that due to a bug in the madwifi drivers you can't change band when the radio is turned on,
you have to turn it off first by setting the channel to 0 first.
I looked at your madwifi.sh script and have made changes
Also I think this is down to webif2 sometimes $txpwr is set to something silly so I fixed that too.

Regards
Jon Westgate
(0ryn)

ps heres the patch



--- madwifi.sh.old Sun Sep 30 10:49:28 2007

+++ madwifi.sh Sun Sep 30 10:48:16 2007

@@ -103,7 +103,9 @@

*a) agmode=11a;;

*) agmode=auto;;

esac

  • iwconfig "$ifname" channel "$channel" >/dev/null 2>/dev/null

+ # due to a bug in the madwifi driver you can't change band if the channel

+ # !=0 so lets set it to 0 before we change band

+ iwconfig "$ifname" channel "0" >/dev/null 2>/dev/null

ifconfig "$ifname" up

sleep 1

iwpriv "$ifname" mode "$agmode"

@@ -180,6 +182,9 @@

config_get txpwr "$vif" txpower

if [ -n "$txpwr" ]; then

+ #we have a bug here txpower is sometimes set to a silly value

+ if [ $txpwr -gt "18" ]; then txpwr=18; fi

+ if [ $txpwr -lt "0" ]; then txpwr=0; fi

iwconfig "$ifname" txpower "${txpwr%%.*}"

fi

Attachments (0)

Change History (5)

comment:1 Changed 10 years ago by anonymous

I hope this patch is NOT implemented.

I had problems before when the channel was set to 0. It caused my atheros wifi boards to end up in an indeterminate state. Since the patch to not set the channel to 0, my routers have been working reliably. Maybe there is an order of execution issue in the madwifi.sh?

The txpower can be greater than 18 for high power cards. I am currently using a txpower of 23 for my 200mw atheros cards. Can you give an example of the 'silly values'?

comment:2 Changed 10 years ago by bart.swinnen@…

On my Atheros platform 11a is not working when set to auto channel (0).
When I set agmode=11a and channel=0
the resulting channel is always 1 (2.412)

A fixed channel setting works fine. Only auto channel is causing problems.

comment:3 Changed 10 years ago by nbd

please try latest trunk

comment:4 Changed 10 years ago by anonymous

:S That is even worse now. In ap mode it keeps changing frequency all the time, even int 2.4GHz. The only way now to have a stable ap frequency is to select a valid frequency/channel otherwise it keeps changing the ap frequency.

Auto channel (0) is not working anymore for me.

comment:5 Changed 10 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

the root cause of this has been fixed in the newer versions based on madwifi-trunk

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.