Modify

Opened 10 years ago

Closed 10 years ago

#2440 closed defect (fixed)

Build system is broken

Reported by: berny156 at gmx.de Owned by: developers
Priority: normal Milestone: Kamikaze 8.09 RC1
Component: other Version:
Keywords: Cc:

Description

r9051 breaks build system:
https://dev.openwrt.org/changeset/9051/trunk#file4

Something is wrong with the line
ifeq ($(DUMP)$(if $(TARGET_BUILD)1),)

With this line there's only the default profile available. If I comment it out (together with the "endif") it works as expected.

Attachments (0)

Change History (6)

comment:1 Changed 10 years ago by florian

  • Milestone changed from Kamikaze 7.09 to 7.10?

comment:2 Changed 10 years ago by berny156 AT gmx.de

Fixed in r9099. Thanks!

comment:3 Changed 10 years ago by berny156 AT gmx.de

Oh no, it's not fixed. Now during menuconfig a profile can be selected, but there's no image generated for system LE ADM5120 and, profile generic.

comment:4 Changed 10 years ago by florian

  • Resolution set to worksforme
  • Status changed from new to closed

You have to remove the tmp/ directory and re-run menuconfig for it to work.

comment:5 Changed 10 years ago by anonymous

  • Resolution worksforme deleted
  • Status changed from closed to reopened

It still doesn't work for me.

I run a make distclean and started with menuconfig to create a fresh .config. The build process again ends with no image (and no error), anything else is there.

comment:6 Changed 10 years ago by juhosg

  • Resolution set to fixed
  • Status changed from reopened to closed

Fixed in [9113], thanks for reporting.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.