Modify

Opened 10 years ago

Closed 10 years ago

Last modified 3 years ago

#2434 closed defect (worksforme)

defective build/config after r8694

Reported by: dl4huf@… Owned by: developers
Priority: high Milestone:
Component: base system Version:
Keywords: Cc:

Description

With current Revision I can not build a new firmware.
(svn co https://svn.openwrt.org/openwrt/trunk")
Only with downgrade to r8693 it works.
(svn -r8693 update)

I have no target selection in "make menuconfig" .
Whats wrong ? I checkt this many times ....

With current Revision I have this output :

wrt:/home/tmp/trunk # make menuconfig FORCE=1
make[2]: *** No rule to make target `.config', needed by `/home/tmp/trunk/staging_dir/toolchain-_gcc/info.mk'.  Stop.
Collecting package info: package/nw802-2.4ERROR: please fix package/nw802-2.4/Makefile
Collecting package info: package/aodv-uuERROR: please fix package/aodv-uu/Makefile
Collecting package info: package/mtdERROR: please fix package/mtd/Makefile
Collecting package info: package/broadcom-diagERROR: please fix package/broadcom-diag/Makefile
Collecting package info: package/linux-uvcERROR: please fix package/linux-uvc/Makefile
Collecting package info: package/fuseERROR: please fix package/fuse/Makefile
Collecting package info: package/iptablesERROR: please fix package/iptables/Makefile
Collecting package info: package/shfsERROR: please fix package/shfs/Makefile
Collecting package info: package/ar7-atmERROR: please fix package/ar7-atm/Makefile
Collecting package info: package/base-filesERROR: please fix package/base-files/Makefile
Collecting package info: package/openswanERROR: please fix package/openswan/Makefile
Collecting package info: package/pcmcia-csERROR: please fix package/pcmcia-cs/Makefile
Collecting package info: package/broadcom-mmcERROR: please fix package/broadcom-mmc/Makefile
Collecting package info: package/switchERROR: please fix package/switch/Makefile
Collecting package info: package/kernelERROR: please fix package/kernel/Makefile
Collecting package info: package/bcm43xx-mac80211ERROR: please fix package/bcm43xx-mac80211/Makefile
Collecting package info: package/mac80211ERROR: please fix package/mac80211/Makefile
Collecting package info: package/rt61ERROR: please fix package/rt61/Makefile
Collecting package info: package/pppERROR: please fix package/ppp/Makefile
Collecting package info: package/ipsec-toolsERROR: please fix package/ipsec-tools/Makefile
Collecting package info: package/rt2570ERROR: please fix package/rt2570/Makefile
Collecting package info: package/acx-mac80211ERROR: please fix package/acx-mac80211/Makefile
Collecting package info: package/broadcom-wlERROR: please fix package/broadcom-wl/Makefile
Collecting package info: package/acxERROR: please fix package/acx/Makefile
Collecting package info: package/madwifiERROR: please fix package/madwifi/Makefile
Collecting package info: package/alsaERROR: please fix package/alsa/Makefile
Collecting package info: package/wlcompatERROR: please fix package/wlcompat/Makefile
Collecting package info: package/hostap-driverERROR: please fix package/hostap-driver/Makefile
Collecting package info: package/isakmpdERROR: please fix package/isakmpd/Makefile
Collecting package info: package/spca5xx-leERROR: please fix package/spca5xx-le/Makefile
Collecting package info: package/qc-usbERROR: please fix package/qc-usb/Makefile
Collecting package info: package/bridge-utilsERROR: please fix package/bridge-utils/Makefile
Collecting package info: package/rt2500ERROR: please fix package/rt2500/Makefile
Collecting package info: package/rt2x00ERROR: please fix package/rt2x00/Makefile
Collecting package info: package/fonera-mp3-drvERROR: please fix package/fonera-mp3-drv/Makefile
Collecting package info: package/gspcav1ERROR: please fix package/gspcav1/Makefile
Collecting package info: package/ov51x-jpegERROR: please fix package/ov51x-jpeg/Makefile
Collecting package info: package/strongswanERROR: please fix package/strongswan/Makefile
Collecting package info: package/nozomiERROR: please fix package/nozomi/Makefile
Collecting package info: package/zd1211-driverERROR: please fix package/zd1211-driver/Makefile
Collecting package info: package/ifenslaveERROR: please fix package/ifenslave/Makefile
Collecting package info: done
make[2]: *** No rule to make target `.config', needed by `/home/tmp/trunk/staging_dir/toolchain-_gcc/info.mk'.  Stop.
Collecting target info: target/linux/etraxERROR: please fix target/linux/etrax/Makefile
Collecting target info: target/linux/iop32xERROR: please fix target/linux/iop32x/Makefile
Collecting target info: target/linux/brcm-2.4ERROR: please fix target/linux/brcm-2.4/Makefile
Collecting target info: target/linux/amazonERROR: please fix target/linux/amazon/Makefile
Collecting target info: target/linux/x86ERROR: please fix target/linux/x86/Makefile
Collecting target info: target/linux/pxaERROR: please fix target/linux/pxa/Makefile
Collecting target info: target/linux/ar7ERROR: please fix target/linux/ar7/Makefile
Collecting target info: target/linux/magicboxERROR: please fix target/linux/magicbox/Makefile
Collecting target info: target/linux/avr32ERROR: please fix target/linux/avr32/Makefile
Collecting target info: target/linux/rb532ERROR: please fix target/linux/rb532/Makefile
Collecting target info: target/linux/umlERROR: please fix target/linux/uml/Makefile
Collecting target info: target/linux/sibyteERROR: please fix target/linux/sibyte/Makefile
Collecting target info: target/linux/amccERROR: please fix target/linux/amcc/Makefile
Collecting target info: target/linux/ixp4xxERROR: please fix target/linux/ixp4xx/Makefile
Collecting target info: target/linux/atherosERROR: please fix target/linux/atheros/Makefile
Collecting target info: target/linux/au1000ERROR: please fix target/linux/au1000/Makefile
Collecting target info: target/linux/rdcERROR: please fix target/linux/rdc/Makefile
Collecting target info: target/linux/adm5120ERROR: please fix target/linux/adm5120/Makefile
Collecting target info: target/linux/brcm63xxERROR: please fix target/linux/brcm63xx/Makefile
Collecting target info: target/linux/brcm47xxERROR: please fix target/linux/brcm47xx/Makefile
Collecting target info: target/linux/at91ERROR: please fix target/linux/at91/Makefile
Collecting target info: done
tmp/.config-target.in:1:warning: config symbol defined without type

tmp/.config-target.in:11:warning: config symbol defined without type

tmp/.config-package.in:81:warning: 'select' used by config symbol 'PACKAGE_qos-scripts' refer to undefined symbol 'PACKAGE_kmod-sched'
tmp/.config-package.in:82:warning: 'select' used by config symbol 'PACKAGE_qos-scripts' refer to undefined symbol 'PACKAGE_iptables-mod-filter'
tmp/.config-package.in:83:warning: 'select' used by config symbol 'PACKAGE_qos-scripts' refer to undefined symbol 'PACKAGE_iptables-mod-ipopt'
tmp/.config-package.in:84:warning: 'select' used by config symbol 'PACKAGE_qos-scripts' refer to undefined symbol 'PACKAGE_iptables-mod-conntrack'
tmp/.config-package.in:85:warning: 'select' used by config symbol 'PACKAGE_qos-scripts' refer to undefined symbol 'PACKAGE_iptables-mod-imq'
tmp/.config-package.in:195:warning: 'select' used by config symbol 'PACKAGE_comgt' refer to undefined symbol 'PACKAGE_chat'
tmp/.config-package.in:329:warning: 'select' used by config symbol 'PACKAGE_spca5xx-view' refer to undefined symbol 'PACKAGE_kmod-video-spca5xx-le'
tmp/.config-package.in:330:warning: 'select' used by config symbol 'PACKAGE_spca5xx-view' refer to undefined symbol 'PACKAGE_libpthread'
tmp/.config-package.in:555:warning: 'select' used by config symbol 'PACKAGE_arptables' refer to undefined symbol 'PACKAGE_kmod-arptables'


*** End of OpenWrt configuration.
*** Execute 'make' to build the OpenWrt or try 'make help'.

With "make clean V=99" I see :

make[1]: Entering directory `/home/tmp/trunk/'
rm -rf /home/tmp/trunk/build_dir/ /home/tmp/trunk/bin
make target/linux/clean
make[2]: Entering directory `/home/tmp/trunk'
make[3]: Entering directory `/home/tmp/trunktarget/linux'
/home/tmp/trunk/include/target.mk:80: *** missing `endif'.  Stop.
make[3]: Leaving directory `/home/tmp/trunk/target/linux'
make[2]: *** [target/linux/clean] Error 2
make[2]: Leaving directory `/home/tmp/trunk'
make[1]: *** [clean] Error 2
make[1]: Leaving directory `/home/tmp/trunk'
make: *** [clean] Error 2

Attachments (0)

Change History (10)

comment:1 Changed 10 years ago by juhosg

  • Component changed from packages to base system
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #2354. Please reopen the ticket if the method described here don't works.

comment:2 follow-up: Changed 10 years ago by anonymous

  • Resolution duplicate deleted
  • Status changed from closed to reopened

This methode dos not work.
The error is with a fresh checkout, no tmp/ and config to delete.

After the first run of "make menuconfig" I have a tmp but the menu is incomplete.
The errors like

Collecting package info: package/acxERROR: please fix package/acx/Makefile

comes only by the first run.

comment:3 Changed 10 years ago by juhosg

Simply it works for me:

[yuhi@idared openwrt]$ svn co https://svn.openwrt.org/openwrt/trunk ./tmp >/dev/null
[yuhi@idared openwrt]$ cd tmp
[yuhi@idared tmp]$ svn info
Path: .
URL: https://svn.openwrt.org/openwrt/trunk
Repository Root: https://svn.openwrt.org/openwrt
Repository UUID: 3c298f89-4303-0410-b956-a3cf2f4a3e73
Revision: 9045
Node Kind: directory
Schedule: normal
Last Changed Author: juhosg
Last Changed Rev: 9040
Last Changed Date: 2007-09-26 19:58:44 +0200 (sze, 26 szept 2007)
Properties Last Updated: 2007-09-27 13:00:45 +0200 (cs, 27 szept 2007)

[yuhi@idared tmp]$ make menuconfig
Checking 'working-make'... ok.
Checking 'case-sensitive-fs'... ok.
Checking 'working-gcc'... ok.
Checking 'working-g++'... ok.
Checking 'ncurses'... ok.
Checking 'zlib'... ok.
Checking 'gawk'... ok.
Checking 'bison'... ok.
Checking 'flex'... ok.
Checking 'unzip'... ok.
Checking 'bzip2'... ok.
Checking 'patch'... ok.
Checking 'perl'... ok.
Checking 'wget'... ok.
Checking 'gnutar'... ok.
Checking 'autoconf'... ok.
Checking 'non-root'... ok.
Collecting package info: doneing...enslaveivers11
Collecting target info: doneing...ux/at9147xx


*** End of OpenWrt configuration.
*** Execute 'make' to build the OpenWrt or try 'make help'.

[yuhi@idared tmp]$

What is the reason why you use 'FORCE=1'?

comment:4 in reply to: ↑ 2 Changed 10 years ago by nico

Replying to anonymous:

After the first run of "make menuconfig" I have a tmp but the menu is incomplete.
The errors like

Collecting package info: package/acxERROR: please fix package/acx/Makefile

Can you run the following

TOPDIR=$(pwd) make -C package/acx DUMP=1 V=99

and post the result?

comment:5 follow-up: Changed 10 years ago by dl4huf@…

The result (with a new fresh checkout) :

ronald@wrt:~/kamikaze/trunk> TOPDIR=$(pwd) make -C package/acx DUMP=1 V=99
make: Entering directory `/home/ronald/kamikaze/trunk/package/acx'
/home/ronald/kamikaze/trunk/include/target.mk:80: *** missing `endif'.  Stop.
make: Leaving directory `/home/ronald/kamikaze/trunk/package/acx'
ronald@wrt:~/kamikaze/trunk>

But it´s not the acx package.

ronald@wrt:~/kamikaze/trunk> TOPDIR=$(pwd) make -C package/base-files DUMP=1 V=99
make: Entering directory `/home/ronald/kamikaze/trunk/package/base-files'
/home/ronald/kamikaze/trunk/include/target.mk:80: *** missing `endif'.  Stop.
make: Leaving directory `/home/ronald/kamikaze/trunk/package/base-files'
ronald@wrt:~/kamikaze/trunk>

I can not found any noticeable error in include/target.mk .

comment:6 in reply to: ↑ 5 ; follow-up: Changed 10 years ago by dl4huf@…

The same with current revision 9063

wrt-hp:/home/trunk # make menuconfig DUMP=1 V=99
Checking 'non-root'... ok.
Checking 'working-make'... ok.
Checking 'case-sensitive-fs'... ok.
Checking 'working-gcc'... ok.
Checking 'working-g++'... ok.
Checking 'ncurses'... ok.
Checking 'zlib'... ok.
Checking 'gawk'... ok.
Checking 'bison'... ok.
Checking 'flex'... ok.
Checking 'unzip'... ok.
Checking 'bzip2'... ok.
Checking 'patch'... ok.
Checking 'perl'... ok.
Checking 'wget'... ok.
Checking 'gnutar'... ok.
Checking 'autoconf'... ok.
make[1]: Entering directory `/home/trunk/scripts/config'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/home/trunk/scripts/config'
make[2]: *** No rule to make target `.config', needed by `/home/trunk/staging_dir/toolchain-_gcc/info.mk'.  Stop.
Collecting package info: package/nw802-2.4ERROR: please fix package/nw802-2.4/Makefile
Collecting package info: package/aodv-uuERROR: please fix package/aodv-uu/Makefile
Collecting package info: package/mtdERROR: please fix package/mtd/Makefile
Collecting package info: package/broadcom-diagERROR: please fix package/broadcom

also the (false?) error in Line 82

wrt-hp:/home/trunk # TOPDIR=$(pwd) make -C package/acx DUMP=1 V=99
make: Entering directory `/home/trunk/package/acx'
/home/trunk/include/target.mk:82: *** missing `endif'.  Stop.
make: Leaving directory `/home/trunk/package/acx'

Im confused this is only by me. My system to old (SuSE 9.3)? Missing packages?

comment:7 in reply to: ↑ 6 Changed 10 years ago by dl4huf@…

Replying to dl4huf@web.de:

Im confused this is only by me. My system to old (SuSE 9.3)? Missing packages?

Solved, partial.

I use now Ubuntu 6.06 without problems.

thanks.

comment:8 Changed 10 years ago by blogic

try rm -rf tmp/

comment:9 Changed 10 years ago by blogic

  • Resolution set to worksforme
  • Status changed from reopened to closed

comment:10 Changed 3 years ago by riley@…

I know that this is a bit late, but I ran into this problem, and I'll leave my solution here in case anyone else needs it.

I'm using Debian make 4.0. When I downgrade to make 3.8.1-8 from Debian squeeze, the build works.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.