Modify

Opened 10 years ago

Closed 10 years ago

#2420 closed defect (fixed)

Sinus 154 DSL Basic SE with OpenWRT

Reported by: Axel Gembe Owned by: developers
Priority: normal Milestone:
Component: kernel Version:
Keywords: Cc: weil@…

Description

After much wrestling with the build system I am able to build a flashable image for the Sinus 154 which starts to boot using the loader from http://ar7-firmware.berlios.de/openwrt/svndiff.patch. It doesn't fully boot yet and I'm trying to find out what the problem is. This is what I'm getting:

===========================================================
 Sinus 154 DSL Basic SE Loader 0.65 build Jun 11 2004 14:57:56
                 Broad Net Technology, INC.
===========================================================
INTEL TE28F160C3-B bottom boot 16-bit mode found

Copying boot params.....DONE

Press any key to enter command mode ...
Flash Checking  Passed.

Unzipping program from bank 2...done
Try to find image for running...
Unzipping program from bank 3...doneargc = 0x943E0004
argv = 0x940E0004
arge = 0x943E0000

Launching kernel decompressor.
Kernel decompressor found data.
Kernel decompressor was successful ... launching kernel.
Linux version 2.6.22.4 (ago@agovm) (gcc version 4.1.2) #22 Sun Sep 23 02:28:25 E
DT 2007
CPU revision is: 00018448
TI AR7 (TNETD7300), ID: 0x0005, Revision: 0x57
Determined physical RAM map:
 memory: 01000000 @ 14000000 (usable)

When I put printks in arch/mips/kernel/setup.c in the print_memory_map function, before and after the loop, as well as in arch_mem_init after the call to print_memory_map, this is what im getting:

Determined physical RAM map:
in print_memory_map
 memory: 01000000 @ 14000000 (usable)
after print_memory_map loop

as you can see, it doesn't return from print_memory_map. If I rename print_memory_map to print_memory_map_real and put a function like this in there:

static void __init print_memory_map(void)
{
        print_memory_map_real();
        printk("test\n");
}

Then the test printk will be executed, but it still won't return from the function.

Any help is appreciated.

Attachments (0)

Change History (4)

comment:1 Changed 10 years ago by blogic

feel free to contribute such a device, so we can test it

without the hardware, there not much point guessing

comment:2 Changed 10 years ago by sw

Sinus 154 DSL Basic SE and the other AR7 based routers of the same family provide only 2 MiB of flash memory - a configuration which was not really supported by the official OpenWrt in the past.

Nevertheless, it works with OpenWrt r9321 and the latest patch from ar7-firmware.berlios.de, at least as good or bad as other AR7 routers which are all WiP (work in progress): smaller bugs in ethernet driver (bad locks, problems under high load), larger bugs in WLAN driver (bad locks, crashs with kernel 2.6.23).

I'm going to publish a new flashable image as soon as WLAN (acx-mac80211) works.

comment:3 Changed 10 years ago by anonymous

thanks for feedback,

closing ticket as the bug seems to be resolved in current trunk

comment:4 Changed 10 years ago by blogic

  • Resolution set to fixed
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.