Modify

Opened 10 years ago

Closed 10 years ago

Last modified 5 years ago

#2377 closed defect (fixed)

WARNING: at kernel/softirq.c:138 local_bh_enable() with r8765

Reported by: nabcore Owned by: matteo
Priority: low Milestone: Kamikaze 8.09 RC1
Component: kernel Version:
Keywords: Cc:

Description

On a DG834G(v2); seems to happen when the pppoa link is brought up:

Jan  1 00:01:17 Bunny user.warn kernel: WARNING: at kernel/softirq.c:138 local_bh_enable()
Jan  1 00:01:17 Bunny user.warn kernel: Call Trace:
Jan  1 00:01:17 Bunny user.warn kernel: [<941096ec>] dump_stack+0x8/0x34
Jan  1 00:01:17 Bunny user.warn kernel: [<9412908c>] local_bh_enable+0x50/0xa8
Jan  1 00:01:17 Bunny user.warn kernel: [<c00c44c0>] tn7atm_receive+0x154/0x200 [tiatm]
Jan  1 00:01:17 Bunny user.warn kernel: [<c00c254c>] tn7sar_process_unmatched_oam+0x2ac/0x34c [tiatm]

Attachments (1)

atm.diff (730 bytes) - added by nabcore 10 years ago.
nbd's suggested modification

Download all attachments as: .zip

Change History (17)

comment:1 Changed 10 years ago by florian

  • Owner changed from developers to matteo

comment:2 Changed 10 years ago by anonymous

cd ./trunk/build_dir/linux-ar7/sangam_atm-07.02.01.00
./trunk/toolchain_build_mipsel/gdb-6.3/gdb/gdb tiatm.ko


(gdb) l *(tn7sar_process_unmatched_oam+0x2ac/0x34c)
0x72a0 is in tn7sar_process_unmatched_oam (/scratch/openwrt/trunk/build_dir/linux-ar7/sangam_atm-07.02.01.00/tn7sar.c:531).
526     }
527
528     //#define PRTK_UNWANTED_CELLS_2_HOST  1
529
530     int tn7sar_process_unmatched_oam(FRAGLIST *frag_list, unsigned int frag_count, unsigned int packet_size, unsigned int mode)
531     {
532
533       FRAGLIST *local_list;
534       int i;
535       unsigned int atmHdr;

comment:3 Changed 10 years ago by GuidoSerra

i have the same problem and i'm working on it, how can i authenticate to the trac/wiki?

i already have access to wiki.openwrt.org as author of http://wiki.openwrt.org/OpenWrtDocs/Hardware/D-Link/DSL-524T

on mine, with the latest trunk/

registered device TI Avalanche SAR
Sangam detected
requesting firmware image "ar0700xx.bin"
avsar firmware released
tn7dsl_set_modulation : Setting mode to 0xffff
Creating new root folder avalanche in the proc for the driver stats 
Texas Instruments ATM driver: version:[7.02.01.00]
DSL in Sync
WARNING: at kernel/softirq.c:139 local_bh_enable()
Call Trace:
[<9410840c>] dump_stack+0x8/0x34
[<941296c0>] local_bh_enable+0x50/0xa8
[<c00fc4c0>] tn7atm_receive+0x154/0x200 [tiatm]
[<c00fa54c>] tn7sar_process_unmatched_oam+0x2ac/0x34c [tiatm]

tn7atm_close: closing 0.8.35.5
tn7sar_teardown_complete called for channel 0
ChannelTeardown returned rc = 0

comment:4 Changed 10 years ago by gserra@…

my email...

comment:5 Changed 10 years ago by oliver@…

The stacktrace is somewhat mangled for some reason, the real call path seems to be something like this from inspecting the code:

dump_stack
local_bh_enable
rcu_read_unlock_bh (macro)
ppp_input
pppoatm_push
tn7atm_receive
tn7dsl_clear_eoc_receive
tn7dsl_handle_interrupt
tn7atm_sar_irq

It is a WARN_ON_ONCE so it could well be happening all the time, we just only see it once.

comment:6 Changed 10 years ago by gserra@…

so, the adsl interface should work, right? because it does not obtaing the IP in my case... i thought it was for this bug...

comment:7 Changed 10 years ago by oliver@…

Yes it works fine here (D-Link DSL-502T) even with that warning. (Though I am beginning to suspect that the intermittent router hangs I see may be related).

comment:8 Changed 10 years ago by gserra@…

i should check if the problem is the carrier

anyway, mine is DSL-524T

comment:9 Changed 10 years ago by gserra@…

nope... the problem is not the carrier but the driver

i get the line but the ppp interface does not come up

i also have no atm0 interface... so? i binded the "ifup wan" to the eth1 interface which i suppose to be the adsl ones... but... i just can recreate the situation of the driver doing a kernel dump

i'm trying to make debugging doing printk() into the code... any better idea?

comment:10 Changed 10 years ago by oliver@…

If you can get a DSL carrier but you can't bring ppp up, it sounds more like a ppp configuration problem than a DSL driver problem. I think you might be chasing a red herring here as this WARNING is really about a potential deadlock issue, not a "it doesn't bring up ppp" issue.

comment:11 Changed 10 years ago by Wipster

I'm running a DSL-G604T on r9890 and I get the same warning after DSL Syncs -but- the internet comes up and everything runs fine.

When I ifdown wan and bring it up again everything gets loaded and no errors, it only seems to happen when DSL first goes into sync, as my DSL drops sync and re syncs without these errors happening.

comment:12 Changed 10 years ago by oliver@…

As I said above: it is a WARN_ON_ONCE so it could well be happening all the time, we just only see it once.

Changed 10 years ago by nabcore

nbd's suggested modification

comment:13 Changed 10 years ago by nabcore

Having tried nbd's suggested modification (patch attached), the issue still remains (r9763):

[42949417.930000] WARNING: at kernel/softirq.c:139 local_bh_enable()
[42949417.930000] Call Trace:
[42949417.930000] [<9410845c>] dump_stack+0x8/0x34
[42949417.930000] [<9412b9a8>] local_bh_enable+0x50/0xa8
[42949417.930000] [<c01254c0>] tn7atm_receive+0x154/0x200 [tiatm]
[42949417.930000] [<c012354c>] tn7sar_process_unmatched_oam+0x2ac/0x34c [tiatm]
[42949417.930000]

comment:14 Changed 10 years ago by anonymous

I'm also seeing the problem. Its an actiontec gt701 (svn 1/2/2008). DSL seems to be running fine though, ppp is also working using ifup wan. It hasn't hung yet, but I'm halfway expecting it to seeing that its a possible dealock issue.

comment:15 Changed 10 years ago by florian

  • Resolution set to fixed
  • Status changed from new to closed

Fixed with [10141].

comment:16 Changed 5 years ago by anonymous

Hi

I post this in here might helps. I get this in a linux distro called Dopra Linux, probably some Chinese stolen copy paste code based linux on my Huawei router:

BUG: at kernel/softirq.c:138 local_bh_enable()
[<c0028934>] (dump_stack+0x0/0x14) from [<c003b1fc>] (local_bh_enable+0x8c/0xac)
[<c003b170>] (local_bh_enable+0x0/0xac) from [<bf012e7c>] (nf_nat_cleanup_conntrack+0x54/0x60 [nf_nat])

r5 = C0A62860 r4 = C06F0478

[<bf012e28>] (nf_nat_cleanup_conntrack+0x0/0x60 [nf_nat]) from [<bf002480>] (destroy_conntrack+0xd0/0x1f4 [nf_conntrack])

r4 = C06F03A0

[<bf0023b0>] (destroy_conntrack+0x0/0x1f4 [nf_conntrack]) from [<c019be9c>] (kfree_skb+0xf0/0x144)

r4 = C2A33EA0

[<c019bdac>] (kfree_skb+0x0/0x144) from [<c019bf18>] (kfree_skb+0x28/0x4c)

r5 = 00000000 r4 = C1E1B000

[<c019bef0>] (kfree_skb+0x0/0x4c) from [<bf5a86a0>] (ath_txq_add_mcast+0x174/0x194 [ath_pci])
[<bf5a866c>] (ath_txq_add_mcast+0x140/0x194 [ath_pci]) from [<bf5a89b0>] (ath_node_reorderq_free+0xe8/0x514 [ath_pci])

r6 = C06C4320 r5 = C0513F00 r4 = 00002880

[<bf5a893c>] (ath_node_reorderq_free+0x74/0x514 [ath_pci]) from [<bf5ac9dc>] (ath_tx_comp_aggr+0xa2c/0x11b4 [ath_pci])

r6 = C0513F00 r5 = C1E1B000 r4 = FFC256E0

[<bf5abfb0>] (ath_tx_comp_aggr+0x0/0x11b4 [ath_pci]) from [<bf5ab0c4>] (owl_tx_processq+0x260/0x2dc [ath_pci])
[<bf5aae64>] (owl_tx_processq+0x0/0x2dc [ath_pci]) from [<bf5ab2b8>] (owl_tx_tasklet+0x94/0x29c [ath_pci])
[<bf5ab224>] (owl_tx_tasklet+0x0/0x29c [ath_pci]) from [<bf5a28fc>] (ath_tasklet+0xb4/0xf4 [ath_pci])
[<bf5a2848>] (ath_tasklet+0x0/0xf4 [ath_pci]) from [<c003b2e0>] (tasklet_action+0x64/0xc8)

r6 = C02DB9A0 r5 = C02DB9C4 r4 = 00000000

[<c003b27c>] (tasklet_action+0x0/0xc8) from [<c003afec>] (do_softirq+0x68/0xd0)

r6 = 0000000A r5 = C02DBA04 r4 = 00000001

[<c003af84>] (do_softirq+0x0/0xd0) from [<c003b450>] (irq_exit+0x44/0x4c)
[<c003b40c>] (irq_exit+0x0/0x4c) from [<c0024bf4>] (asm_do_IRQ+0x48/0x5c)
[<c0024bac>] (asm_do_IRQ+0x0/0x5c) from [<c0023870>] (irq_svc+0x30/0xa0)

r7 = C02FA6B4 r6 = 00000001 r5 = F4000000 r4 = FFFFFFFF

[<c0025398>] (default_idle+0x0/0x48) from [<c0025198>] (cpu_idle+0x34/0x50)
[<c0025164>] (cpu_idle+0x0/0x50) from [<c002316c>] (rest_init+0x24/0x2c)

r6 = C0020E28 r5 = C02D5DE8 r4 = C02E2764

[<c0023148>] (rest_init+0x0/0x2c) from [<c0008b08>] (start_kernel+0x204/0x2cc)
[<c0008904>] (start_kernel+0x0/0x2cc) from [<90008030>] (0x90008030)

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.