Modify

Opened 18 months ago

#23001 new defect

Some devices not able to access Internet over wi-fi while others can

Reported by: alexstan Owned by: developers
Priority: response-needed Milestone: Designated Driver (Trunk)
Component: base system Version: Trunk
Keywords: wireless, wi-fi, connectivity Cc:

Description

I've installed OpenWrt Designated Driver r49390 / LuCI Master (git-16.171.60975-65c7610) on a BT Home Hub V5 Type A but some devices cannot access the Internet over Wi-Fi whilst others can, I'm a bit stuck as to why though.
I have a Macbook Pro Mid 2009, iPhone 5S, Nokia Lumia 520 and Samsung Galaxy S2 that can connect to the Internet no problem, but Nexus 4 and Amazon Fire Stick connect to the LAN fine but cannot reach the Internet. This is with a default install and simply enabling the default Wi-Fi Openwrt open wireless network. I have only changed what is needed to connect to my ISP Sky Fibre in UK (Client ID ,Vendor ID, Mac Address and VLAN tag)

Here is my /etc/config/network:

config interface 'loopback'                                                                                                              
        option ifname 'lo'                                                                                                               
        option proto 'static'                                                                                                            
        option ipaddr '127.0.0.1'                                                                                                        
        option netmask '255.0.0.0'                                                                                                       
                                                                                                                                         
config globals 'globals'                                                                                                                 
        option ula_prefix 'fdf2:d840:1467::/48'
                                                                                                                                         
config atm-bridge 'atm'                                                                                                                  
        option vpi '1'                                                                                                                   
        option vci '32'                                                                                                                  
        option encaps 'llc'                                                                                                              
        option payload 'bridged'                                                                                                         
                                                                                                                                         
config dsl 'dsl'                                                                                                                         
        option annex 'a'                                                                                                                 
        option tone 'av'                                                                                                                 
        option xfer_mode 'ptm'                                                                                                           
                                                                                                                                         
config interface 'lan'                                                                                                                   
        option type 'bridge'                                                                                                             
        option ifname 'eth0.1'                                                                                                           
        option proto 'static'                                                                                                            
        option netmask '255.255.255.0'                                                                                                   
        option ip6assign '60'                                                                                                            
        option ipaddr '192.168.0.1'                                                                                                      
                                                                                                                                         
config device 'lan_dev'                                                                                                                  
        option name 'eth0.1'                                                                                                             
        option macaddr 'a0:1b:29:71:c8:46'                                                                                               
                                                                                                                                         
config interface 'wan'                                                                                                                   
        option ifname 'ptm0.101'                                                                                                         
        option _orig_ifname 'ptm0'                                                                                                       
        option _orig_bridge 'false'                                                                                                      
        option proto 'dhcp'                                                                                                              
        option hostname 'Sky'                                                                                                            
        option clientid MY_CLIENT_ID_HERE                                       
        option vendorid MY_VENDOR_ID_HERE                                                                          
        option macaddr MY_MAC_ADDRESS_HERE                                                                                         
                                                                                                                                         
config device 'wan_dev'                                                                                                                  
        option name 'ptm0'                                                                                                               
        option macaddr 'a0:1b:29:71:c8:47'                                                                                               
                                                                                                                                         
config interface 'wan6'                                                                                                                  
        option ifname 'pppoe-wan'                                                                                                        
        option proto 'dhcpv6'                                                                                                            
                                                                                                                                         
config switch                                                                                                                            
        option name 'switch0'                                                                                                            
        option reset '1'                                                                                                                 
        option enable_vlan '1'                                                                                                           
                                                                                                                                         
config switch_vlan                                                                                                                       
        option device 'switch0'                                                                                                          
        option vlan '1'                                                                                                                  
        option ports '0 1 2 4 6t'                                                                                                        
        option vid '1'  

And here is my logread output, you can see the Android device I'm having a problem with connect at the bottom with no errors:

Tue Aug  2 11:12:18 2016 kern.info kernel: [16359.875367] eth0: port 4 got link
Tue Aug  2 11:12:18 2016 daemon.info dnsmasq-dhcp[1604]: DHCPREQUEST(br-lan) 192.168.0.2 00:26:b0:e5:4c:1a 
Tue Aug  2 11:12:18 2016 daemon.info dnsmasq-dhcp[1604]: DHCPNAK(br-lan) 192.168.0.2 00:26:b0:e5:4c:1a address not available
Tue Aug  2 11:12:22 2016 daemon.info dnsmasq-dhcp[1604]: DHCPDISCOVER(br-lan) 00:26:b0:e5:4c:1a 
Tue Aug  2 11:12:22 2016 daemon.info dnsmasq-dhcp[1604]: DHCPOFFER(br-lan) 192.168.0.144 00:26:b0:e5:4c:1a 
Tue Aug  2 11:12:22 2016 daemon.info dnsmasq-dhcp[1604]: DHCPDISCOVER(br-lan) 00:26:b0:e5:4c:1a 
Tue Aug  2 11:12:22 2016 daemon.info dnsmasq-dhcp[1604]: DHCPOFFER(br-lan) 192.168.0.144 00:26:b0:e5:4c:1a 
Tue Aug  2 11:12:23 2016 daemon.info dnsmasq-dhcp[1604]: DHCPREQUEST(br-lan) 192.168.0.144 00:26:b0:e5:4c:1a 
Tue Aug  2 11:12:23 2016 daemon.info dnsmasq-dhcp[1604]: DHCPACK(br-lan) 192.168.0.144 00:26:b0:e5:4c:1a alexmbpro
Tue Aug  2 11:12:42 2016 daemon.notice netifd: Network device 'ptm0' link is up
Tue Aug  2 11:12:42 2016 daemon.notice netifd: VLAN 'ptm0.101' link is up
Tue Aug  2 11:12:42 2016 daemon.notice netifd: Interface 'wan' has link connectivity 
Tue Aug  2 11:12:42 2016 daemon.notice netifd: Interface 'wan' is setting up now
Tue Aug  2 11:12:42 2016 kern.warn kernel: [16383.694199] enter showtime
Tue Aug  2 11:12:42 2016 kern.warn kernel: [16383.702646] enter showtime
Tue Aug  2 11:12:42 2016 daemon.notice netifd: wan (10515): udhcpc: option -h NAME is deprecated, use -x hostname:NAME
Tue Aug  2 11:12:42 2016 daemon.notice netifd: wan (10515): udhcpc (v1.24.2) started
Tue Aug  2 11:12:42 2016 daemon.notice netifd: wan (10515): Sending discover...
Tue Aug  2 11:12:45 2016 daemon.notice netifd: wan (10515): Sending discover...
Tue Aug  2 11:12:48 2016 daemon.notice netifd: wan (10515): Sending discover...
Tue Aug  2 11:13:08 2016 daemon.info dnsmasq-dhcp[1604]: DHCPDISCOVER(br-lan) 18:af:61:cd:1b:fa 
Tue Aug  2 11:13:08 2016 daemon.info dnsmasq-dhcp[1604]: DHCPOFFER(br-lan) 192.168.0.210 18:af:61:cd:1b:fa 
Tue Aug  2 11:13:09 2016 daemon.info dnsmasq-dhcp[1604]: DHCPREQUEST(br-lan) 192.168.0.210 18:af:61:cd:1b:fa 
Tue Aug  2 11:13:09 2016 daemon.info dnsmasq-dhcp[1604]: DHCPACK(br-lan) 192.168.0.210 18:af:61:cd:1b:fa Alex-iPhone
Tue Aug  2 11:13:09 2016 daemon.notice netifd: wan (10515): Sending select for 94.194.31.41...
Tue Aug  2 11:13:09 2016 daemon.notice netifd: wan (10515): Lease of 94.194.31.41 obtained, lease time 3600
Tue Aug  2 11:13:10 2016 daemon.warn dnsmasq[1604]: no servers found in /tmp/resolv.conf.auto, will retry
Tue Aug  2 11:13:10 2016 daemon.notice netifd: Interface 'wan' is now up
Tue Aug  2 11:13:10 2016 daemon.info dnsmasq[1604]: reading /tmp/resolv.conf.auto
Tue Aug  2 11:13:10 2016 daemon.info dnsmasq[1604]: using local addresses only for domain lan
Tue Aug  2 11:13:10 2016 daemon.info dnsmasq[1604]: using nameserver 90.207.238.97#53
Tue Aug  2 11:13:10 2016 daemon.info dnsmasq[1604]: using nameserver 90.207.238.99#53
Tue Aug  2 11:13:10 2016 user.notice firewall: Reloading firewall due to ifup of wan (ptm0.101)
Tue Aug  2 11:14:22 2016 daemon.info dnsmasq-dhcp[1604]: DHCPREQUEST(br-lan) 192.168.0.114 c4:d6:55:41:26:60 
Tue Aug  2 11:14:22 2016 daemon.info dnsmasq-dhcp[1604]: DHCPACK(br-lan) 192.168.0.114 c4:d6:55:41:26:60 
Tue Aug  2 11:18:10 2016 authpriv.info dropbear[10949]: Child connection from 192.168.0.219:49441
Tue Aug  2 11:18:22 2016 authpriv.notice dropbear[10949]: Password auth succeeded for 'root' from 192.168.0.219:49441
Tue Aug  2 11:19:48 2016 daemon.info hostapd: wlan1: STA a8:16:b2:8d:17:e6 IEEE 802.11: authenticated
Tue Aug  2 11:19:48 2016 daemon.info hostapd: wlan1: STA a8:16:b2:8d:17:e6 IEEE 802.11: associated (aid 1)
Tue Aug  2 11:19:48 2016 daemon.info hostapd: wlan1: STA a8:16:b2:8d:17:e6 WPA: pairwise key handshake completed (RSN)
Tue Aug  2 11:19:51 2016 daemon.info dnsmasq-dhcp[1604]: DHCPDISCOVER(br-lan) a8:16:b2:8d:17:e6 
Tue Aug  2 11:19:51 2016 daemon.info dnsmasq-dhcp[1604]: DHCPOFFER(br-lan) 192.168.0.115 a8:16:b2:8d:17:e6 
Tue Aug  2 11:19:51 2016 daemon.info dnsmasq-dhcp[1604]: DHCPREQUEST(br-lan) 192.168.0.115 a8:16:b2:8d:17:e6 
Tue Aug  2 11:19:51 2016 daemon.info dnsmasq-dhcp[1604]: DHCPACK(br-lan) 192.168.0.115 a8:16:b2:8d:17:e6 android-d9b194c835b4dc5d
Tue Aug  2 11:20:11 2016 daemon.info hostapd: wlan1: STA a8:16:b2:8d:17:e6 WPA: group key handshake completed (RSN)

I previously had a TP-Link WDR740N running perfectly well and all devices could connect to that over Wi-Fi, so it may be a bug in the trunk version I am using. Incidentally, if I share the Macbook Internet connection from Ethernet to wi-fi both the Nexus 4 and Fire Stick connect to that and can use the Internet perfectly fine.

Attachments (0)

Change History (0)

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.