Modify

Opened 12 years ago

Closed 12 years ago

#229 closed enhancement (fixed)

Webif: align 'loading' page in centre as intended, convert to xhtml, beautify

Reported by: Stereo <openwrt@…> Owned by: developers
Priority: low Milestone: 1.0-rc5
Component: packages Version: 1.0
Keywords: webif Cc:

Description

This will make the silly 'loading' page align the text in the centre like intended, uses the colours of the webif and converts to valid xhtml for (hopefully) faster parsing by the browser.

Index: OpenWrt/package/webif/files/www/index.html
===================================================================
--- OpenWrt/package/webif/files/www/index.html	(revision 2867)
+++ OpenWrt/package/webif/files/www/index.html	(working copy)
@@ -1,10 +1,15 @@
-<html>
-	<head>
-		<meta http-equiv="refresh" content="0; URL=/cgi-bin/webif.sh" />
-	</head>
-	<body>
-		<div style="vertical-align: middle; text-align: center; height: 100%">
-			Redirecting to <a href="/cgi-bin/webif.sh">main page</a>...
-		</div>
-	</body>
-</html>
+<?xml version="1.0" encoding="utf-8"?>
+<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN" "http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">
+<html xmlns="http://www.w3.org/1999/xhtml">
+<head>
+<meta http-equiv="Content-type" content="text/html; charset=utf-8" />
+<meta http-equiv="refresh" content="0; URL=/cgi-bin/webif.sh" />
+<title>OpenWrt Administrative Console</title>
+</head>
+<body style="margin: 0pt auto; height:100%; color: #C3C4D2; background-color: #213242;">
+<div style="width: 100%; height: 100%; position: fixed; display: table;">
+<p style="display: table-cell; line-height: 4em; vertical-align: middle; text-align: center;">Welcome to OpenWrt<br />
+Opening <a style="color: inherit;" href="/cgi-bin/webif.sh">Administrative Console</a></p>
+</div>
+</body>
+</html>
\ No newline at end of file

Attachments (0)

Change History (1)

comment:1 Changed 12 years ago by florian

  • Resolution set to fixed
  • Status changed from new to closed

Corrected in r3051, thanks.

I just kept the original "redirecting to main page" because it is what it really does

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.