Modify

Opened 10 years ago

Closed 10 years ago

#2273 closed defect (worksforme)

WR 0.9: S35firewall script error

Reported by: openwrt@… Owned by: developers
Priority: normal Milestone:
Component: base system Version:
Keywords: Cc:

Description

The firewall init script (/etc/init.d/S35firewall) contains these two lines:

  iptables -t nat -A NEW -m limit --limit 50 --limit-burst 100 -j RETURN && \
        iptables -t nat -A NEW -j DROP

...which produce an error when the script is run:

root@foo:/etc$ /etc/init.d/S35firewall restart
iptables: No chain/target/match by that name

Commenting out the lines makes the error go away, but either way the intended functionality is not being achieved. I don't know if this error occurs on boot or only on restart (no serial console).

Attachments (0)

Change History (3)

comment:1 Changed 10 years ago by anonymous

The same lines occur in the current trunk in trunk/package/iptables/files/firewall.init, around line 110.

comment:2 Changed 10 years ago by florian

I cannot reproduce such errors with the default builds, so I gues sou slightly modified the iptables/kernel configuration ?

comment:3 Changed 10 years ago by florian

  • Resolution set to worksforme
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.