Modify

Opened 22 months ago

Last modified 21 months ago

#22249 new defect

Lantiq: Trunk fails to build r49218

Reported by: anonymous Owned by: developers
Priority: normal Milestone:
Component: packages Version: Trunk
Keywords: Cc:

Description

make[5]: Entering directory '/home/tom/openwrt/build_dir/target-mips_34kc+dsp_musl-1.1.14/linux-lantiq_xrx200/linux-4.4.7'

CHK include/config/kernel.release
CHK include/generated/uapi/linux/version.h
CHK include/generated/utsrelease.h
CHK include/generated/bounds.h
CHK include/generated/timeconst.h
CHK include/generated/asm-offsets.h
CALL scripts/checksyscalls.sh
CHK include/generated/compile.h
GENVDSO arch/mips/vdso/vdso-image.c

arch/mips/vdso/genvdso: 'arch/mips/vdso/vdso.so.dbg' already contains a '.MIPS.abiflags' section
arch/mips/vdso/Makefile:82: recipe for target 'arch/mips/vdso/vdso-image.c' failed
make[7]: * [arch/mips/vdso/vdso-image.c] Error 1
scripts/Makefile.build:403: recipe for target 'arch/mips/vdso' failed
make[6]:
* [arch/mips/vdso] Error 2
Makefile:943: recipe for target 'arch/mips' failed
make[5]: * [arch/mips] Error 2
make[5]: Leaving directory '/home/tom/openwrt/build_dir/target-mips_34kc+dsp_musl-1.1.14/linux-lantiq_xrx200/linux-4.4.7'
Makefile:25: recipe for target '/home/tom/openwrt/build_dir/target-mips_34kc+dsp_musl-1.1.14/linux-lantiq_xrx200/linux-4.4.7/.image' failed
make[4]:
* /home/tom/openwrt/build_dir/target-mips_34kc+dsp_musl-1.1.14/linux-lantiq_xrx200/linux-4.4.7/.image Error 2
make[4]: Leaving directory '/home/tom/openwrt/target/linux/lantiq'
Makefile:13: recipe for target 'install' failed
make[3]: * [install] Error 2
make[3]: Leaving directory '/home/tom/openwrt/target/linux'
target/Makefile:21: recipe for target 'target/linux/install' failed
make[2]:
* [target/linux/install] Error 2
make[2]: Leaving directory '/home/tom/openwrt'
target/Makefile:17: recipe for target '/home/tom/openwrt/staging_dir/target-mips_34kc+dsp_musl-1.1.14/stamp/.target_install' failed
make[1]: * /home/tom/openwrt/staging_dir/target-mips_34kc+dsp_musl-1.1.14/stamp/.target_install Error 2
make[1]: Leaving directory '/home/tom/openwrt'
/home/tom/openwrt/include/toplevel.mk:192: recipe for target 'world' failed
make:
* [world] Error 2

Attachments (0)

Change History (6)

comment:1 Changed 22 months ago by Hauke

You probably removed the patches deactivating vdso support. When I do so I also see this problem, but I have never seen it with an unmodified OpenWrt.

comment:2 Changed 22 months ago by mkresin

Had the same error and make dirclean fixed it.

comment:3 Changed 21 months ago by anonymous

delete build/$(platform)/$(target)/linux-4.4.7/arch/mips/vdso/vdso.so.dbg will fix the problem.

comment:4 Changed 21 months ago by anonymous

I Get the same problem @MT7621

comment:5 Changed 21 months ago by anonymous

I Get the same problem @MT7621

comment:6 Changed 21 months ago by anonymous

I get the same error @MT7620

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.