Modify

Opened 22 months ago

Last modified 22 months ago

#22239 new defect

WLAN is dropping some SSIDs

Reported by: kraut Owned by: developers
Priority: normal Milestone:
Component: packages Version: Trunk
Keywords: wifi ssid trunk Cc:

Description

I configured 3 SSIDs on 2,4GHz:

  • lanlegacy with wpa2-psk
  • lan with wpa2-eap
  • languest with wpa2-psk

In my setup i configured three TP-Link Archer C7 V2 (running trunk version r49166) the same way. After some time (4 hours) after reloading wifi, the device is dropping the ssid lan and languest, lanlegacy is still working. After using the command 'wifi', everything is fine for a while. In logread i see this:

Tue Apr 19 04:54:24 2016 daemon.notice netifd: Network device 'wlan1-2' link is down
Tue Apr 19 04:54:24 2016 kern.info kernel: [114780.854916] br-captive: port 2(wlan1-2) entered disabled state
Tue Apr 19 04:54:24 2016 kern.info kernel: [114780.864134] device wlan1-2 left promiscuous mode
Tue Apr 19 04:54:24 2016 kern.info kernel: [114780.868961] br-captive: port 2(wlan1-2) entered disabled state
Tue Apr 19 04:54:24 2016 kern.info kernel: [114780.881201] br-lan: port 4(wlan1-1) entered disabled state
Tue Apr 19 04:54:24 2016 kern.info kernel: [114780.899680] device wlan1-1 left promiscuous mode
Tue Apr 19 04:54:24 2016 kern.info kernel: [114780.904562] br-lan: port 4(wlan1-1) entered disabled state

This is the wireless config, which is exactly the same on all three devices, except the nasid:

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path 'platform/qca955x_wmac'
        option txpower '20'
        option channel 'auto'
        option htmode 'HT40'
        option country 'DE'

config wifi-iface
        option device 'radio0'
        option mode 'ap'
        option encryption 'psk2'
        option key 'psksecret'
        option ssid 'lanlegacy'
        option network 'lan'

config wifi-iface
        option device 'radio0'
        option mode 'ap'
        option ssid 'lan'
        option network 'lan'
        option encryption 'wpa2'
        option auth_port '1812'
        option auth_secret 'radiussecret'
        option auth_server '10.0.0.1'
        option nasid 'ap0'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11a'
        option path 'pci0000:01/0000:01:00.0'
        option txpower '20'
        option country 'DE'
        option channel 'auto'
        option htmode 'VHT80'

config wifi-iface
        option device 'radio0'
        option mode 'ap'
        option ssid 'languest'
        option network 'captive'
        option encryption 'psk2'
        option key 'psksecret'

config wifi-iface
        option device 'radio1'
        option mode 'ap'
        option ssid 'lan5G'
        option network 'lan'
        option encryption 'wpa2'
        option auth_server '10.0.0.1'
        option auth_port '1812'
        option auth_secret 'radiussecret'

Attachments (0)

Change History (7)

comment:1 Changed 22 months ago by anonymous

I can confirm that. Actually i'm seeing this for some time now on trunk, on 3 different routers.

Only the secondary, third... and so on SSIDs are dropped after a few hours, wlan0/1 always stays up.

I didn't find a real pattern yet, maybe it depends on the amount of traffic, but sometimes i think it's just random... enabling max. debugging messages for hostapd also didn't help.

And btw., it also doesn't matter if encryption is turned on or what kind of encryption i use.

comment:2 Changed 22 months ago by anonymous

do you ever get this drop on CC images?

comment:3 Changed 22 months ago by anonymous

no - i think it started after the last driver/hostapd version bump in january

(but as nobody else saw this behaviour [maybe nobody else uses more than one SSID?] i wanted to do some more debugging before reporting it, in case it's just PEBKAC :)

comment:4 Changed 22 months ago by kraut

Actually it's reproducable. The time is different, sometimes within 4 hours sometimes after 15 hours the SSIDs are dropping, only the first one is working. It's really a bad situation for me, because CC is also unusuable for me, because of a kerne bug with wrong udp checksum handling. I also tried to pin the radio on a fixed channel without auto function without success.

comment:5 Changed 22 months ago by kraut

By the way, it doesn't matter how much traffic goes through the ssid. I ran iperf3 in a loop and the ssid dropped after ~10 hours, the first one still worked like a charm.

comment:7 Changed 22 months ago by kraut

Nevermind, that patch is already included in r49166.

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.