Modify

Opened 22 months ago

Last modified 22 months ago

#22222 reopened defect

WAN on 1 Gbps using RP-PPPOE DOWN!!

Reported by: goldchang Owned by: developers
Priority: high Milestone:
Component: base system Version: Trunk
Keywords: RP-PPPOE, RGMII, 1 Gbps Cc:

Description

Hi,
I have a router with ramips MT7620A
Buffalo WHR-1166D specifically (On current trunk)
After ruling out some of the possibilities,
I found out that

RP-PPPOE have an issue on WAN working at 1 Gbps

Here are my tests

  1. 100Mbps with DHCP on wan OK
  2. 100Mbps with PPPOE on wan OK
  3. 1 Gbps with DHCP on wan seems OK!!!
  4. 1 Gbps with PPPOE on wan NOT OK!!!

I have tried full duplex and half duplex with ethtool but in vain

I searched some posts and also tried the following

  1. override setting wan mac address with

option macaddr '00:00:00:00:00:00'
NOPE!!

  1. Turn PPPD warning level to debug

option pppd_options 'debug'
(Pasted Below)

  1. ethtool eth0 shows the following message

Current message level: 0x000000ff (255)
drv probe link timer ifdown ifup rx_err tx_err

When WAN is on 1 Gbps with DHCP
Luci shows WAN's MAC address and TX RX packets
When WAN is on 1 Gbps with PPPOE
Luci shows NO MAC address and TX RX both 0 packets!!
(Screenshot pasted below)

The interesting fact is that it only failed with
WAN on 1 Gbps using RP-PPPOE

AND According to another post

https://forum.openwrt.org/viewtopic.php?id=50648

This issue seems to be reproduced on TP-Link TL-WR1043ND v2.1
which its SoC is Qualcomm Atheros QCA9558

So, could someone verify that is it a Software Issue (RP-PPPOE)
or a Hardware Issue?
Thanks!!

MT7620A Specs:
My Buffalo WHR-1166D has ramips MT7620A
with 4 FE & 2 RGMII
1 for CPU (switch)
&
1 for WAN (on port 5)

Which its DTS file
https://git.openwrt.org/?p=openwrt.git;a=blob;f=target/linux/ramips/dts/WSR-1166.dts;hb=HEAD
seems to be correct

LOGS:

System Log (with PPPD Debug Log):

kern.info kernel: [   77.303336] mtk_soc_eth 10100000.ethernet eth0: port 5 link up (1000Mbps/Full duplex)
daemon.debug pppd[2134]: Send PPPOE Discovery V1T1 PADI session 0x0 length 4
daemon.debug pppd[2134]:  dst ff:ff:ff:ff:ff:ff  src 00:00:00:00:00:00
daemon.debug pppd[2134]:  [service-name]
daemon.debug pppd[2134]: Send PPPOE Discovery V1T1 PADI session 0x0 length 4
daemon.debug pppd[2134]:  dst ff:ff:ff:ff:ff:ff  src 00:00:00:00:00:00
daemon.debug pppd[2134]:  [service-name]
daemon.warn pppd[2134]: Timeout waiting for PADO packets
daemon.err pppd[2134]: Unable to complete PPPoE Discovery
daemon.info pppd[2134]: Exit.
daemon.notice netifd: Interface 'wan' is now down
daemon.notice netifd: Interface 'wan' is setting up now
daemon.info pppd[2195]: Plugin rp-pppoe.so loaded.
daemon.info pppd[2195]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
daemon.notice pppd[2195]: pppd 2.4.7 started by root, uid 0
daemon.debug pppd[2195]: Send PPPOE Discovery V1T1 PADI session 0x0 length 4
daemon.debug pppd[2195]:  dst ff:ff:ff:ff:ff:ff  src 00:00:00:00:00:00
daemon.debug pppd[2195]:  [service-name]
daemon.debug pppd[2195]: Send PPPOE Discovery V1T1 PADI session 0x0 length 4
daemon.debug pppd[2195]:  dst ff:ff:ff:ff:ff:ff  src 00:00:00:00:00:00
daemon.debug pppd[2195]:  [service-name]
daemon.debug pppd[2195]: Send PPPOE Discovery V1T1 PADI session 0x0 length 4
daemon.debug pppd[2195]:  dst ff:ff:ff:ff:ff:ff  src 00:00:00:00:00:00
daemon.debug pppd[2195]:  [service-name]
daemon.warn pppd[2195]: Timeout waiting for PADO packets
daemon.err pppd[2195]: Unable to complete PPPoE Discovery
daemon.info pppd[2195]: Exit.

Kernel Log:

mtk_soc_eth 10100000.ethernet eth0: port 5 link up (1000Mbps/Full duplex)
br-lan: port 1(eth0.1) entered disabled state
device eth0.1 left promiscuous mode
br-lan: port 1(eth0.1) entered disabled state
IPv6: ADDRCONF(NETDEV_UP): eth0.1: link is not ready
device eth0 left promiscuous mode
8021q: adding VLAN 0 to HW filter on device eth0
device eth0 entered promiscuous mode
device eth0.1 entered promiscuous mode
br-lan: port 1(eth0.1) entered forwarding state
br-lan: port 1(eth0.1) entered forwarding state
br-lan: port 1(eth0.1) entered forwarding state

Ethtool Log:

Settings for eth0:
        Supported ports: [ TP MII ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Supported pause frame use: No
        Supports auto-negotiation: Yes
        Advertised link modes:  1000baseT/Full
        Advertised pause frame use: No
        Advertised auto-negotiation: No
        Speed: 1000Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 5
        Transceiver: external
        Auto-negotiation: off
        Current message level: 0x000000ff (255)
                               drv probe link timer ifdown ifup rx_err tx_err
        Link detected: yes

Screenshot when WAN on 1 Gbps using RP-PPPOE:

Attachments (0)

Change History (9)

comment:2 Changed 22 months ago by swalker

  • Resolution set to duplicate
  • Status changed from new to closed

comment:3 Changed 22 months ago by goldchang

  • Resolution duplicate deleted
  • Status changed from closed to reopened

comment:4 Changed 22 months ago by goldchang

TL;DR
WAN with PPPOE did not work on 1 Gbps

Did anyone managed to get PPPOE working on 1 Gbps?
on any platform (ramips, ar71xx, etc.)?

comment:5 Changed 22 months ago by anonymous

Working without any problems on atheros soc and power-pc (mpc85xx).

comment:6 Changed 22 months ago by anonymous

Same here OpenWrt Designated Driver r49162 4.4.6 Also a newer release with kernel 4.4.7
Will try a new trunk build of 4.4.7
Interface 'wan' is now down
Fri Apr 15 18:26:55 2016 daemon.notice netifd: Interface 'wan' is setting up now
Fri Apr 15 18:26:55 2016 daemon.info pppd[2089]: Plugin rp-pppoe.so loaded.
Fri Apr 15 18:26:55 2016 daemon.info pppd[2089]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Fri Apr 15 18:26:55 2016 daemon.notice pppd[2089]: pppd 2.4.7 started by root, uid 0
Fri Apr 15 18:26:55 2016 daemon.info pppd[2098]: Plugin rp-pppoe.so loaded.
Fri Apr 15 18:26:55 2016 daemon.info pppd[2098]: RP-PPPoE plugin version 3.8p compiled
I can't get it running here either. OpenWrt Designated Driver r49162 kernel 4.4.6
Or on 4.4.7 Will try a new trunk build.
against pppd 2.4.7
Fri Apr 15 18:26:55 2016 daemon.notice pppd[2098]: pppd 2.4.7 started by root, uid 0
Fri Apr 15 18:27:10 2016 daemon.warn pppd[2089]: Timeout waiting for PADO packets
Fri Apr 15 18:27:10 2016 daemon.err pppd[2089]: Unable to complete PPPoE Discovery
Fri Apr 15 18:27:10 2016 daemon.info pppd[2089]: Exit.
Fri Apr 15 18:27:10 2016 daemon.warn pppd[2098]: Timeout waiting for PADO packets
Fri Apr 15 18:27:10 2016 daemon.notice netifd: Interface 'wan6' is now down
Fri Apr 15 18:27:10 2016 daemon.notice netifd: Interface 'wan6' is setting up now
Fri Apr 15 18:27:10 2016 daemon.err pppd[2098]: Unable to complete PPPoE Discovery

comment:7 Changed 22 months ago by anonymous

WRT1900ac v1 it went from bad to worse Firmware VersionOpenWrt Designated Driver r49168 / LuCI Master (git-16.100.63971-9c77aea) Kernel Version4.4.7

If I save settings from a previous version using dhcp it runs fine but if I change to pppoe and reboot I can no longer access the modem I can ping hw but there is no wireless and luci bombs. The below is changing to pppoe and applying and clicking connect in luci.

Fri Apr 15 20:16:09 2016 kern.info kernel: [ 415.467634] mvneta f1074000.ethernet eth1: Link is Up - 1Gbps/Full - flow control off
Fri Apr 15 20:16:09 2016 kern.info kernel: [ 415.475530] IPv6: ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
Fri Apr 15 20:16:09 2016 daemon.notice netifd: Network device 'eth1' link is up
Fri Apr 15 20:16:09 2016 daemon.notice netifd: Interface 'wan6' has link connectivity
Fri Apr 15 20:16:09 2016 daemon.notice netifd: Interface 'wan' has link connectivity
Fri Apr 15 20:16:09 2016 daemon.notice netifd: Interface 'wan' is setting up now
Fri Apr 15 20:16:09 2016 daemon.info pppd[5942]: Plugin rp-pppoe.so loaded.
Fri Apr 15 20:16:09 2016 daemon.info pppd[5942]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Fri Apr 15 20:16:09 2016 daemon.notice pppd[5942]: pppd 2.4.7 started by root, uid 0
Fri Apr 15 20:16:25 2016 daemon.warn pppd[5942]: Timeout waiting for PADO packets
Fri Apr 15 20:16:25 2016 daemon.err pppd[5942]: Unable to complete PPPoE Discovery
Fri Apr 15 20:16:25 2016 daemon.info pppd[5942]: Exit.
Fri Apr 15 20:16:25 2016 daemon.notice netifd: Interface 'wan' is now down
Fri Apr 15 20:16:25 2016 daemon.notice netifd: Interface 'wan6' is disabled
Fri Apr 15 20:16:25 2016 daemon.notice netifd: Interface 'wan' is disabled
Fri Apr 15 20:17:25 2016 kern.err kernel: [ 490.918984] INFO: rcu_sched self-detected stall on CPU
Fri Apr 15 20:17:25 2016 kern.err kernel: [ 490.924181] 1-...: (6000 ticks this GP) idle=111/140000000000001/0 softirq=29919/29925 fqs=5993
Fri Apr 15 20:17:25 2016 kern.err kernel: [ 490.929036] INFO: rcu_sched detected stalls on CPUs/tasks:
Fri Apr 15 20:17:25 2016 kern.err kernel: [ 490.929058] 1-...: (6000 ticks this GP) idle=111/140000000000001/0 softirq=29919/29925 fqs=5993
Fri Apr 15 20:17:25 2016 kern.err kernel: [ 490.929070] (detected by 0, t=6002 jiffies, g=4872, c=4871, q=2719)
Fri Apr 15 20:17:25 2016 kern.info kernel: [ 490.929075] Task dump for CPU 1:
Fri Apr 15 20:17:25 2016 kern.info kernel: [ 490.929088] netifd R running 0 1320 1 0x00000002
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 490.929094] Backtrace:
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 490.929111] [<c0009e98>] (sys_trace_return_nosave) from [<00000000>] ( (null))
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 490.929120] Backtrace aborted due to bad frame pointer <ce933400>
Fri Apr 15 20:17:25 2016 kern.err kernel: [ 490.979554] (t=6007 jiffies g=4872 c=4871 q=2719)
Fri Apr 15 20:17:25 2016 kern.info kernel: [ 490.984485] Task dump for CPU 1:
Fri Apr 15 20:17:25 2016 kern.info kernel: [ 490.987733] netifd R running 0 1320 1 0x00000002
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 490.994151] Backtrace:
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 490.996630] [<c001d180>] (dump_backtrace) from [<c001d388>] (show_stack+0x18/0x1c)
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.004221] r7:c04f84c0 r6:80000193 r5:c05000c0 r4:ce933400
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.009960] [<c001d370>] (show_stack) from [<c004b158>] (sched_show_task+0xcc/0x100)
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.017729] [<c004b08c>] (sched_show_task) from [<c004c6e8>] (dump_cpu_task+0x40/0x44)
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.025666] r5:c05000c0 r4:00000001
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.029282] [<c004c6a8>] (dump_cpu_task) from [<c006cd6c>] (rcu_dump_cpu_stacks+0x80/0xb8)
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.037567] r5:c05000c0 r4:00000001
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.041182] [<c006ccec>] (rcu_dump_cpu_stacks) from [<c00703a4>] (rcu_check_callbacks+0x29c/0x754)
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.050163] r9:c05000c0 r8:c05000c0 r7:c04f8100 r6:0f8ed000 r5:c04f8100 r4:c04f4200
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.057996] [<c0070108>] (rcu_check_callbacks) from [<c007264c>] (update_process_times+0x40/0x6c)
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.066890] r10:c04f84f0 r9:00000000 r8:cfddeb00 r7:00000072 r6:4d1cd7e4 r5:00000000
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.074804] r4:ce933400
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.077373] [<c007260c>] (update_process_times) from [<c0081b80>] (tick_sched_timer+0x22c/0x270)
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.086182] r5:cdc75d40 r4:cfddec80
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.089799] [<c0081954>] (tick_sched_timer) from [<c00734e4>] (
hrtimer_run_queues+0x110/0x1dc)
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.098606] r10:c04f84f0 r9:00000000 r8:cfddeb00 r7:cfddeac0 r6:cfddeb0c r5:c04f1ac0
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.106518] r4:cfddec80
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.109076] [<c00733d4>] (hrtimer_run_queues) from [<c0073734>] (hrtimer_interrupt+0xbc/0x208)
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.117882] r10:ffffffff r9:00000003 r8:cfddeb38 r7:cfddeb58 r6:cfddead4 r5:c04f1ac0
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.125793] r4:cfddeac0
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.128353] [<c0073678>] (hrtimer_interrupt) from [<c027f3b0>] (armada_370_xp_timer_interrupt+0x38/0x40)
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.137857] r10:00000000 r9:00000000 r8:00000010 r7:cf80eb80 r6:c05040cc r5:cf805c00
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.145770] r4:cfde3780
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.148334] [<c027f378>] (armada_370_xp_timer_interrupt) from [<c0067e40>] (handle_percpu_devid_irq+0x74/0x8c)
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.158361] r5:cf805c00 r4:cfde3780
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.161975] [<c0067dcc>] (handle_percpu_devid_irq) from [<c0063c14>] (generic_handle_irq+0x2c/0x3c)
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.171045] r9:00000000 r8:cf808000 r7:00000001 r6:00000000 r5:00000000 r4:c04f1fd4
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.178877] [<c0063be8>] (generic_handle_irq) from [<c0063f2c>] (
handle_domain_irq+0xa0/0xb4)
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.187603] [<c0063e8c>] (handle_domain_irq) from [<c000946c>] (armada_370_xp_handle_irq+0x54/0xb8)
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.196845] r9:00000000 r8:c053ac90 r7:c053ac78 r6:cdc75d40 r5:c053ac90 r4:c00437b8
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.204678] [<c0009418>] (armada_370_xp_handle_irq) from [<c000a654>] (
irq_svc+0x54/0x70)
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.213051] Exception stack(0xcdc75d40 to 0xcdc75d88)
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.218123] 5d40: 00000000 cf83eca0 00000000 cf83eca0 c04fe240 cf83eca0 00000000 cf83e830
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.226326] 5d60: 00000000 00000000 00000000 cdc75d9c cf83eca4 cdc75d90 c00296e8 c00437b8
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.234525] 5d80: 60000013 ffffffff
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.238023] r10:00000000 r9:00000000 r8:00000000 r7:cdc75d74 r6:ffffffff r5:60000013
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.245935] r4:c00437b8 r3:c00296e8
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.249560] [<c004378c>] (raw_notifier_chain_register) from [<c00296e8>] (register_cpu_notifier+0x30/0x44)
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.259252] [<c00296b8>] (register_cpu_notifier) from [<c026f078>] (mvneta_open+0xb8/0x18c)
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.267625] r5:cf83ec80 r4:cf83e800
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.271249] [<c026efc0>] (mvneta_open) from [<c02a94b0>] (dev_open+0x94/0x110)
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.278665] r6:c04897a4 r5:00000001 r4:cf83e800
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.283338] [<c02a941c>] (
dev_open) from [<c02a9790>] (dev_change_flags+0xb8/0x148)
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.291362] r7:00001002 r6:00001003 r5:00000001 r4:cf83e800
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.297090] [<c02a96d8>] (
dev_change_flags) from [<c02a9840>] (dev_change_flags+0x20/0x50)
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.305549] r9:00000000 r8:00000000 r7:00001002 r6:cdc75ea4 r5:cf83e940 r4:cf83e800
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.313391] [<c02a9820>] (dev_change_flags) from [<c02bee7c>] (dev_ifsioc+0xd8/0x328)
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.321241] r9:00000000 r8:00000000 r7:c04897a4 r6:cdc75ea4 r5:cf83e800 r4:00008914
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.329077] [<c02beda4>] (dev_ifsioc) from [<c02bf950>] (dev_ioctl+0x808/0x8d4)
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.336405] r8:00000000 r7:bead3c34 r6:c04f83c8 r5:c0513dc0 r4:00008914
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.343199] [<c02bf148>] (dev_ioctl) from [<c028e918>] (sock_ioctl+0x2e4/0x2f8)
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.350528] r10:00000000 r9:cdc74000 r8:bead3c34 r7:00000005 r6:bead3c34 r5:fffffdfd
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.358441] r4:00008914
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.361003] [<c028e634>] (sock_ioctl) from [<c00de9e8>] (do_vfs_ioctl+0x6ac/0x6fc)
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.368592] r7:00000005 r6:ce8a7d80 r5:cf5619a0 r4:bead3c34
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.374322] [<c00de33c>] (do_vfs_ioctl) from [<c00dea74>] (SyS_ioctl+0x3c/0x64)
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.381650] r10:00000000 r9:cdc74000 r8:bead3c34 r7:00008914 r6:ce8a7d80 r5:00000005
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.389562] r4:ce8a7d80
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.392120] [<c00dea38>] (SyS_ioctl) from [<c0009ce0>] (ret_fast_syscall+0x0/0x3c)
Fri Apr 15 20:17:25 2016 kern.warn kernel: [ 491.399708] r9:cdc74000 r8:c0009ea4 r7:00000036 r6:0003a418 r5:0003a440 r4:00001003
Fri Apr 15 20:20:25 2016 kern.err kernel: [ 670.971033] INFO: rcu_sched self-detected stall on CPU
Fri Apr 15 20:20:25 2016 kern.err kernel: [ 670.976232] 1-...: (23958 ticks this GP) idle=111/140000000000001/0 softirq=29919/29925 fqs=23947
Fri Apr 15 20:20:25 2016 kern.err kernel: [ 670.981082] INFO: rcu_sched detected stalls on CPUs/tasks:
Fri Apr 15 20:20:25 2016 kern.err kernel: [ 670.981104] 1-...: (23958 ticks this GP) idle=111/140000000000001/0 softirq=29919/29925 fqs=23947
Fri Apr 15 20:20:25 2016 kern.err kernel: [ 670.981116] (detected by 0, t=24007 jiffies, g=4872, c=4871, q=5692)
Fri Apr 15 20:20:25 2016 kern.info kernel: [ 670.981121] Task dump for CPU 1:
Fri Apr 15 20:20:25 2016 kern.info kernel: [ 670.981135] netifd R running 0 1320 1 0x00000002
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 670.981141] Backtrace:
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 670.981158] [<c0009e98>] (sys_trace_return_nosave) from [<00000000>] ( (null))
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 670.981167] Backtrace aborted due to bad frame pointer <ce933400>
Fri Apr 15 20:20:25 2016 kern.err kernel: [ 671.032043] (t=24012 jiffies g=4872 c=4871 q=5692)
Fri Apr 15 20:20:25 2016 kern.info kernel: [ 671.037061] Task dump for CPU 1:
Fri Apr 15 20:20:25 2016 kern.info kernel: [ 671.040309] netifd R running 0 1320 1 0x00000002
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.046724] Backtrace:
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.049204] [<c001d180>] (dump_backtrace) from [<c001d388>] (show_stack+0x18/0x1c)
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.056795] r7:c04f84c0 r6:80000193 r5:c05000c0 r4:ce933400
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.062533] [<c001d370>] (show_stack) from [<c004b158>] (sched_show_task+0xcc/0x100)
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.070302] [<c004b08c>] (sched_show_task) from [<c004c6e8>] (dump_cpu_task+0x40/0x44)
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.078239] r5:c05000c0 r4:00000001
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.081856] [<c004c6a8>] (dump_cpu_task) from [<c006cd6c>] (rcu_dump_cpu_stacks+0x80/0xb8)
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.090141] r5:c05000c0 r4:00000001
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.093756] [<c006ccec>] (rcu_dump_cpu_stacks) from [<c00703a4>] (rcu_check_callbacks+0x29c/0x754)
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.102737] r9:c05000c0 r8:c05000c0 r7:c04f8100 r6:0f8ed000 r5:c04f8100 r4:c04f4200
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.110570] [<c0070108>] (rcu_check_callbacks) from [<c007264c>] (update_process_times+0x40/0x6c)
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.119465] r10:c04f84f0 r9:00000000 r8:cfddeb00 r7:0000009c r6:38edd791 r5:00000000
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.127376] r4:ce933400
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.129945] [<c007260c>] (update_process_times) from [<c0081b80>] (tick_sched_timer+0x22c/0x270)
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.138752] r5:cdc75d40 r4:cfddec80
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.142369] [<c0081954>] (tick_sched_timer) from [<c00734e4>] (
hrtimer_run_queues+0x110/0x1dc)
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.151176] r10:c04f84f0 r9:00000000 r8:cfddeb00 r7:cfddeac0 r6:cfddeb0c r5:c04f1ac0
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.159088] r4:cfddec80
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.161646] [<c00733d4>] (hrtimer_run_queues) from [<c0073734>] (hrtimer_interrupt+0xbc/0x208)
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.170454] r10:ffffffff r9:00000003 r8:cfddeb38 r7:cfddeb58 r6:cfddead4 r5:c04f1ac0
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.178367] r4:cfddeac0
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.180927] [<c0073678>] (hrtimer_interrupt) from [<c027f3b0>] (armada_370_xp_timer_interrupt+0x38/0x40)
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.190432] r10:00000000 r9:00000000 r8:00000010 r7:cf80eb80 r6:c05040cc r5:cf805c00
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.198344] r4:cfde3780
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.200909] [<c027f378>] (armada_370_xp_timer_interrupt) from [<c0067e40>] (handle_percpu_devid_irq+0x74/0x8c)
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.210937] r5:cf805c00 r4:cfde3780
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.214551] [<c0067dcc>] (handle_percpu_devid_irq) from [<c0063c14>] (generic_handle_irq+0x2c/0x3c)
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.223620] r9:00000000 r8:cf808000 r7:00000001 r6:00000000 r5:00000000 r4:c04f1fd4
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.231452] [<c0063be8>] (generic_handle_irq) from [<c0063f2c>] (
handle_domain_irq+0xa0/0xb4)
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.240178] [<c0063e8c>] (handle_domain_irq) from [<c000946c>] (armada_370_xp_handle_irq+0x54/0xb8)
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.249420] r9:00000000 r8:c053ac90 r7:c053ac78 r6:cdc75d40 r5:c053ac90 r4:c00437a8
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.257253] [<c0009418>] (armada_370_xp_handle_irq) from [<c000a654>] (
irq_svc+0x54/0x70)
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.265627] Exception stack(0xcdc75d40 to 0xcdc75d88)
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.270698] 5d40: 00000000 cf83eca0 00000000 cf83eca0 c04fe240 cf83eca0 00000000 cf83e830
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.278902] 5d60: 00000000 00000000 00000000 cdc75d9c cf83eca4 cdc75d90 c00296e8 c00437a8
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.287102] 5d80: a0000013 ffffffff
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.290599] r10:00000000 r9:00000000 r8:00000000 r7:cdc75d74 r6:ffffffff r5:a0000013
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.298515] r4:c00437a8 r3:c00296e8
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.302138] [<c004378c>] (raw_notifier_chain_register) from [<c00296e8>] (register_cpu_notifier+0x30/0x44)
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.311831] [<c00296b8>] (register_cpu_notifier) from [<c026f078>] (mvneta_open+0xb8/0x18c)
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.320204] r5:cf83ec80 r4:cf83e800
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.323829] [<c026efc0>] (mvneta_open) from [<c02a94b0>] (dev_open+0x94/0x110)
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.331245] r6:c04897a4 r5:00000001 r4:cf83e800
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.335917] [<c02a941c>] (
dev_open) from [<c02a9790>] (dev_change_flags+0xb8/0x148)
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.343942] r7:00001002 r6:00001003 r5:00000001 r4:cf83e800
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.349672] [<c02a96d8>] (
dev_change_flags) from [<c02a9840>] (dev_change_flags+0x20/0x50)
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.358131] r9:00000000 r8:00000000 r7:00001002 r6:cdc75ea4 r5:cf83e940 r4:cf83e800
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.365975] [<c02a9820>] (dev_change_flags) from [<c02bee7c>] (dev_ifsioc+0xd8/0x328)
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.373826] r9:00000000 r8:00000000 r7:c04897a4 r6:cdc75ea4 r5:cf83e800 r4:00008914
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.381658] [<c02beda4>] (dev_ifsioc) from [<c02bf950>] (dev_ioctl+0x808/0x8d4)
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.388986] r8:00000000 r7:bead3c34 r6:c04f83c8 r5:c0513dc0 r4:00008914
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.395784] [<c02bf148>] (dev_ioctl) from [<c028e918>] (sock_ioctl+0x2e4/0x2f8)
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.403112] r10:00000000 r9:cdc74000 r8:bead3c34 r7:00000005 r6:bead3c34 r5:fffffdfd
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.411025] r4:00008914
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.413586] [<c028e634>] (sock_ioctl) from [<c00de9e8>] (do_vfs_ioctl+0x6ac/0x6fc)
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.421176] r7:00000005 r6:ce8a7d80 r5:cf5619a0 r4:bead3c34
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.426903] [<c00de33c>] (do_vfs_ioctl) from [<c00dea74>] (SyS_ioctl+0x3c/0x64)
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.434231] r10:00000000 r9:cdc74000 r8:bead3c34 r7:00008914 r6:ce8a7d80 r5:00000005
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.442142] r4:ce8a7d80
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.444699] [<c00dea38>] (SyS_ioctl) from [<c0009ce0>] (ret_fast_syscall+0x0/0x3c)
Fri Apr 15 20:20:25 2016 kern.warn kernel: [ 671.452288] r9:cdc74000 r8:c0009ea4 r7:00000036 r6:0003a418 r5:0003a440 r4:00001003


comment:8 Changed 22 months ago by goldchang

Thanks for all your replies
You can also follow up on the thread that I opened

https://forum.openwrt.org/viewtopic.php?id=64188

I have found some previous tickets that might help

Additionally,

Maybe using tcpdump to capture PADI & PADO packets
Can show what's really going wrong

comment:9 Changed 22 months ago by anonymous

Can somebody confirm when if this problem has been resolved? I got identical issues (mentioned above) with latest stable Calmer Chaos 15.5.1 on WRT 1900ACS

Add Comment

Modify Ticket

Action
as reopened .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.