Modify

#22218 closed defect (duplicate)

WAN on 1 Gbps using RP-PPPOE

Reported by: goldchang Owned by: developers
Priority: high Milestone:
Component: base system Version: Trunk
Keywords: RP-PPPOE, RGMII, 1 Gbps Cc:

Description

Hi,
I have a router with ramips MT7620A
Buffalo WHR-1166D specifically (On current trunk)
After ruling out some of the possiblilties,
I found out that

RP-PPPOE have an issue on WAN working at 1 Gbps

Here are my tests

  1. 100Mbps with DHCP on wan OK
  2. 100Mbps with PPPOE on wan OK
  3. 1 Gbps with DHCP on wan seems OK!!!
  4. 1 Gbps with PPPOE on wan NOT OK!!!

I have tried full duplex and half duplex with ethtool but in vain

I searched some posts and also tried the following

  1. override setting wan mac address with

option macaddr '00:00:00:00:00:00'
NOPE!!

  1. Turn PPPD warning level to debug

option pppd_options 'debug'
(Pasted Below)

  1. ethtool eth0 shows the following message

Current message level: 0x000000ff (255)
drv probe link timer ifdown ifup rx_err tx_err

When WAN is on 1 Gbps with DHCP
Luci shows WAN's MAC address and TX RX packets
When WAN is on 1 Gbps with PPPOE
Luci shows NO MAC address and TX RX both 0 packets!!
(Screenshot pasted below)

The interesting fact is that it only failed with
WAN on 1 Gbps using RP-PPPOE

AND According to another post

[url]https://forum.openwrt.org/viewtopic.php?id=50648[/url]

This issue seems to be reproduced on TP-Link TL-WR1043ND v2.1
which its SoC is Qualcomm Atheros QCA9558

So, could someone verify that is it a Software Issue (RP-PPPOE)
or a Hardware Issue?
Thanks!!

MT7620A Specs:
My Buffalo WHR-1166D has ramips MT7620A
with 4 FE & 2 RGMII
1 for CPU (switch)
&
1 for WAN (on port 5)

Which its DTS file
[url]https://git.openwrt.org/?p=openwrt.git;a=blob;f=target/linux/ramips/dts/WSR-1166.dts;hb=HEAD[/url]
seems to be correct

LOGS:

System Log (with PPPD Debug Log):

kern.info kernel: [   77.303336] mtk_soc_eth 10100000.ethernet eth0: port 5 link up (1000Mbps/Full duplex)
daemon.debug pppd[2134]: Send PPPOE Discovery V1T1 PADI session 0x0 length 4
daemon.debug pppd[2134]:  dst ff:ff:ff:ff:ff:ff  src 00:00:00:00:00:00
daemon.debug pppd[2134]:  [service-name]
daemon.debug pppd[2134]: Send PPPOE Discovery V1T1 PADI session 0x0 length 4
daemon.debug pppd[2134]:  dst ff:ff:ff:ff:ff:ff  src 00:00:00:00:00:00
daemon.debug pppd[2134]:  [service-name]
daemon.warn pppd[2134]: Timeout waiting for PADO packets
daemon.err pppd[2134]: Unable to complete PPPoE Discovery
daemon.info pppd[2134]: Exit.
daemon.notice netifd: Interface 'wan' is now down
daemon.notice netifd: Interface 'wan' is setting up now
daemon.info pppd[2195]: Plugin rp-pppoe.so loaded.
daemon.info pppd[2195]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
daemon.notice pppd[2195]: pppd 2.4.7 started by root, uid 0
daemon.debug pppd[2195]: Send PPPOE Discovery V1T1 PADI session 0x0 length 4
daemon.debug pppd[2195]:  dst ff:ff:ff:ff:ff:ff  src 00:00:00:00:00:00
daemon.debug pppd[2195]:  [service-name]
daemon.debug pppd[2195]: Send PPPOE Discovery V1T1 PADI session 0x0 length 4
daemon.debug pppd[2195]:  dst ff:ff:ff:ff:ff:ff  src 00:00:00:00:00:00
daemon.debug pppd[2195]:  [service-name]
daemon.debug pppd[2195]: Send PPPOE Discovery V1T1 PADI session 0x0 length 4
daemon.debug pppd[2195]:  dst ff:ff:ff:ff:ff:ff  src 00:00:00:00:00:00
daemon.debug pppd[2195]:  [service-name]
daemon.warn pppd[2195]: Timeout waiting for PADO packets
daemon.err pppd[2195]: Unable to complete PPPoE Discovery
daemon.info pppd[2195]: Exit.

Kernel Log:

mtk_soc_eth 10100000.ethernet eth0: port 5 link up (1000Mbps/Full duplex)
br-lan: port 1(eth0.1) entered disabled state
device eth0.1 left promiscuous mode
br-lan: port 1(eth0.1) entered disabled state
IPv6: ADDRCONF(NETDEV_UP): eth0.1: link is not ready
device eth0 left promiscuous mode
8021q: adding VLAN 0 to HW filter on device eth0
device eth0 entered promiscuous mode
device eth0.1 entered promiscuous mode
br-lan: port 1(eth0.1) entered forwarding state
br-lan: port 1(eth0.1) entered forwarding state
br-lan: port 1(eth0.1) entered forwarding state

Ethtool Log:

Settings for eth0:
        Supported ports: [ TP MII ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Supported pause frame use: No
        Supports auto-negotiation: Yes
        Advertised link modes:  1000baseT/Full
        Advertised pause frame use: No
        Advertised auto-negotiation: No
        Speed: 1000Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 5
        Transceiver: external
        Auto-negotiation: off
        Current message level: 0x000000ff (255)
                               drv probe link timer ifdown ifup rx_err tx_err
        Link detected: yes

Screenshot when WAN on 1 Gbps using RP-PPPOE:

Attachments (0)

Change History (4)

comment:2 Changed 22 months ago by goldchang

Please close as duplicate tickets
Accidentally happened because of unable to upload image (Trac filtered as spam)

comment:3 Changed 22 months ago by goldchang

@swalker or other admins
Could you close this ticket,
As I have updated and fixed typo on another ticket
Thanks!

Last edited 22 months ago by goldchang (previous) (diff)

comment:4 Changed 22 months ago by swalker

  • Resolution set to duplicate
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.