Modify

Opened 22 months ago

Last modified 18 months ago

#22212 new defect

Cannot install openvswitch on Chaos Calmer 15.05.1

Reported by: ericribas Owned by: developers
Priority: normal Milestone:
Component: packages Version: Chaos Calmer 15.05
Keywords: openvswitch, kmod-openvswitch, Cc:

Description

I'm trying to install openvswitch but this happens:

root@OpenWrt:~# opkg install openvswitch
Installing openvswitch (2.3.90-58be9c9fd732b5bdd3d4c2e9b8cc2313f570094d) to root...
Downloading http://downloads.openwrt.org/chaos_calmer/15.05.1/ar71xx/generic/packages/packages/openvswitch_2.3.90-58be9c9fd732b5bdd3d4c2e9b8cc2313f570094d_ar71xx.ipk.
Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for openvswitch:
  • kernel (= 3.18.21-1-3d4bd113f3f10b8986a142b8792db9c5) *
  • opkg_install_cmd: Cannot install package openvswitch.

root@OpenWrt:~#

The same happens when i try to install manually the dependencies:

root@OpenWrt:~# opkg install kmod-openvswitch
Installing kmod-openvswitch (3.18.21+2.3.90-58be9c9fd732b5bdd3d4c2e9b8cc2313f570094d) to root...
Downloading http://downloads.openwrt.org/chaos_calmer/15.05.1/ar71xx/generic/packages/packages/kmod-openvswitch_3.18.21+2.3.90-58be9c9fd732b5bdd3d4c2e9b8cc2313f570094d_ar71xx.ipk.
Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-openvswitch:
  • kernel (= 3.18.21-1-3d4bd113f3f10b8986a142b8792db9c5) *
  • opkg_install_cmd: Cannot install package kmod-openvswitch.

root@OpenWrt:~#

some advices?

Attachments (0)

Change History (5)

comment:1 Changed 22 months ago by hnyman

This is duplicate of #22073

As far as I can see, 15.05.1 release is broken.
It contains mixed 3.18.21 / 3.18.23 binaries at least for ar71xx.

Apparently kernel packages from the main Openwrt source have been rebuilt before the release with 3.18.23, but the kmods from the other feeds are old 3.18.21 :-(

Several 3.18.21 kmods are listed in 15.05.1 "packages" repo:
https://downloads.openwrt.org/chaos_calmer/15.05.1/ar71xx/generic/packages/packages/
(that includes openvswitch)

While the kernel and kmods are 3.18.23 in the 15.05.1 "base" repo:
https://downloads.openwrt.org/chaos_calmer/15.05.1/ar71xx/generic/packages/base/

I have not checked other platforms, but at least for ar71xx there are several kmods build with older than the release kernel.

comment:2 Changed 21 months ago by tol-eric@…

I have one too.. Hardware - Linksys E2500V3

oot@OpenWrt:~# cp /rom/etc/opkg.conf /etc/opkg.conf
root@OpenWrt:~# opkg install kmod-openvswitch
Installing kmod-openvswitch (3.18.21+2.3.90-58be9c9fd732b5bdd3d4c2e9b8cc2313f570094d) to root...
Downloading http://downloads.openwrt.org/chaos_calmer/15.05.1/brcm47xx/mips74k/packages/packages/kmod-openvswitch_3.18.21+2.3.90-58be9c9fd732b5bdd3d4c2e9b8cc2313f570094d_brcm47xx.ipk.
Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-openvswitch:
  • kernel (= 3.18.21-1-218c25f965f38473476eadfc59ba065c) *
  • opkg_install_cmd: Cannot install package kmod-openvswitch.

root@OpenWrt:~#

comment:3 Changed 21 months ago by anonymous

Yep. I have this erorr too on 3.18.29

Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-usb-serial-wwan:
  • kernel (= 3.18.23-1-b2f200610f46d20ef52d269421369d0c) *
  • opkg_install_cmd: Cannot install package kmod-usb-serial-wwan.

comment:4 Changed 20 months ago by anonymous

CC 15.05.1 Yep. Broken too on WRT54gs V1.1 (8Meg Flash)
root@OpenWrt:~# opkg install openvswitch
Installing openvswitch (2.3.90-58be9c9fd732b5bdd3d4c2e9b8cc2313f570094d) to root...
Downloading http://downloads.openwrt.org/chaos_calmer/15.05.1/brcm47xx/legacy/packages/packages/openvswitch_2.3.90-58be9c9f d732b5bdd3d4c2e9b8cc2313f570094d_brcm47xx.ipk.
Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for openvswitch:
  • kernel (= 3.18.21-1-f99713dcf1203f329e3362507d296364) *
  • opkg_install_cmd: Cannot install package openvswitch.

root@OpenWrt:~# df -h
Filesystem Size Used Available Use% Mounted on
rootfs 4.3M 408.0K 3.9M 9% /
/dev/root 2.4M 2.4M 0 100% /rom
tmpfs 14.2M 1.0M 13.2M 7% /tmp
tmpfs 14.2M 44.0K 14.2M 0% /tmp/root
tmpfs 512.0K 0 512.0K 0% /dev
/dev/mtdblock5 4.3M 408.0K 3.9M 9% /overlay
overlayfs:/overlay 4.3M 408.0K 3.9M 9% /
root@OpenWrt:~#

comment:5 Changed 18 months ago by anonymous

The same occurs on ASUS RT-N-16

root@OpenWrt:/etc/config# opkg install kmod-openvswitch
Installing kmod-openvswitch (3.18.21+2.3.90-58be9c9fd732b5bdd3d4c2e9b8cc2313f570094d) to root...
Downloading http://downloads.openwrt.org/chaos_calmer/15.05.1/brcm47xx/mips74k/packages/packages/kmod-openvswitch_3.18.21+2.3.90-58be9c9fd732b5bdd3d4c2e9b8cc2313f570094d_brcm47xx.ipk.
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-openvswitch:
 * 	kernel (= 3.18.21-1-218c25f965f38473476eadfc59ba065c) * 
 * opkg_install_cmd: Cannot install package kmod-openvswitch.
root@OpenWrt:/etc/config#


Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.