Modify

Opened 22 months ago

Last modified 22 months ago

#22201 new defect

dependencies for map-t (kmod-ipv6)

Reported by: jocke Owned by: developers
Priority: normal Milestone:
Component: packages Version: Trunk
Keywords: map-t kmod-ipv6 @IPV6 Cc:

Description

Hi,

Trying to install map-t on trunk, but get dependency error;

root@OpenWrt:~# opkg install map-t
Installing map-t (6) to root...
Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/generic/packages/routing/map-t_6_ar71xx.ipk.
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for map-t:
 * 	kmod-ipv6 * 
 * opkg_install_cmd: Cannot install package map-t.

Seems to be somewhat related to these;

Attachments (0)

Change History (4)

comment:1 Changed 22 months ago by jocke

Unsure as would be the right procedure to get this fixed.

I'm about to make a custom build, and I can just leave out kmod-ipv6 from the DEPENDS:= manually, but I guess it would be nice to get these dependencies fixed properly?

comment:2 Changed 22 months ago by jocke

Oh, forgot the version this was tested on; DESIGNATED DRIVER (Bleeding Edge, r49161). Clean install.

comment:3 Changed 22 months ago by jocke

Seems like map-t is part of the nat46, which is a separate package feed, whilst map is part of the "official" feed.

It seems that the fix that was implemented in #21358 had a typo (+@IPV6 rather than just @IPV6). It was reverted in a later commit. I'll make an issue on the GitHub page, referencing both this and #21358 (as they are related), and hopefully that will get it fixed.

comment:4 Changed 22 months ago by jocke

You may close this issue, and I guess #21358 can be closed too.

https://github.com/openwrt-routing/packages/issues/170

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.