Modify

Opened 22 months ago

Last modified 22 months ago

#22179 new defect

kmod-fs-hfsplus requires kernel 3.18.20, does not install on 3.18.23

Reported by: Tipo874 Owned by: developers
Priority: normal Milestone:
Component: packages Version: Trunk
Keywords: hfs+ Cc:

Description

I would be very happy if this could be fixed:

---
root@ROOter-Uppsala:~# opkg install kmod-fs-hfsplus
Installing kmod-fs-hfsplus (3.18.20-1) to root...
Downloading http://downloads.openwrt.org/chaos_calmer/15.05/ar71xx/nand/packages/base/kmod-fs-hfsplus_3.18.20-1_ar71xx.ipk.
Multiple packages (kmod-nls-base and kmod-nls-base) providing same name marked HOLD or PREFER. Using latest.
Multiple packages (kmod-nls-utf8 and kmod-nls-utf8) providing same name marked HOLD or PREFER. Using latest.
Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-fs-hfsplus:
  • kernel (= 3.18.20-1-a44d8090b8f752ec1d96871dbbb8988a) *
  • opkg_install_cmd: Cannot install package kmod-fs-hfsplus.

root@ROOter-Uppsala:~# uname -a
Linux ROOter-Uppsala 3.18.23 #3 Sat Mar 26 13:53:42 PDT 2016 mips GNU/Linux

Attachments (0)

Change History (1)

comment:1 Changed 22 months ago by anonymous

You have wrong opkg settings: you are trying to fetch from .../15.05/... that has older kernel instead of .../15.05.1/... that has mainly 3.18.23 kernel.

Upgrade to the CC15.05.1 release, which should also fix your opkg settings to fetch from the 15.05.1 package repo. (And you can't install kmod packages from the release repo to a private build.)

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.