Modify

Opened 22 months ago

Last modified 22 months ago

#22177 new defect

DHCP passing through wan to lan on TL-WR743NDv2

Reported by: sangamshukla.cvs@… Owned by: developers
Priority: high Milestone:
Component: packages Version: Trunk
Keywords: Cc:

Description

Wan port is working as switch and forwarding all packets on WAN to LAN and vise-versa.

WAN PORT:if i check its operstatus its always showing down.
and not detecting cable on plug and unplug.

Scenario:
If LAN is configured as dhcp client and connected to network(XXX), it will get an IP from network's dhcp server.
Now i connect my laptop to WAN port(irrespective of its configuration type i.e. whether static or dhcp client).my laptop is getting ip from dhcp server of network(XXX) i.e. same series ip as of LAN.
DHCP server of router is disabled.

Tested on:

  1. https://downloads.openwrt.org/chaos_calmer/15.05.1/ar71xx/generic/openwrt-15.05.1-ar71xx-generic-tl-wr743nd-v2-squashfs-sysupgrade.bin

2.https://downloads.openwrt.org/chaos_calmer/15.05.1/ar71xx/generic/openwrt-15.05.1-ar71xx-generic-tl-wr743nd-v2-squashfs-factory.bin

3.https://downloads.openwrt.org/barrier_breaker/14.07/ar71xx/generic/openwrt-ar71xx-generic-tl-wr743nd-v2-squashfs-factory.bin

4.https://downloads.openwrt.org/barrier_breaker/14.07/ar71xx/generic/openwrt-ar71xx-generic-tl-wr743nd-v2-squashfs-sysupgrade.bin

Attachments (0)

Change History (5)

comment:1 Changed 22 months ago by anonymous

Provide the following outputs please:

  • swconfig dev switch0 help
  • swconfig dev switch0 show
  • uci show network
  • brctl show
  • ifconfig -a
  • route -n

comment:2 Changed 22 months ago by anonymous

Issue was Fixed in:
/changeset/24938.html
/changeset/24998.html

Referece: /ticket/6819.html

Changeset 24938
View differences

Show

2

lines around each change
Show the changes in full context

Ignore:

Blank lines
Case changes
White space changes

Update
Timestamp:
2011-01-08T21:24:26+01:00 (5 years ago)
Author:
juhosg
Message:
generic: rtl8366: enable ports only after VLAN configuration is done
Location:
trunk/target/linux/generic/files/drivers/net/phy
Files:
4 edited

rtl8366_smi.c (2 diffs)
rtl8366_smi.h (1 diff)
rtl8366rb.c (2 diffs)
rtl8366s.c (2 diffs)

But these changes are not present in openwrt image builder:

  1. openwrt-master.zip(14.07)\openwrt-master\target\linux\generic\files\drivers\net\phy
  2. 15.05\openwrt\target\linux\generic\files\drivers\net\phy

Changes done in files rtl8366rb.c and rtl8366s.c (Changeset 24938) is not present while change of files rtl8366_smi.c & rtl8366_smi.h is present.

same can be checked.

comment:3 Changed 22 months ago by sangamshukla.cvs@…

Issue was Fixed in:
/changeset/24938.html
/changeset/24998.html

Referece: /ticket/6819.html

Changeset 24938
View differences

Show

2

lines around each change
Show the changes in full context

Ignore:

Blank lines
Case changes
White space changes

Update
Timestamp:
2011-01-08T21:24:26+01:00 (5 years ago)
Author:
juhosg
Message:
generic: rtl8366: enable ports only after VLAN configuration is done
Location:
trunk/target/linux/generic/files/drivers/net/phy
Files:
4 edited

rtl8366_smi.c (2 diffs)
rtl8366_smi.h (1 diff)
rtl8366rb.c (2 diffs)
rtl8366s.c (2 diffs)

But these changes are not present in openwrt image builder:

  1. openwrt-master.zip(14.07)\openwrt-master\target\linux\generic\files\drivers\net\phy
  2. 15.05\openwrt\target\linux\generic\files\drivers\net\phy

Changes done in files rtl8366rb.c and rtl8366s.c (Changeset 24938) is not present while change of files rtl8366_smi.c & rtl8366_smi.h is present.

same can be checked.

comment:4 Changed 22 months ago by sangamshukla.cvs@…

sorry for same post two times.

swconfig dev switch0 help:
==========================
switch0: eth0(AR7240/AR9330 built-in switch), ports: 5 (cpu @ 0), vlans: 16

--switch

Attribute 1 (int): enable_vlan (Enable VLAN mode)
Attribute 2 (none): apply (Activate changes in the hardware)
Attribute 3 (none): reset (Reset the switch)

--vlan

Attribute 1 (int): vid (VLAN ID)
Attribute 2 (ports): ports (VLAN port mapping)

--port

Attribute 1 (int): pvid (Primary VLAN ID)
Attribute 2 (string): link (Get port link information)

swconfig dev switch0 show:
==========================
Global attributes:

enable_vlan: 1

Port 0:

pvid: 1
link: port:0 link:up speed:1000baseT full-duplex txflow rxflow

Port 1:

pvid: 1
link: port:1 link:up speed:100baseT full-duplex auto

Port 2:

pvid: 1
link: port:2 link:up speed:100baseT full-duplex auto

Port 3:

pvid: 1
link: port:3 link:up speed:100baseT half-duplex auto

Port 4:

pvid: 1
link: port:4 link:up speed:100baseT full-duplex auto

VLAN 1:

vid: 1
ports: 0 1 2 3 4

uci show network:
=================
network.loopback=interface
network.loopback.ifname='lo'
network.loopback.proto='static'
network.loopback.ipaddr='127.0.0.1'
network.loopback.netmask='255.0.0.0'
network.globals=globals
network.globals.ula_prefix='fd10:d50f:df8d::/48'
network.lan=interface
network.lan.ifname='eth0'
network.lan.type='bridge'
network.lan._orig_ifname='eth0 radio0.network1'
network.lan._orig_bridge='true'
network.lan.proto='dhcp'
network.lan.macaddr='C8:EE:A6:07:5A:E2'
network.@switch[0]=switch
network.@switch[0].name='switch0'
network.@switch[0].reset='1'
network.@switch[0].enable_vlan='1'
network.@switch_vlan[0]=switch_vlan
network.@switch_vlan[0].device='switch0'
network.@switch_vlan[0].vlan='1'
network.@switch_vlan[0].vid='1'
network.@switch_vlan[0].ports='0 1 2 3 4'
network.Eth1=interface
network.Eth1.proto='dhcp'
network.Eth1.ifname='eth1'
network.Eth1.macaddr='C8:EE:A6:07:5A:E4'

brctl show:
===========
bridge name bridge id STP enabled interfaces
br-lan 7fff.c8eea6075ae2 no eth0

ifconfig -a:
============
br-lan Link encap:Ethernet HWaddr C8:EE:A6:07:5A:E2

inet addr:10.100.208.77 Bcast:10.100.208.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:120085 errors:0 dropped:38 overruns:0 frame:0
TX packets:1602 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:8097177 (7.7 MiB) TX bytes:939196 (917.1 KiB)

eth0 Link encap:Ethernet HWaddr C8:EE:A6:F0:00:00

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1427720 errors:0 dropped:764 overruns:0 frame:0
TX packets:6850 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:578299561 (551.5 MiB) TX bytes:3294312 (3.1 MiB)
Interrupt:5

eth1 Link encap:Ethernet HWaddr C8:EE:A6:07:5A:E4

UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:1353 errors:0 dropped:236 overruns:0 frame:0
TX packets:3875 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:312305 (304.9 KiB) TX bytes:1323450 (1.2 MiB)
Interrupt:4

lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:2957 errors:0 dropped:0 overruns:0 frame:0
TX packets:2957 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:202189 (197.4 KiB) TX bytes:202189 (197.4 KiB)

route -n:
=========
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
0.0.0.0 10.100.208.1 0.0.0.0 UG 0 0 0 br-lan
10.100.208.0 0.0.0.0 255.255.255.0 U 0 0 0 br-lan
10.100.208.1 0.0.0.0 255.255.255.255 UH 0 0 0 br-lan

comment:5 Changed 22 months ago by sangamshukla

any update on this, as i am stuck.

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.