Modify

#22115 closed defect (duplicate)

Can't choose ath10k firmware binaries

Reported by: initialed85@… Owned by: developers
Priority: normal Milestone:
Component: packages Version: Chaos Calmer 15.05
Keywords: ath10k firmware binary blob Cc:

Description

Hi guys,

Firstly I apologise if this the wrong place to be bringing this up.

The scene is this:

  • building OpenWrt for a Mikrotik BaseBox2 (RB912UAG-2HPnD-OUT, ar71xx as with most RB stuff)
  • have an ath10k-compatible QCA988x fitted
  • selecting ath10k in "make menuconfig" enforces selection of QCA988x firmware binary
  • firmware binary included is the firmware-5.bin (AP and STA only)

The problem is this:

  • my use case calls for IBSS, so I need firmware-2.bin
  • "make menuconfig" doesn't allow selection of specific firmware binaries
  • "make menuconfig" doesn't allow deselection of all firmware binaries (to allow the user to manually place binary in files/lib/firmware/ath10k/QCA988X/hw2.0

I've been working around this by manually editing .config prior to building, and commenting out the line that reads "CONFIG_PACKAGE_ath10k-firmware-qca988x=y"; this works, but it's not real tidy (throws a warning on build, undoes itself anytime you re-run "make menuconfig"). I then include the desired firmware binaries (board.bin and firmware-2.bin) in the abovementioned "files" path.

I envisage the solution includes all firmware binaries being available for building with and menuconfig permitting you select which one you'd like.

Different binaries for each of the ath10k cards are available at https://github.com/kvalo/ath10k-firmware

I'll aim to attach .config and .feeds.conf.default for reference; also a directory tree of my "files" folder.

Thanks in advance,

Regards,

Ed Beech

Attachments (0)

Change History (2)

comment:1 in reply to: ↑ description Changed 23 months ago by initialed85@…

Had a gateway timeout from dev.openwrt.org while submitting this ticket- please use ticket #22116 and ideally delete this one.

Replying to initialed85@…:

Hi guys,

Firstly I apologise if this the wrong place to be bringing this up.

The scene is this:

  • building OpenWrt for a Mikrotik BaseBox2 (RB912UAG-2HPnD-OUT, ar71xx as with most RB stuff)
  • have an ath10k-compatible QCA988x fitted
  • selecting ath10k in "make menuconfig" enforces selection of QCA988x firmware binary
  • firmware binary included is the firmware-5.bin (AP and STA only)

The problem is this:

  • my use case calls for IBSS, so I need firmware-2.bin
  • "make menuconfig" doesn't allow selection of specific firmware binaries
  • "make menuconfig" doesn't allow deselection of all firmware binaries (to allow the user to manually place binary in files/lib/firmware/ath10k/QCA988X/hw2.0

I've been working around this by manually editing .config prior to building, and commenting out the line that reads "CONFIG_PACKAGE_ath10k-firmware-qca988x=y"; this works, but it's not real tidy (throws a warning on build, undoes itself anytime you re-run "make menuconfig"). I then include the desired firmware binaries (board.bin and firmware-2.bin) in the abovementioned "files" path.

I envisage the solution includes all firmware binaries being available for building with and menuconfig permitting you select which one you'd like.

Different binaries for each of the ath10k cards are available at https://github.com/kvalo/ath10k-firmware

I'll aim to attach .config and .feeds.conf.default for reference; also a directory tree of my "files" folder.

Thanks in advance,

Regards,

Ed Beech

comment:2 Changed 23 months ago by hauke

  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #22116

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.