Modify

#22061 closed defect (wontfix)

Problem with make !

Reported by: ugami Owned by: developers
Priority: normal Milestone:
Component: packages Version: Trunk
Keywords: Cc:

Description

when i run make i got this

admin@dhouha:/home/dhouha/openwrt$ make

make[1] world
make[2] tools/install
make[3] -C tools/m4 compile

make -r world: build failed. Please re-run make with V=99 to see what's going on
make: * [world] Error 1

when i run with V=99 i got :

admin@dhouha:/home/dhouha/openwrt$ make V=99
make[1]: Entering directory `/home/dhouha/openwrt'
make[2]: Entering directory `/home/dhouha/openwrt'
+ mkdir -p /home/dhouha/openwrt/staging_dir/target-mipsel_r2_uClibc-0.9.32
+ cd /home/dhouha/openwrt/staging_dir/target-mipsel_r2_uClibc-0.9.32
+ mkdir -p bin lib include stamp
mkdir -p /home/dhouha/openwrt/build_dir/target-mipsel_r2_uClibc-0.9.32/stamp
touch /home/dhouha/openwrt/staging_dir/target-mipsel_r2_uClibc-0.9.32/.prepared
+ mkdir -p /home/dhouha/openwrt/staging_dir/host
+ cd /home/dhouha/openwrt/staging_dir/host
+ mkdir -p bin lib include stamp
mkdir -p /home/dhouha/openwrt/build_dir/host/stamp
install -m0644 /home/dhouha/openwrt/tools/include/*.h /home/dhouha/openwrt/staging_dir/host/include/
touch /home/dhouha/openwrt/staging_dir/host/.prepared
make[3]: Entering directory `/home/dhouha/openwrt/tools/m4'
make -C /home/dhouha/openwrt/build_dir/host/m4-1.4.15
make[4]: Entering directory `/home/dhouha/openwrt/build_dir/host/m4-1.4.15'
make all-recursive
make[5]: Entering directory `/home/dhouha/openwrt/build_dir/host/m4-1.4.15'
Making all in .
make[6]: Entering directory `/home/dhouha/openwrt/build_dir/host/m4-1.4.15'
make[6]: Nothing to be done for `all-am'.
make[6]: Leaving directory `/home/dhouha/openwrt/build_dir/host/m4-1.4.15'
Making all in examples
make[6]: Entering directory `/home/dhouha/openwrt/build_dir/host/m4-1.4.15/examples'
make[6]: Nothing to be done for `all'.
make[6]: Leaving directory `/home/dhouha/openwrt/build_dir/host/m4-1.4.15/examples'
Making all in lib
make[6]: Entering directory `/home/dhouha/openwrt/build_dir/host/m4-1.4.15/lib'
make all-am
make[7]: Entering directory `/home/dhouha/openwrt/build_dir/host/m4-1.4.15/lib'
x86_64-linux-gnu-gcc -std=gnu99 -I. -O2 -I/home/dhouha/openwrt/staging_dir/host/include -O2 -I/home/dhouha/openwrt/staging_dir/host/include -MT gl_avltree_oset.o -MD -MP -MF .deps/gl_avltree_oset.Tpo -c -o gl_avltree_oset.o gl_avltree_oset.c
mv -f .deps/gl_avltree_oset.Tpo .deps/gl_avltree_oset.Po
x86_64-linux-gnu-gcc -std=gnu99 -I. -O2 -I/home/dhouha/openwrt/staging_dir/host/include -O2 -I/home/dhouha/openwrt/staging_dir/host/include -MT c-stack.o -MD -MP -MF .deps/c-stack.Tpo -c -o c-stack.o c-stack.c
mv -f .deps/c-stack.Tpo .deps/c-stack.Po
x86_64-linux-gnu-gcc -std=gnu99 -I. -O2 -I/home/dhouha/openwrt/staging_dir/host/include -O2 -I/home/dhouha/openwrt/staging_dir/host/include -MT clean-temp.o -MD -MP -MF .deps/clean-temp.Tpo -c -o clean-temp.o clean-temp.c
In file included from clean-temp.h:22:0,

from clean-temp.c:23:

./stdio.h:456:1: error: 'gets' undeclared here (not in a function)

_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");

make[7]: * [clean-temp.o] Error 1
make[7]: Leaving directory `/home/dhouha/openwrt/build_dir/host/m4-1.4.15/lib'
make[6]: * [all] Error 2
make[6]: Leaving directory `/home/dhouha/openwrt/build_dir/host/m4-1.4.15/lib'
make[5]:
* [all-recursive] Error 1
make[5]: Leaving directory `/home/dhouha/openwrt/build_dir/host/m4-1.4.15'
make[4]: * [all] Error 2
make[4]: Leaving directory `/home/dhouha/openwrt/build_dir/host/m4-1.4.15'
make[3]:
* /home/dhouha/openwrt/build_dir/host/m4-1.4.15/.built Error 2
make[3]: Leaving directory `/home/dhouha/openwrt/tools/m4'
make[2]: * [tools/m4/compile] Error 2
make[2]: Leaving directory `/home/dhouha/openwrt'
make[1]:
* /home/dhouha/openwrt/staging_dir/target-mipsel_r2_uClibc-0.9.32/stamp/.tools_install_nnynn Error 2
make[1]: Leaving directory `/home/dhouha/openwrt'
make: * [world] Error 2

Attachments (0)

Change History (1)

comment:1 Changed 23 months ago by hauke

  • Resolution set to wontfix
  • Status changed from new to closed

This is neither trunk nor CC because both of them are using a more recent versions of m4 in tools, all older versions are not supported any more.

This OpenWrt version wants to build an old version of m4 which uses the gets function which is insecure and your host toolchain complains about that and then it fails. It looks your linux distribution is too new for this old OpenWrt version you want to build.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.