Modify

Opened 23 months ago

Last modified 23 months ago

#22055 new defect

You can't get the firmware on ubuntu 14.04

Reported by: anonymous Owned by: developers
Priority: highest Milestone:
Component: toolchain Version: Chaos Calmer 15.05
Keywords: Cc:

Description

I'm trying to build the firmware on ubuntu 14.04.
I do:

git clone git://git.openwrt.org/15.05/openwrt.git
cd ./openwrt
./scripts/feeds update -a
./scripts/feeds install -a

Displays an error:
Build dependency: Please install ncurses. (Missing libncurses.so or ncurses.h)
Build dependency: Please install zlib. (Missing libz.so or zlib.h)
Build dependency: Please install the openssl library (with development headers)

But in Synaptic Manager I see install:
ncurses-bin
version: 5.9+20140118-1ubuntu1
zlib1g
version:1:1.2.8.dfsg-1ubuntu1
openssl
version:1.0.1f-1ubuntu2.18

Please help to build the firmware, I don't know what to do in such a case, thanks in advance !!!

Attachments (0)

Change History (6)

comment:1 Changed 23 months ago by anon2

https://wiki.openwrt.org/doc/howto/buildroot.exigence#table_of_known_prerequisites_and_their_corresponding_packages

Likely you are missing the development versions:

   sudo apt-get install libncurses5-dev zlib1g-dev libssl-dev

comment:2 Changed 23 months ago by anonymous

Thanks anon2 , it works !!!

comment:3 Changed 23 months ago by anonymous

Git glone git:// ? Normaly we use https: now. Is there some old wiki page with git:// ? Please show the link.
Thanks

comment:5 Changed 23 months ago by wkwnxpel

I cant edit it. This would be hopefully fixed soon:
/ticket/22056.html

comment:6 Changed 23 months ago by hauke

What is the problem with the git:// prefix?

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.