Modify

Opened 2 years ago

Last modified 18 months ago

#21929 new defect

AR9331 full-speed USB problems in CC/trunk

Reported by: anonymous Owned by: developers
Priority: normal Milestone:
Component: packages Version: Trunk
Keywords: Cc:

Description

USB Device connected in full-speed mode doesn't function in CC/trunk.

[  218.740000] CPU: 0 PID: 1603 Comm: hostapd Tainted: G        W      3.18.23 #7
[  218.750000] Stack : 00000000 00000000 00000000 00000000 803e42d2 00000042 00000000 81b691b8
	  00000001 000000d0 8032670c 80383083 00000643 803e3504 81ba32b8 000000d0
	  00000003 00000001 8171c810 800a2b60 00000003 8007f838 000001c2 000000d0
	  80329a94 816ebbdc 00000000 00000000 00000000 00000000 00000000 00000000
	  00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
	  ...
[  218.780000] Call Trace:
[  218.780000] [<80070680>] show_stack+0x50/0x84
[  218.790000] [<8007f9b4>] warn_slowpath_common+0x84/0xb4
[  218.790000] [<8007fa10>] warn_slowpath_fmt+0x2c/0x38
[  218.800000] [<81b691b8>] usb_submit_urb+0x2e0/0x4d4 [usbcore]
[  218.800000] [<80f5236c>] ath9k_htc_hw_deinit+0x1a0c/0x1c14 [ath9k_htc]
[  218.810000] 
[  218.810000] ---[ end trace 531f366e5262f325 ]---
[  218.820000] ------------[ cut here ]------------
[  218.820000] WARNING: CPU: 0 PID: 1603 at drivers/usb/core/urb.c:450 usb_submit_urb+0x2e0/0x4d4 [usbcore]()
[  218.830000] usb 1-1: BOGUS urb xfer, pipe 1 != type 3

It works in AA.

Attachments (0)

Change History (6)

comment:1 Changed 2 years ago by anonymous

Logfile of recent trunk build would be nice

comment:2 Changed 2 years ago by anonymous

AA full log: http://pastebin.com/mmH4W4Xc

CC full log (same sitaution is at R48666): http://www5.zippyshare.com/v/d8LTRuk2/file.html

comment:3 Changed 23 months ago by anonymous

same problem, completely different hardware (both router and usb device). unloading ath9k_htc stopped dmesg flood but reloading ath drivers didn't help to start the device. it seems to be usb driver issue.

dmesg:

[571988.317775] ------------[ cut here ]------------
[571988.322686] WARNING: CPU: 0 PID: 7316 at drivers/usb/core/urb.c:450 usb_submit_urb+0x2d4/0x530 [usbcore]()
[571988.332682] usb 2-1: BOGUS urb xfer, pipe 1 != type 3
[571988.337946] Modules linked in: pppoe ppp_async l2tp_ppp iptable_nat rt2800usb rt2800soc rt2800mmio rt2800lib pptp pppox ppp_mppe ppp_generic nf_nat_ipv4 nf_conntrack_ipv4 ipt_REJECT ipt_MASQUERADE ath9k_htc ath9k_common xt_time xt_tcpudp xt_tcpmss xt_statistic xt_state xt_recent xt_nat xt_multiport xt_mark xt_mac xt_limit xt_length xt_id xt_hl xt_helper xt_ecn xt_dscp xt_conntrack xt_connmark xt_connlimit xt_connbytes xt_comment xt_TCPMSS xt_REDIRECT xt_LOG xt_HL xt_DSCP xt_CT xt_CLASSIFY slhc rt2x00usb rt2x00soc rt2x00mmio rt2x00lib nf_reject_ipv4 nf_nat_redirect nf_nat_masquerade_ipv4 nf_nat nf_log_ipv4 nf_log_common nf_defrag_ipv4 nf_conntrack_rtcache iptable_raw iptable_mangle iptable_filter ipt_ECN ip_tables crc_itu_t crc_ccitt ath9k_hw ath act_connmark nf_conntrack act_skbedit act_mirred em_u32 cls_u32 cls_tcindex cls_flow cls_route cls_fw sch_hfsc sch_ingress mt76x2e mt76 mac80211 cfg80211 compat xt_set x_tables ip_set_list_set ip_set_hash_netiface ip_set_hash_netport ip_set_hash_netnet ip_set_hash_net ip_set_hash_netportnet ip_set_hash_mac ip_set_hash_ipportnet ip_set_hash_ipportip ip_set_hash_ipport ip_set_hash_ipmark ip_set_hash_ip ip_set_bitmap_port ip_set_bitmap_ipmac ip_set_bitmap_ip ip_set nfnetlink ip_gre gre ifb l2tp_netlink l2tp_core udp_tunnel ip_tunnel tun eeprom_93cx6 sha1_generic ecb leds_gpio dwc2 ohci_platform ohci_hcd ehci_platform ehci_hcd gpio_button_hotplug usbcore nls_base usb_common aead crypto_null crypto_hash
[571988.469499] CPU: 0 PID: 7316 Comm: kworker/u2:4 Tainted: G        W       4.3.4 #6
[571988.477341] Workqueue: phy7 ath9k_led_work [ath9k_htc]
[571988.482689] Stack : 00000003 85654718 00000088 800489c4 8626eab8 80350b63 802ef134 00001c94
[571988.482689] 	  802f9174 860c1c9c 80350000 80046998 00000088 800489c4 8035d364 80350000
[571988.482689] 	  00000003 860c1c9c 80350000 80036e70 00000088 860c1cd4 00008dc3 00000000
[571988.482689] 	  8034f230 00000000 873a9650 871bf700 871bf600 37796870 00000000 00000000
[571988.482689] 	  00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
[571988.482689] 	  ...
[571988.520994] Call Trace:
[571988.523613] [<800134fc>] show_stack+0x50/0x84
[571988.528231] [<800238a0>] warn_slowpath_common+0xa0/0xd0
[571988.533663] [<800238fc>] warn_slowpath_fmt+0x2c/0x38
[571988.538918] [<87009598>] usb_submit_urb+0x2d4/0x530 [usbcore]
[571988.544925] [<873a24d4>] ath9k_htc_hw_deinit+0x1b54/0x1d60 [ath9k_htc]
[571988.551696] 
[571988.553312] ---[ end trace a841080099319b2d ]---

comment:4 Changed 23 months ago by anonymous

forgot to add:

usb device was working stable for days as wlan5, then i changed to another card to check something and that card was properl detected as wlan6. after replugging first card back it should have been detected as wlan7, but router detected it as wlan2.

comment:5 Changed 18 months ago by anonymous

I am having the same kernal log flooding.
when ever I plugin the the ath9271 usb dangle,
the ssh connection will start to snail, dmesg will block the session giving a lot of kernal trace stuff, much like what the OP has.

[571988.322686] WARNING: CPU: 0 PID: 7316 at drivers/usb/core/urb.c:450 usb_submit_urb+0x2d4/0x530 [usbcore]()
[571988.332682] usb 2-1: BOGUS urb xfer, pipe 1 != type 3
[571988.337946] Modules linked in: ...
[571988.469499] CPU: 0 PID: 7316 Comm: kworker/u2:4 Tainted: G W 4.3.4 #6
[571988.477341] Workqueue: phy7 ath9k_led_work [ath9k_htc]
........
go to start, repeat
.......

An answer was found there, indicating the lack of a kernel patch.
on https://github.com/qca/open-ath9k-htc-firmware/wiki/usb-related-issues

BOGUS urb xfer, pipe 1 != type 3

If you get this error, then you need to update firmware (at least version 1.4) and kernel (at least v3.18). If you still get this issue, ask or check if your kernel really has this patch ath9k_htc: do not use bulk on EP3 and EP4.

... Or, your USB host controller forced this adapter to start in USB 1.1 Full Speed mode. Which is not tested or supported yet.

comment:6 Changed 18 months ago by anonymous

thanks for a patch hint. on a damaged usb port hardware i had to force USB 1.1 full speed mode by soldering a resistor to one of the usb data lines. the connection to uplink via ar9271 adapter does not start on CC/trunk but it worked pretty well on AA (5-6Mbps throughput which corresponds to USB full speed mode)

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.