Modify

Opened 2 years ago

Last modified 21 months ago

#21884 new defect

Adhoc wireless mode not working on Xiaomi miWifi dual band router

Reported by: hotspotsystem Owned by: developers
Priority: normal Milestone: Designated Driver (Trunk)
Component: kernel Version: Trunk
Keywords: Cc:

Description

It speaks for itself. We cannot get Xiaomi Miwifi dual band router working with a 2.4GHz wireless adhoc SSID. On 5 GHz it may work eventually. It can also work on 2.4 GHz if there's only one SSID (adhoc mode) set. If I add another (regular access point mode) so I would use two SSIDs (access point and and adhoc for mesh) it never starts. Obviously one needs 2.4 GHz as well.

I tested previous builds and it seems it was working better with kernel 3.18 before kernel change to 4.3 (or 4.1.x) . However the wireless power with those builds (around 15.05 final) are not correctly set and underpowers the SOC in the router.

Hotspot System development team

Attachments (0)

Change History (6)

comment:1 Changed 2 years ago by bittorf@…

this is not a bug, but simply not supported:

ih phy phy0 info
# check "valid interface combinations:"

comment:2 Changed 2 years ago by hotspotsystem

If I create an Adhoc SSID on 5 GHz band it starts right away on the same router. Mesh point is supported for both bands according to iw phy phy0/1 info. STA/AP BI must match says the config but I'm not going to use AP/STA but Batman-Adv Mesh running on Adhoc mode. So 2.4 Ghz on this unit cannot support Adhoc and AP mode the same time while on AC it runs fine?

Steve / HSS team

comment:3 Changed 2 years ago by bittorf@…

yes. these are 2 different radios with different drivers (rt2xx + mt76).

phy0 = 5ghz = mt76x2e
phy1 = 2ghz = rt2800_wmac

the rt2xx does only support valid interface combinations: #{ managed, AP } <= 8

comment:4 in reply to: ↑ description Changed 2 years ago by anonymous

Replying to hotspotsystem:

I tested previous builds and it seems it was working better with kernel 3.18 before kernel change to 4.3 (or 4.1.x) . However the wireless power with those builds (around 15.05 final) are not correctly set and underpowers the SOC in the router.

Hotspot System development team

Are you saying that with kernel 3.18 both adhoc and AP worked simultaneously without problems?

I've sent patch for CC that fixes low wireless power, but the question is if it's going to be included in 15.05.1 release. https://www.mail-archive.com/openwrt-devel@lists.openwrt.org/msg37803.html

comment:5 Changed 2 years ago by anonymous

Indeed it's not working. In the GUI it shows all 2 SSIDs up, but it broadcasts only one at a time. We'll try the WDS to get wireless repeater mode.
Batman-adv works nicely with Atheros chipsets we were aiming for that here too.

comment:6 Changed 21 months ago by unpaseo

I encountered problem with Atheros 9341, and cannot make adhoc and AP work simultaneously, but it was good with AR72xx. Is it a driver problem?

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.