Modify

Opened 2 years ago

Last modified 21 months ago

#21765 new defect

mixed mode wireless broken in trunk

Reported by: anonymous Owned by: developers
Priority: response-needed Milestone:
Component: packages Version: Trunk
Keywords: Cc:

Description

when connected to 802.11g AP as client and create virtual AP on the same radio the newly created AP is limited to 802.11g rates.

to exclude kernel 4.3 as a cause i've compiled r47831 and with same settings AP works with 802.11n rates without problems.

this can be easily noticed in luci where in latest trunk revisions TX and RX rates show only rates and units (48.0 Mbps) while in r47831 it shows all info (54.0 Mbit/s, MCS 0, 20MHz)

Attachments (0)

Change History (11)

comment:1 Changed 2 years ago by jow

That LuCI behaviour change is unrelated to that. "54.0 Mbit/s, MCS 0, 20MHz" has been a display bug, it was no indication that 11n rates were in use.

comment:2 Changed 2 years ago by jow

  • Priority changed from normal to response-needed

Please show the outputs of "iw dev wlan0 link", "iw dev wlan1 station dump" and "iwinfo" without arguments in both the correct and the broken cases. The commands above assume that wlan0 = sta, wlan1 = ap. If this is not the case for you then change accordingly.

comment:3 Changed 2 years ago by anonymous

after clean checkout of r48531 it seems to look ok, probably on a bad revison first time.

comment:4 Changed 2 years ago by anonymous

ok i found what is causing it, it is setting wifi interface changes through luci, it messes up config file in such a way that it changes hwmode from 11g to 11a, resets channel to auto etc. r48619 with luci from 8630a1dbfb5c8baa0b18bb31c5b05852e80d14c6

comment:5 Changed 2 years ago by jow

Please attach the wireless config before and after it is broken.

comment:6 Changed 2 years ago by anonymous

config wifi-device 'radio2'
	option type 'mac80211'
	option path '101c0000.ehci/usb1/1-1/1-1:1.0'
	option txpower '20'
	option noscan '1'
	option country 'GB'
	option country_ie '0'
	option hwmode '11g'
	option htmode 'HT40'
	option channel '13'

config wifi-iface
	option device 'radio2'
	option network 'wwan'
	option encryption 'psk2+ccmp'
	option key 'ssidssid'
	option ssid 'ap'
	option mode 'sta'

after switching to ap mode and back:

config wifi-device 'radio2'
	option type 'mac80211'
	option path '101c0000.ehci/usb1/1-1/1-1:1.0'
	option txpower '20'
	option noscan '1'
	option country 'GB'
	option country_ie '0'
	option hwmode '11a'
	option channel 'auto'

config wifi-iface
	option device 'radio2'
	option network 'wwan'
	option encryption 'psk2+ccmp'
	option key 'ssidssid'
	option ssid 'ap'
	option mode 'sta'

comment:7 Changed 2 years ago by jow

What is reported by these commands?

  • iwinfo radio2 hwmodelist
  • iwinfo radio2 htmodelist
  • iwinfo radio2 freqlist

comment:8 follow-up: Changed 2 years ago by anonymous

root@OpenWrt:~# iwinfo wlan2 hwmodelist
HT20 HT40 
root@OpenWrt:~# iwinfo wlan2 htmodelist
HT20 HT40 
root@OpenWrt:~# iwinfo wlan2 freqlist
  2.312 GHz (Channel 237)
  2.317 GHz (Channel 238)
  2.322 GHz (Channel 239)
  2.327 GHz (Channel 240)
  2.332 GHz (Channel 241)
  2.337 GHz (Channel 242)
  2.342 GHz (Channel 243)
  2.347 GHz (Channel 244)
  2.352 GHz (Channel 245)
  2.357 GHz (Channel 246)
  2.362 GHz (Channel 247)
  2.367 GHz (Channel 248)
  2.372 GHz (Channel 249)
  2.377 GHz (Channel 250)
  2.382 GHz (Channel 251)
  2.387 GHz (Channel 252)
  2.392 GHz (Channel 253)
  2.397 GHz (Channel 254)
  2.402 GHz (Channel 255)
  2.407 GHz (Channel unknown)
  2.412 GHz (Channel 1)
  2.417 GHz (Channel 2)
  2.422 GHz (Channel 3)
  2.427 GHz (Channel 4)
  2.432 GHz (Channel 5)
  2.437 GHz (Channel 6)
  2.442 GHz (Channel 7)
  2.447 GHz (Channel 8)
  2.452 GHz (Channel 9)
  2.457 GHz (Channel 10)
  2.462 GHz (Channel 11)
  2.467 GHz (Channel 12)
* 2.472 GHz (Channel 13)
  2.484 GHz (Channel 14)

comment:9 Changed 2 years ago by jow

Please attach the complete output of iw list and iwinfo radio2 info as well.

Last edited 2 years ago by jow (previous) (diff)

comment:10 Changed 2 years ago by anonymous

root@OpenWrt:~# iw list
Wiphy phy2
	max # scan SSIDs: 4
	max scan IEs length: 2257 bytes
	max # sched scan SSIDs: 0
	max # match sets: 0
	Retry short limit: 7
	Retry long limit: 4
	Coverage class: 0 (up to 0m)
	Device supports T-DLS.
	Available Antennas: TX 0x1 RX 0x1
	Configured Antennas: TX 0x1 RX 0x1
	Supported interface modes:
		 * IBSS
		 * managed
		 * AP
		 * AP/VLAN
		 * monitor
		 * mesh point
		 * P2P-client
		 * P2P-GO
		 * outside context of a BSS
	Band 1:
		Capabilities: 0x116e
			HT20/HT40
			SM Power Save disabled
			RX HT20 SGI
			RX HT40 SGI
			RX STBC 1-stream
			Max AMSDU length: 3839 bytes
			DSSS/CCK HT40
		Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
		Minimum RX AMPDU time spacing: 8 usec (0x06)
		HT TX/RX MCS rate indexes supported: 0-7
		Frequencies:
			* 2312 MHz [-19] (20.0 dBm)
			* 2317 MHz [-18] (20.0 dBm)
			* 2322 MHz [-17] (20.0 dBm)
			* 2327 MHz [-16] (20.0 dBm)
			* 2332 MHz [-15] (20.0 dBm)
			* 2337 MHz [-14] (20.0 dBm)
			* 2342 MHz [-13] (20.0 dBm)
			* 2347 MHz [-12] (20.0 dBm)
			* 2352 MHz [-11] (20.0 dBm)
			* 2357 MHz [-10] (20.0 dBm)
			* 2362 MHz [-9] (20.0 dBm)
			* 2367 MHz [-8] (20.0 dBm)
			* 2372 MHz [-7] (20.0 dBm)
			* 2377 MHz [-6] (20.0 dBm)
			* 2382 MHz [-5] (20.0 dBm)
			* 2387 MHz [-4] (20.0 dBm)
			* 2392 MHz [-3] (20.0 dBm)
			* 2397 MHz [-2] (20.0 dBm)
			* 2402 MHz [-1] (20.0 dBm)
			* 2407 MHz [0] (20.0 dBm)
			* 2412 MHz [1] (20.0 dBm)
			* 2417 MHz [2] (20.0 dBm)
			* 2422 MHz [3] (20.0 dBm)
			* 2427 MHz [4] (20.0 dBm)
			* 2432 MHz [5] (20.0 dBm)
			* 2437 MHz [6] (20.0 dBm)
			* 2442 MHz [7] (20.0 dBm)
			* 2447 MHz [8] (20.0 dBm)
			* 2452 MHz [9] (20.0 dBm)
			* 2457 MHz [10] (20.0 dBm)
			* 2462 MHz [11] (20.0 dBm)
			* 2467 MHz [12] (20.0 dBm)
			* 2472 MHz [13] (20.0 dBm)
			* 2484 MHz [14] (20.0 dBm)
	valid interface combinations:
		 * #{ managed, P2P-client } <= 2, #{ AP, mesh point, P2P-GO } <= 2,
		   total <= 2, #channels <= 1
	HT Capability overrides:
		 * MCS: ff ff ff ff ff ff ff ff ff ff
		 * maximum A-MSDU length
		 * supported channel width
		 * short GI for 40 MHz
		 * max A-MPDU length exponent
		 * min MPDU start spacing
Wiphy phy1
	max # scan SSIDs: 4
	max scan IEs length: 2257 bytes
	max # sched scan SSIDs: 0
	max # match sets: 0
	Retry short limit: 7
	Retry long limit: 4
	Coverage class: 0 (up to 0m)
	Available Antennas: TX 0 RX 0
	Supported interface modes:
		 * IBSS
		 * managed
		 * AP
		 * AP/VLAN
		 * WDS
		 * monitor
		 * mesh point
	Band 1:
		Capabilities: 0x2f2
			HT20/HT40
			Static SM Power Save
			RX Greenfield
			RX HT20 SGI
			RX HT40 SGI
			TX STBC
			RX STBC 2-streams
			Max AMSDU length: 3839 bytes
			No DSSS/CCK HT40
		Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
		Minimum RX AMPDU time spacing: 2 usec (0x04)
		HT RX MCS rate indexes supported: 0-15, 32
		TX unequal modulation not supported
		HT TX Max spatial streams: 2
		HT TX MCS rate indexes supported may differ
		Frequencies:
			* 2412 MHz [1] (20.0 dBm)
			* 2417 MHz [2] (20.0 dBm)
			* 2422 MHz [3] (20.0 dBm)
			* 2427 MHz [4] (20.0 dBm)
			* 2432 MHz [5] (20.0 dBm)
			* 2437 MHz [6] (20.0 dBm)
			* 2442 MHz [7] (20.0 dBm)
			* 2447 MHz [8] (20.0 dBm)
			* 2452 MHz [9] (20.0 dBm)
			* 2457 MHz [10] (20.0 dBm)
			* 2462 MHz [11] (20.0 dBm)
			* 2467 MHz [12] (20.0 dBm)
			* 2472 MHz [13] (20.0 dBm)
			* 2484 MHz [14] (20.0 dBm)
	valid interface combinations:
		 * #{ managed, AP, mesh point } <= 8,
		   total <= 8, #channels <= 1
	HT Capability overrides:
		 * MCS: ff ff ff ff ff ff ff ff ff ff
		 * maximum A-MSDU length
		 * supported channel width
		 * short GI for 40 MHz
		 * max A-MPDU length exponent
		 * min MPDU start spacing
Wiphy phy0
	max # scan SSIDs: 4
	max scan IEs length: 2247 bytes
	max # sched scan SSIDs: 0
	max # match sets: 0
	Retry short limit: 7
	Retry long limit: 4
	Coverage class: 0 (up to 0m)
	Available Antennas: TX 0 RX 0
	Supported interface modes:
		 * IBSS
		 * managed
		 * AP
		 * AP/VLAN
		 * monitor
		 * mesh point
	Band 2:
		Capabilities: 0x1f3
			RX LDPC
			HT20/HT40
			Static SM Power Save
			RX Greenfield
			RX HT20 SGI
			RX HT40 SGI
			TX STBC
			RX STBC 1-stream
			Max AMSDU length: 3839 bytes
			No DSSS/CCK HT40
		Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
		Minimum RX AMPDU time spacing: 4 usec (0x05)
		HT TX/RX MCS rate indexes supported: 0-15
		VHT Capabilities (0x000001b0):
			Max MPDU length: 3895
			Supported Channel Width: neither 160 nor 80+80
			RX LDPC
			short GI (80 MHz)
			TX STBC
		VHT RX MCS set:
			1 streams: MCS 0-9
			2 streams: MCS 0-9
			3 streams: not supported
			4 streams: not supported
			5 streams: not supported
			6 streams: not supported
			7 streams: not supported
			8 streams: not supported
		VHT RX highest supported: 0 Mbps
		VHT TX MCS set:
			1 streams: MCS 0-9
			2 streams: MCS 0-9
			3 streams: not supported
			4 streams: not supported
			5 streams: not supported
			6 streams: not supported
			7 streams: not supported
			8 streams: not supported
		VHT TX highest supported: 0 Mbps
		Frequencies:
			* 5180 MHz [36] (30.0 dBm)
			* 5200 MHz [40] (30.0 dBm)
			* 5220 MHz [44] (30.0 dBm)
			* 5240 MHz [48] (30.0 dBm)
			* 5260 MHz [52] (30.0 dBm)
			* 5280 MHz [56] (30.0 dBm)
			* 5300 MHz [60] (30.0 dBm)
			* 5320 MHz [64] (30.0 dBm)
			* 5500 MHz [100] (30.0 dBm)
			* 5520 MHz [104] (30.0 dBm)
			* 5540 MHz [108] (30.0 dBm)
			* 5560 MHz [112] (30.0 dBm)
			* 5580 MHz [116] (30.0 dBm)
			* 5600 MHz [120] (30.0 dBm)
			* 5620 MHz [124] (30.0 dBm)
			* 5640 MHz [128] (30.0 dBm)
			* 5660 MHz [132] (30.0 dBm)
			* 5680 MHz [136] (30.0 dBm)
			* 5700 MHz [140] (30.0 dBm)
			* 5745 MHz [149] (30.0 dBm)
			* 5765 MHz [153] (30.0 dBm)
			* 5785 MHz [157] (30.0 dBm)
			* 5805 MHz [161] (30.0 dBm)
			* 5825 MHz [165] (30.0 dBm)
	valid interface combinations:
		 * #{ IBSS } <= 1, #{ managed, AP, mesh point } <= 8,
		   total <= 8, #channels <= 1, STA/AP BI must match
	HT Capability overrides:
		 * MCS: ff ff ff ff ff ff ff ff ff ff
		 * maximum A-MSDU length
		 * supported channel width
		 * short GI for 40 MHz
		 * max A-MPDU length exponent
		 * min MPDU start spacing
	Device supports VHT-IBSS.

root@OpenWrt:~# iwinfo wlan2 info
wlan2     ESSID: "ssid"
          Access Point: C4:E9:84:18:BE:2A
          Mode: Client  Channel: 13 (2.472 GHz)
          Tx-Power: 20 dBm  Link Quality: 46/70
          Signal: -64 dBm  Noise: unknown
          Bit Rate: 54.0 MBit/s
          Encryption: WPA2 PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11bgn
          Hardware: unknown [Generic MAC80211]
          TX power offset: unknown
          Frequency offset: unknown
          Supports VAPs: yes  PHY name: phy2

comment:11 in reply to: ↑ 8 Changed 21 months ago by mr3b2004

Replying to anonymous:

root@OpenWrt:~# iwinfo wlan2 hwmodelist
HT20 HT40 
root@OpenWrt:~# iwinfo wlan2 htmodelist
HT20 HT40 
root@OpenWrt:~# iwinfo wlan2 freqlist
  2.312 GHz (Channel 237)
  2.317 GHz (Channel 238)
  2.322 GHz (Channel 239)
  2.327 GHz (Channel 240)
  2.332 GHz (Channel 241)
  2.337 GHz (Channel 242)
  2.342 GHz (Channel 243)
  2.347 GHz (Channel 244)
  2.352 GHz (Channel 245)
  2.357 GHz (Channel 246)
  2.362 GHz (Channel 247)
  2.367 GHz (Channel 248)
  2.372 GHz (Channel 249)
  2.377 GHz (Channel 250)
  2.382 GHz (Channel 251)
  2.387 GHz (Channel 252)
  2.392 GHz (Channel 253)
  2.397 GHz (Channel 254)
  2.402 GHz (Channel 255)
  2.407 GHz (Channel unknown)
  2.412 GHz (Channel 1)
  2.417 GHz (Channel 2)
  2.422 GHz (Channel 3)
  2.427 GHz (Channel 4)
  2.432 GHz (Channel 5)
  2.437 GHz (Channel 6)
  2.442 GHz (Channel 7)
  2.447 GHz (Channel 8)
  2.452 GHz (Channel 9)
  2.457 GHz (Channel 10)
  2.462 GHz (Channel 11)
  2.467 GHz (Channel 12)
* 2.472 GHz (Channel 13)
  2.484 GHz (Channel 14)

who to add new channel 2312-2407MHz

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.