Modify

Opened 2 years ago

Last modified 22 months ago

#21737 reopened defect

Can't flash current trunk kirkwood image from stock EA4500 firmware

Reported by: anonymous Owned by: developers
Priority: highest Milestone:
Component: base system Version: Trunk
Keywords: Cc:

Description

Using https://downloads.openwrt.org/snapshots/trunk/kirkwood/generic/openwrt-kirkwood-linksys-viper-squashfs-factory.bin
Stock EA4500 firmware version 2.1.41.164606

After flash process and reboot device will boot stock firmware.

Attachments (0)

Change History (10)

comment:1 Changed 2 years ago by anonymous

same problem here

comment:2 Changed 2 years ago by diizzyy@…

Do you have any logs to provide?

It's probably related to this being the same platform:
/ticket/20948.html

comment:3 Changed 2 years ago by anonymous

sysupgrade not working too

how can i get logs without serial and jtag?

using r48424 now, problem is somewhere after that changeset

comment:4 Changed 2 years ago by diizzyy@…

You don't unfortunately

comment:5 Changed 2 years ago by anonymous

same problem with ea3500.

comment:6 Changed 2 years ago by Dekker

I am having a similar (sysupgrade) problem.

I am running r48522, tried to update to the snapshot from Jan 31 (Kirkwood Viper sysupgrade https://downloads.openwrt.org/snapshots/trunk/kirkwood/generic/). Don't know which release that represents since it fails to install. Using LUCI web interface to upgrade. When it reboots, it 'hangs', the LED/light is dim. After an excessive long time, I would manually reboot, I needed to use hardware button to force reset, it finally booted back to r48522. Tried twice, gave up because it is obvious something is wrong.

The router is in a semi-prod environment so I can't test any more for a few weeks, but the failed upgrade has messed with a few plugin pages, such as in luci-app-statistics, the Setup | Output Statistics pages are missing the buttons (view source reveals error 500). I was going to re-install with a new image once the issue is resolved, as I can no longer tell if it is due to the failed image itself, or due to the failed upgrade process.

Perhaps on a related note, the trunk/snapshots folder has not been updated since Jan 31 (it is now Feb 3).

comment:7 Changed 2 years ago by anonymous

just successfully flashed current trunk r48638 above r48424 using sysupgrade image

so, i suppose problem was fixed somehow

comment:8 Changed 2 years ago by jow

  • Resolution set to fixed
  • Status changed from new to closed

comment:9 Changed 2 years ago by anonymous

  • Resolution fixed deleted
  • Status changed from closed to reopened

Still can't upgrade from CC 15.05 r46767 to recent trunk, it's say "Firmware upgrade is not implemented for this platform."

comment:10 Changed 22 months ago by anonymous

flash back to Linksys firmware first before installing dd trunk.

Add Comment

Modify Ticket

Action
as reopened .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.