Modify

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#21712 closed defect (fixed)

mvebu wrt1900ac cannot boot

Reported by: anonymous Owned by: developers
Priority: normal Milestone:
Component: packages Version: Trunk
Keywords: Cc:

Description

The router works well with r48454, but kernel can't boot with recent changes. I checked the commit log, the default flag introduced in r48470 might be the root cause.

Attachments (0)

Change History (13)

comment:1 Changed 2 years ago by anonymous

I don't know if it's related, but r48508 fails to boot on my WRT1900AC V1. I get stuck with a slow blinking power LED on boot. Reverting to r48456 boots fine.

comment:2 follow-up: Changed 2 years ago by xavier@…

I also confirm that, removing that change makes it boot again.

Thanks.

comment:3 Changed 2 years ago by anonymous

Serial console of wrt1200ac on freshly build trunk r48510

Board configuration detected:
mvEthE6171SwitchBasicInit init 
Net:   
|  port  | Interface | PHY address  |
|--------|-----------|--------------|
| egiga0 |   RGMII   |     0x01     |
| egiga1 |   SGMII   |     0x00     |
egiga0 [PRIME], egiga1
auto_recovery_check changes bootcmd: run altnandboot 
Hit any key to stop autoboot:  0 

NAND read: device 0 offset 0x3200000, size 0x600000
 6291456 bytes read: OK
## Booting kernel from Legacy Image at 02000000 ...
   Image Name:   ARM OpenWrt Linux-4.1.16
   Created:      2016-01-27  15:29:21 UTC
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    1691529 Bytes = 1.6 MiB
   Load Address: 00008000
   Entry Point:  00008000
   Verifying Checksum ... OK
   Loading Kernel Image ... OK
OK

Starting kernel ...

The boot process hangs there indefinitely.

comment:4 in reply to: ↑ 2 Changed 2 years ago by anonymous

Replying to xavier@…:

I also confirm that, removing that change makes it boot again.

Thanks.

Did you revert r48470? I re-ran the build with r48470 reverted, but I can't test it until I'm off work.

comment:5 Changed 2 years ago by nbd

If it hangs in the kernel, I don't see how r48470 could have caused this. This flag only applies to compiled user space packages.

comment:6 Changed 2 years ago by doITright

I first ran into this between r48444 and r48474.

I assume that the issue is still in play but have not tried to build again or attempted to revert the change in r48470.

Cheers

comment:7 Changed 2 years ago by anonymous

I removed the one line imposed in r48470, then did "make clean ; make V=s" and got a functional firmware built and running on my wrt1200ac.

comment:8 Changed 2 years ago by anonymous

Same as above removed the problem line and can now boot the router wrt1900acv1
R48513 loaded fine.

comment:9 Changed 2 years ago by anonymous

I can confirm as well. (I'm comment:1 and comment:4 above).

Unmodified r48508 fails to boot.

r48508 with r48470 reverted boots successfully.

comment:10 Changed 2 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

fixed in r48515

comment:12 Changed 2 years ago by anonymous

Have you checked if these fixes were backported to the gcc 5 branch or if this will only show up in gcc-6? I am planing to add gcc-5.3, when I find some time.

Hauke

comment:13 Changed 2 years ago by anonymous

Not yet. According to this link[1], -fno-plt appears in GCC 6. I suggest waiting for next release. I don't know too much about the gcc thing, what I did before is just search some keywords related to no-plt or plt, I'm afraid I can't offer more help.

[1]: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=69280

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.