Modify

Opened 11 years ago

Closed 11 years ago

Last modified 4 years ago

#2165 closed defect (worksforme)

Build error in isakmpd-20041012 in svn 8307 on Broadcom BCM947xx/953xx

Reported by: Hauke <openwrt@…> Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version:
Keywords: Cc:

Description

In file included from /home/hauke/kamikaze/trunk/build_mipsel/isakmpd-20041012.orig/sysdep/linux/sysdep-os.h:34,
                 from sysdep.h:41,
                 from app.c:38:
/home/hauke/kamikaze/trunk/staging_dir_mipsel/lib/gcc/mipsel-linux-uclibc/4.2.1/../../../../mipsel-linux-uclibc/sys-include/linux/ipsec.h:18:22: error: net/sock.h: No such file or directory
In file included from /home/hauke/kamikaze/trunk/staging_dir_mipsel/lib/gcc/mipsel-linux-uclibc/4.2.1/../../../../mipsel-linux-uclibc/sys-include/linux/sched.h:18,
                 from /home/hauke/kamikaze/trunk/staging_dir_mipsel/lib/gcc/mipsel-linux-uclibc/4.2.1/../../../../mipsel-linux-uclibc/sys-include/linux/skbuff.h:19,
                 from /home/hauke/kamikaze/trunk/staging_dir_mipsel/lib/gcc/mipsel-linux-uclibc/4.2.1/../../../../mipsel-linux-uclibc/sys-include/linux/ipsec.h:19,
                 from /home/hauke/kamikaze/trunk/build_mipsel/isakmpd-20041012.orig/sysdep/linux/sysdep-os.h:34,
                 from sysdep.h:41,
                 from app.c:38:
/home/hauke/kamikaze/trunk/staging_dir_mipsel/lib/gcc/mipsel-linux-uclibc/4.2.1/../../../../mipsel-linux-uclibc/sys-include/asm/semaphore.h:29: error: expected specifier-qualifier-list before 'wait_queue_head_t'
/home/hauke/kamikaze/trunk/staging_dir_mipsel/lib/gcc/mipsel-linux-uclibc/4.2.1/../../../../mipsel-linux-uclibc/sys-include/asm/semaphore.h: In function 'sema_init':
/home/hauke/kamikaze/trunk/staging_dir_mipsel/lib/gcc/mipsel-linux-uclibc/4.2.1/../../../../mipsel-linux-uclibc/sys-include/asm/semaphore.h:60: error: 'struct semaphore' has no member named 'wait'
In file included from /home/hauke/kamikaze/trunk/staging_dir_mipsel/lib/gcc/mipsel-linux-uclibc/4.2.1/../../../../mipsel-linux-uclibc/sys-include/linux/signal.h:4,
                 from /home/hauke/kamikaze/trunk/staging_dir_mipsel/lib/gcc/mipsel-linux-uclibc/4.2.1/../../../../mipsel-linux-uclibc/sys-include/linux/sched.h:26,
                 from /home/hauke/kamikaze/trunk/staging_dir_mipsel/lib/gcc/mipsel-linux-uclibc/4.2.1/../../../../mipsel-linux-uclibc/sys-include/linux/skbuff.h:19,
                 from /home/hauke/kamikaze/trunk/staging_dir_mipsel/lib/gcc/mipsel-linux-uclibc/4.2.1/../../../../mipsel-linux-uclibc/sys-include/linux/ipsec.h:19,
                 from /home/hauke/kamikaze/trunk/build_mipsel/isakmpd-20041012.orig/sysdep/linux/sysdep-os.h:34,
                 from sysdep.h:41,
                 from app.c:38:

Attachments (0)

Change History (2)

comment:1 Changed 11 years ago by florian

  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce the bug, is your toolchain really installed ?

comment:2 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.