Modify

Opened 2 years ago

Last modified 2 years ago

#21648 reopened defect

luci generates broken config files

Reported by: anonymous Owned by: developers
Priority: normal Milestone:
Component: packages Version: Trunk
Keywords: Cc:

Description

at r48233 /etc/config folder contains a lot of uci-snapshot files with partial and empty network config.

Attachments (1)

Screenshot.png (156.6 KB) - added by anonymous 2 years ago.
screenshot

Download all attachments as: .zip

Change History (9)

Changed 2 years ago by anonymous

screenshot

comment:1 Changed 2 years ago by jow

This is not caused by LuCI. Please post the output of ls -lh /etc/config/* and uci set network.test=test; uci commit network

comment:2 Changed 2 years ago by anonymous

root@OpenWrt:~# ls -lh /etc/config/*
-rw-r--r--    1 root     root        1.5K Jan 19 04:16 /etc/config/dhcp
-rw-r--r--    1 root     root         328 Jan 19 04:17 /etc/config/dnscrypt-proxy
-rw-r--r--    1 root     root          90 Jan 18 17:42 /etc/config/dropbear
-rw-r--r--    1 root     root        6.0K Jan 19 08:16 /etc/config/firewall
-rw-r--r--    1 root     root         666 Jan 19 04:18 /etc/config/luci
-rw-r--r--    1 root     root        2.4K Jan 18 17:38 /etc/config/mwan3
-rw-r--r--    1 root     root        2.8K Jan 19 04:12 /etc/config/network
-rw-r--r--    1 root     root          97 Nov 21 18:40 /etc/config/rpcd
-rw-r--r--    1 root     root         471 Nov 28 11:23 /etc/config/system
-rw-r--r--    1 root     root         743 Jan 19 04:26 /etc/config/ucitrack
-rw-r--r--    1 root     root         688 Jan 19 04:25 /etc/config/uhttpd
-rw-r--r--    1 root     root        2.8K Jan 18 17:42 /etc/config/wireless

and after running uci set network.test=test; uci commit network

root@OpenWrt:~# ls -lh /etc/config/*
-rw-r--r--    1 root     root        1.5K Jan 19 04:16 /etc/config/dhcp
-rw-r--r--    1 root     root         328 Jan 19 04:17 /etc/config/dnscrypt-proxy
-rw-r--r--    1 root     root          90 Jan 18 17:42 /etc/config/dropbear
-rw-r--r--    1 root     root        6.0K Jan 19 08:16 /etc/config/firewall
-rw-r--r--    1 root     root         666 Jan 19 04:18 /etc/config/luci
-rw-r--r--    1 root     root        2.4K Jan 18 17:38 /etc/config/mwan3
-rw-r--r--    1 root     root        2.8K Jan 19 09:43 /etc/config/network
-rw-r--r--    1 root     root          97 Nov 21 18:40 /etc/config/rpcd
-rw-r--r--    1 root     root         471 Nov 28 11:23 /etc/config/system
-rw-r--r--    1 root     root         743 Jan 19 04:26 /etc/config/ucitrack
-rw-r--r--    1 root     root         688 Jan 19 04:25 /etc/config/uhttpd
-rw-r--r--    1 root     root        2.8K Jan 18 17:42 /etc/config/wireless

comment:3 Changed 2 years ago by jow

  • Resolution set to worksforme
  • Status changed from new to closed

So everything seems fine. Those temp files are produced by "uci" or rather "libuci" and not by LuCI. Such files usually remain if I/O errors occur while committing configs. Maybe your overlay was broken or you ran out of disk space in the past.

comment:4 Changed 2 years ago by anonymous

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I don't think this is fine. Xiaomi mini is supported device so overlay could not get broken, and the images I flash are between 5 and 8 MB size, the rest of the flash is not used.

I've tried to restart device and generate archive again, all files are still present and it looks like they're created yesterday rather than in the past.

comment:5 Changed 2 years ago by jow

Of course those files are still present, you need to delete them manually.

comment:6 Changed 2 years ago by anonymous

from where?

root@OpenWrt:~# grep -r HHhf /
grep: /dev/log: No such device or address
grep: /dev/watchdog0: Resource busy
/dev/mtdblock6:����̞B�.network.uci-HHhfMI���z
/dev/mtdblock6:.network.uci-HHhfMI
/dev/mtdblock5:����̞B�.network.uci-HHhfMI���z
/dev/mtdblock5:.network.uci-HHhfMI
/dev/mtdblock3:����̞B�.network.uci-HHhfMI���z
/dev/mtdblock3:.network.uci-HHhfMI
grep: /dev/watchdog: Resource busy

grepping other dirs returns nothing.

comment:7 Changed 2 years ago by jow

rm /etc/config/.*.uci-*

comment:8 Changed 2 years ago by anonymous

ok. had to run ls -a /etc/config to show them since la /etc/config returned not found

Add Comment

Modify Ticket

Action
as reopened .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.