Modify

Opened 2 years ago

Closed 2 years ago

Last modified 19 months ago

#21593 closed defect (no_response)

WDR3600 freeze under load

Reported by: fthiery Owned by: developers
Priority: normal Milestone:
Component: packages Version: Chaos Calmer 15.05
Keywords: Cc:

Description

Having quite a lot of these devices on 1.5 hardware revision, on chaos calmer.

Under load (after ~1 hour of intense traffic), the device sometimes hangs completely. Swapping the unit does not fix it. We also don't think it's overheating, because the device sits in a cooled room, and we even ventilated it, still happens.

We have syslogs sent to a remote server, and there is absolutely nothing; all we know is that it will eventually freeze after some time of load, but completely randomly.

Anyone else having the issue ?

Any idea on how to debug this is more than welcome.

Our current workaround is a weekly reboot, but the problem may still happen.

Attachments (0)

Change History (13)

comment:1 Changed 2 years ago by bittorf@…

Anything which differs from OpenWrt-vanilla,
e.g. additional kernel-modules or kernel-patches?
Which OpenWrt-version was tested latest?

comment:2 Changed 2 years ago by nbd

  • Resolution set to no_response
  • Status changed from new to closed

comment:3 Changed 2 years ago by anonymous

This apparently has been fixed in the most recent firmware. See http://www.tp-link.com/en/download/TL-WDR3600.html#Firmware

It says:
Firmware TL-WDR3600_V1_150518
Fixed the bug that the WAN connection speed will dropped down after running the router for about a week.

comment:4 Changed 2 years ago by anonymous

I am having the same problem with latest trunk. Everything works fine in BB

comment:5 Changed 2 years ago by bittorf@…

@anonymous: please make a diff of the 2 latest GPL-tarballs, so you can point at the needed change.

comment:6 Changed 2 years ago by anonymous

Any new information to shed light on the issue?

comment:7 in reply to: ↑ description Changed 22 months ago by anonymous

Replying to fthiery:

We have syslogs sent to a remote server, and there is absolutely nothing; all we know is that it will eventually freeze after some time of load, but completely randomly.

Any idea on how to debug this is more than welcome.

Have you filtered out the possibility of just the LAN connection being dropped (the bug fixed in the latest TP-Link firmware (comment 3) sounds more like this being the case, but I am not sure if this is not a different bug)? So, the router wouldn't be able to send any more syslogs to the remote server, either. Maybe something like

while (true); do touch /root/stillAlive; sync; sleep 30; done

and check the file's timestamp after freeze/reboot (or periodically switch some LED on and off).

Is there any hardware watchdog (available to OpenWrt), which could be made to autoreboot the device in case of freezing?

comment:8 Changed 22 months ago by anonymous

Hi I was considering to install OpenWrt on my TL-WDR3600 because of random freeze.
I tried out every official firmware released by TP-LINK but after few days of testing the problem came out.

I'm beginning to suspect that something hardware could be possibly bad designed.

When the problem occurs I see the 2.4 GHz but no traffic through the interface and the device does not respond via eth. The only solution is power off.

comment:9 Changed 22 months ago by anonymous

Some one try DD-WRT custom firmware on it. I am also getting the same error. Router hang after three or four hours. After that i switch off the router and then turn on it. I am still using the Tp_link software. I will try dd-wrt firmware.

comment:10 follow-up: Changed 22 months ago by anonymous

Any word on this issue and are others having it too? I just bought one of these v1.5, so will let you know if it still happens.

comment:11 in reply to: ↑ 10 Changed 20 months ago by anonymous

Replying to anonymous:

Any word on this issue and are others having it too? I just bought one of these v1.5, so will let you know if it still happens.

Any Update? Is the router working for you? I am thinking about buying this router, but I am not sure if it will work correctly.

comment:12 Changed 19 months ago by anonymous

Having same problem, no solution found on Internet so far, reinstalation of latest firmeware 2015/05/18 did not help

comment:13 Changed 19 months ago by anonymous

Anythink works fine, just this bug :(

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.