Modify

Opened 11 years ago

Closed 10 years ago

Last modified 4 years ago

#2158 closed defect (wontfix)

kamikaze .config file for building a basic image, need help

Reported by: Ben Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: toolchain Version:
Keywords: Cc:

Description

Hi guys,
i've switched to kamikaze few weeks ago and i'm getting some troubles with my own custom image, i need to use kernel 2.6 so kamikaze should be my best bet, i've a Buffalo WHR-G54S (broadcom machine).
I've downloaded standard image from openwrt.org website (broadcom-*, kernel 2.6, no wifi), flashed it and start working with 192.168.1.1 default ip address, no troubles from the beginning.
Then i've started to build my own custom image with these steps:

  • created a new dir from scratch (kamikaze) and synced it with svn (svn co https://svn.openwrt.org/openwrt/trunk/ kamikaze)
  • inside this dir i've executed my make menuconfig
  • changed target system, so Broadcom BCM947xx/953xx (2.6)
  • changed target profile to No WiFi (i don't need it and it's not supported)
  • used squashfs as target images file system
  • selected image configuration and edited my new ip address (192.168.1.1) as well as netmask (255.255.255.0)

I'd like to change more things but this is the default, i just want to have a working image file so i've created my image with make and at the end i've got openwrt-brcm47xx-2.6-squashfs.trx file ready in my bin directory, pretty easy isn't it ?

OK, but the problem is.... it doesn't work !
i don't have serial mod inside this WHR-G54S so i cannot see what it happens but after flashing it by ssh console (mtd -r write firmware.trx linux) i've lost it... i'm continuously pinging router from my console to see what happens, after flashing i can see a boot from the router (no ping replies) and nothing more, even if i wait for 2/3 minutes.
I'm supposing i've done something wrong into my buildroot environment but i didn't changed anything, just svn and nothing more..
I don't need to have a working image, i need to build one by my own, is there anyone using buildroot and mips toolchain with a common router ? i just need your .config file, maybe mine is wrong by default, it doesn't matter if you've Buffalo, Linksys, Asus or whatever, just need 2.6, no wifi and the ip address you want.

I don't have a cue about this kind of error, can you please help me ?
thank you in advance for your reply
Kind Regards

Andrea (Ben) Benini

Attachments (0)

Change History (5)

comment:1 Changed 11 years ago by xkennyx at seznam.cz

This is development branch, this is the problem.
If you doesn't have serial then debugging is close to impossilble :(
Try more svn versions, maybe you are be lucky.

And next time please write questions to forum.

(I'm not developer but this is my opinion)
Jarek

comment:2 Changed 11 years ago by Ben

I'll add serial support today so i can output console messages
Ben

comment:3 Changed 11 years ago by Ben

Got serial support on it, don't know why but after squashfs init boot process stopped there... after some tests i've solved by:

  • tried to create a 2.4 kernel image (with same svn)
  • image worked fine
  • tried to recreate 2.6 image (same config, no mods)
  • image worked fine

it seems after few compiling and some auto patches problem is now solved, don't know why but it works. let me know if you need more info

Cheers
Ben

comment:4 Changed 10 years ago by florian

  • Resolution set to wontfix
  • Status changed from new to closed

comment:5 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.