Modify

Opened 2 years ago

Last modified 2 years ago

#21549 new defect

Regression in lantiq xway USB driver

Reported by: josef.schabasser@… Owned by: developers
Priority: highest Milestone:
Component: kernel Version: Chaos Calmer 15.05
Keywords: Cc:

Description

I found a regression in the lantiq xway USB driver.

In BB 14.07 everything worked fine.
In CC 15.05 (and rc2/3) the problem occures.

The connected devices (except hubs) are resetted over and over again. Only mass storage devices are tested. The devices are excessively resetted, so the SCSI subsystem reports 0 drive capacity.

The router is a Buffalo WBMR-HP-G300-H.
Tested BB 14.07 final and CC 15.05-rc2/3 and CC 15.05 final.

Installed software via opkg:

  • kmod-usb2
  • kmod-usb-storage
  • kmod-usb-storage-extras
  • kmod-fs-ext4
  • kmod-scsi-core
  • block-mount
  • usbutils

Attached logs:

  • dmesg of BB 14.07
  • dmesg of CC 15.05

both taken right after connecting the device

It also happens to thumb drives (extroot is now impossible).
I also found another thread in the forum: https://forum.openwrt.org/viewtopic.php?id=60057
In the thread it is dumbed down to an USB power issue.
In my case it is not a power issue, since the drive has its own PSU.

Attachments (3)

dmesg-after-plugin-BB-1407.txt (1.3 KB) - added by josef.schabasser@… 2 years ago.
dmesg-after-plugin-CC-1505.txt (7.6 KB) - added by josef.schabasser@… 2 years ago.
lsusb-v.txt (2.9 KB) - added by josef.schabasser@… 2 years ago.

Download all attachments as: .zip

Change History (4)

Changed 2 years ago by josef.schabasser@…

Changed 2 years ago by josef.schabasser@…

Changed 2 years ago by josef.schabasser@…

comment:1 Changed 2 years ago by anonymous

The previous ticket /ticket/21526.html can now be closed, due to this one. This ticket should be much more generic.

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.