Modify

Opened 2 years ago

Closed 2 years ago

#21539 closed defect (fixed)

lantiq: netifd doesn't start pppd anymore

Reported by: t0t3m1n Owned by: developers
Priority: normal Milestone: Designated Driver (Trunk)
Component: base system Version: Trunk
Keywords: Cc:

Description

Hi, i've recently upgraded my router's firmware but i have a problem with the new version, when i power on / restart the router netifd doesn't start pppd anymore. The only way i can get internet connection is running the command /etc/init.d/network restart from ssh. I don't know what's wrong, maybe it's a problem with my old configs ?

Some info:

Current broken fw version: OpenWrt Designated Driver r48138
Previous working fw version: OpenWrt Designated Driver r47199
Target: lantiq/xway (mips)
Device: Buffalo WBMR-HP-G300H

In attach you can find the logread output after power on / reboot (no pppd) and after the /etc/init.d/network restart

Attachments (2)

logread_power_on.txt (18.3 KB) - added by t0t3m1n 2 years ago.
logread_network_restart.txt (18.0 KB) - added by t0t3m1n 2 years ago.

Download all attachments as: .zip

Change History (11)

Changed 2 years ago by t0t3m1n

Changed 2 years ago by t0t3m1n

comment:1 Changed 2 years ago by mkresin

I guess this is a duplicate of #21420.

comment:2 Changed 2 years ago by t0t3m1n

mkresin you're right, sorry for the dupe. I'll temporary fix the problem putting "/etc/init.d/br2684ctl restart" in /etc/rc.local until it's fixed.

comment:3 Changed 2 years ago by anonymous

I have the same problem! Waiting for a fix :)

comment:4 Changed 2 years ago by anonymous

I tried r48321 but now it is worse. There is no nas0 created :)

comment:5 follow-up: Changed 2 years ago by anonymous

I don't think it will fix the nas0 problem but anyone tried r48458?

Should I create a new ticket?

comment:6 in reply to: ↑ 5 Changed 2 years ago by t0t3m1n

Replying to anonymous:

I don't think it will fix the nas0 problem but anyone tried r48458?

Should I create a new ticket?

This morning I have compiled trunk r48470, with this version pppd seems to start correctly and nas0 is created, so i think both problems are fixed. Can anyone else confirm this ?

Last edited 2 years ago by t0t3m1n (previous) (diff)

comment:7 Changed 2 years ago by anonymous

I will try it today or tomorrow :)

comment:8 Changed 2 years ago by anonymous

Ok I tested and it works! I think we can close this ticket!

Thank you!

comment:9 Changed 2 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.