Modify

Opened 2 years ago

Closed 2 years ago

#21538 closed defect (worksforme)

netifd / procd high load on target UML

Reported by: bittorf@… Owned by: developers
Priority: normal Milestone:
Component: packages Version: Trunk
Keywords: Cc:

Description

tested with r48138. fresh boot, nothing configured.

Mem: 16512K used, 9368K free, 276K shrd, 648K buff, 5740K cached
CPU:   0% usr   0% sys   0% nic 100% idle   0% io   0% irq   0% sirq
Load average: 5.03 4.36 1.80 1/25 2337
  PID  PPID USER     STAT   VSZ %VSZ %CPU COMMAND
 1876     1 root     S    15500  60%   0% /sbin/netifd
    1     0 root     S    13444  52%   0% /sbin/procd
  522     1 root     S     8972  35%   0% /sbin/ubusd
 1838     1 root     S     6988  27%   0% /sbin/logd -S 16
  629     1 root     S     3096  12%   0% /bin/ash --login
root@OpenWrt:/ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
2: eth8: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 62:9a:ea:9c:52:d0 brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 02:00:00:00:00:00 brd ff:ff:ff:ff:ff:ff
4: wlan1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 02:00:00:00:01:00 brd ff:ff:ff:ff:ff:ff
5: hwsim0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN 
    link/[803] 12:00:00:00:00:00 brd ff:ff:ff:ff:ff:ff

Attachments (0)

Change History (4)

comment:1 Changed 2 years ago by nbd

Have you tried increasing the RAM size? 16M is very small...

comment:2 Changed 2 years ago by bittorf@…

It boots with 32mb. top says 'Mem: 16512K used' - which is ok, see:

root@OpenWrt:/ free
             total       used       free     shared    buffers     cached
Mem:         25936      16408       9528        272        640       5656
-/+ buffers/cache:      10112      15824
Swap:        12284          0      12284

and

root@OpenWrt:/ ps
  PID USER       VSZ STAT COMMAND
    1 root     13436 S    /sbin/procd
    2 root         0 SW   [kthreadd]
    3 root         0 SW   [ksoftirqd/0]
    4 root         0 SW   [kworker/0:0]
    5 root         0 SW<  [kworker/0:0H]
    6 root         0 SW   [kworker/u2:0]
    7 root         0 SW<  [khelper]
    8 root         0 SW<  [writeback]
    9 root         0 SW   [kworker/u2:1]
   10 root         0 SW<  [crypto]
   11 root         0 SW   [kworker/0:1]
   42 root         0 SW<  [bioset]
   43 root         0 SW<  [kblockd]
   45 root         0 SW   [kswapd0]
   69 root         0 SW   [fsnotify_mark]
  361 root         0 SW<  [deferwq]
  364 root         0 SW<  [kworker/0:1H]
  365 root         0 SW<  [ext4-rsv-conver]
  868 root      8972 S    /sbin/ubusd
  973 root      3096 S    /bin/ash --login
 1977 root         0 SW<  [cfg80211]
 2094 root      6988 S    /sbin/logd -S 16
 2132 root     15500 S    /sbin/netifd
 2227 nobody    2928 S    /usr/sbin/dnsmasq -C /var/etc/dnsmasq.conf -k -x /var/run/dnsmasq/dnsmasq.pid
 2405 root      3068 S    /usr/sbin/crond -L /dev/null
 2605 root      3068 R    ps

comment:3 Changed 2 years ago by bittorf@…

i cannot reproduce it anymore. please close this ticket. i will recall if it happens again.

comment:4 Changed 2 years ago by nbd

  • Resolution set to worksforme
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.