Modify

Opened 11 years ago

Closed 10 years ago

Last modified 8 years ago

#2151 closed defect (fixed)

brcm47xx compile error in r8211

Reported by: anonymous Owned by: developers
Priority: normal Milestone:
Component: base system Version:
Keywords: Cc:

Description

make[6]: Entering directory `/home/keith/wl500gp-kernel-20070727/trunk/build_mipsel/linux-2.6-brcm47xx/linux-2.6.22.1'

CHK include/linux/version.h
CHK include/linux/utsrelease.h
CALL scripts/checksyscalls.sh
CHK include/linux/compile.h
CC arch/mips/bcm947xx/setup.o

arch/mips/bcm947xx/setup.c: In function 'plat_mem_setup':
arch/mips/bcm947xx/setup.c:144: error: storage size of 'port' isn't known
arch/mips/bcm947xx/setup.c:148: error: 'struct ssb_mipscore' has no member named 'serial_ports'
arch/mips/bcm947xx/setup.c:149: error: 'struct ssb_mipscore' has no member named 'serial_ports'
arch/mips/bcm947xx/setup.c:149: error: 'struct ssb_mipscore' has no member named 'serial_ports'
arch/mips/bcm947xx/setup.c:150: error: 'struct ssb_mipscore' has no member named 'serial_ports'
arch/mips/bcm947xx/setup.c:144: warning: unused variable 'port'
arch/mips/bcm947xx/setup.c:153: error: 'struct ssb_mipscore' has no member named 'nr_serial_ports'
arch/mips/bcm947xx/setup.c:154: error: 'struct ssb_mipscore' has no member named 'serial_ports'
arch/mips/bcm947xx/setup.c:159: error: dereferencing pointer to incomplete type
arch/mips/bcm947xx/setup.c:160: error: dereferencing pointer to incomplete type
arch/mips/bcm947xx/setup.c:161: error: dereferencing pointer to incomplete type
arch/mips/bcm947xx/setup.c:164: error: dereferencing pointer to incomplete type
make[7]: * [arch/mips/bcm947xx/setup.o] Error 1
make[6]:
* [arch/mips/bcm947xx] Error 2
make[6]: Leaving directory `/home/keith/wl500gp-kernel-20070727/trunk/build_mipsel/linux-2.6-brcm47xx/linux-2.6.22.1'
make[5]: * /home/keith/wl500gp-kernel-20070727/trunk/build_mipsel/linux-2.6-brcm47xx/linux-2.6.22.1/.image Error 2
make[5]: Leaving directory `/home/keith/wl500gp-kernel-20070727/trunk/target/linux/brcm47xx-2.6'
make[4]:
* [install] Error 2
make[4]: Leaving directory `/home/keith/wl500gp-kernel-20070727/trunk/target/linux'
make[3]: * [linux-install] Error 2
make[3]: Leaving directory `/home/keith/wl500gp-kernel-20070727/trunk/target'
make[2]:
* [target/install] Error 2
make[2]: Leaving directory `/home/keith/wl500gp-kernel-20070727/trunk'
make[1]: * [world] Error 2
make[1]: Leaving directory `/home/keith/wl500gp-kernel-20070727/trunk'
make:
* [world] Error 2

Attachments (1)

config (31.9 KB) - added by jmranger@… 10 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 11 years ago by anonymous

This should be easier to read:

make[6]: Entering directory `/home/keith/wl500gp-kernel-20070727/trunk/build_mipsel/linux-2.6-brcm47xx/linux-2.6.22.1'
  CHK     include/linux/version.h
  CHK     include/linux/utsrelease.h
  CALL    scripts/checksyscalls.sh
  CHK     include/linux/compile.h
  CC      arch/mips/bcm947xx/setup.o
arch/mips/bcm947xx/setup.c: In function 'plat_mem_setup':
arch/mips/bcm947xx/setup.c:144: error: storage size of 'port' isn't known
arch/mips/bcm947xx/setup.c:148: error: 'struct ssb_mipscore' has no member named 'serial_ports'
arch/mips/bcm947xx/setup.c:149: error: 'struct ssb_mipscore' has no member named 'serial_ports'
arch/mips/bcm947xx/setup.c:149: error: 'struct ssb_mipscore' has no member named 'serial_ports'
arch/mips/bcm947xx/setup.c:150: error: 'struct ssb_mipscore' has no member named 'serial_ports'
arch/mips/bcm947xx/setup.c:144: warning: unused variable 'port'
arch/mips/bcm947xx/setup.c:153: error: 'struct ssb_mipscore' has no member named 'nr_serial_ports'
arch/mips/bcm947xx/setup.c:154: error: 'struct ssb_mipscore' has no member named 'serial_ports'
arch/mips/bcm947xx/setup.c:159: error: dereferencing pointer to incomplete type
arch/mips/bcm947xx/setup.c:160: error: dereferencing pointer to incomplete type
arch/mips/bcm947xx/setup.c:161: error: dereferencing pointer to incomplete type
arch/mips/bcm947xx/setup.c:164: error: dereferencing pointer to incomplete type
make[7]: *** [arch/mips/bcm947xx/setup.o] Error 1
make[6]: *** [arch/mips/bcm947xx] Error 2
make[6]: Leaving directory `/home/keith/wl500gp-kernel-20070727/trunk/build_mipsel/linux-2.6-brcm47xx/linux-2.6.22.1'
make[5]: *** [/home/keith/wl500gp-kernel-20070727/trunk/build_mipsel/linux-2.6-brcm47xx/linux-2.6.22.1/.image] Error 2
make[5]: Leaving directory `/home/keith/wl500gp-kernel-20070727/trunk/target/linux/brcm47xx-2.6'
make[4]: *** [install] Error 2
make[4]: Leaving directory `/home/keith/wl500gp-kernel-20070727/trunk/target/linux'
make[3]: *** [linux-install] Error 2
make[3]: Leaving directory `/home/keith/wl500gp-kernel-20070727/trunk/target'
make[2]: *** [target/install] Error 2
make[2]: Leaving directory `/home/keith/wl500gp-kernel-20070727/trunk'
make[1]: *** [world] Error 2
make[1]: Leaving directory `/home/keith/wl500gp-kernel-20070727/trunk'
make: *** [world] Error 2

comment:2 Changed 11 years ago by florian

  • Resolution set to fixed
  • Status changed from new to closed

I cannot reproduce the bug here, seems to have been fixed.

comment:3 Changed 10 years ago by jmranger@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

Reproduced while compiling 2.6.23.1, target "Broadcom BCM947xx/953xx [2.6]", profile "WRTSL54GS". I'll attach the .config in a moment.
Fixed (at least partially - build fails later) by enabling CONFIG_SSB_DRIVER_MIPS.

Reporting mostly for general knowledge. Not sure if this can be fixed.

Changed 10 years ago by jmranger@…

comment:4 Changed 10 years ago by jmranger@…

Forgot to say: SVN 10284

comment:5 Changed 10 years ago by noz

  • Resolution set to fixed
  • Status changed from reopened to closed

I believe this is now fixed, as the brcm47xx target has had ssb upgrades and compiles against a newer kernel now (r11462)

comment:6 Changed 8 years ago by fingaz001 <mpitsikm@…>

having problem compiling qpenwrt this my error after trying make V=99

import distutils.core

ImportError: No module named distutils.core
make[4]: * [build] Error 1
make[4]: Leaving directory `/home/fingaz001/trunk/build_dir/host/ipkg-utils-1.7'
make[3]:
* /home/fingaz001/trunk/build_dir/host/ipkg-utils-1.7/.built Error 2
make[3]: Leaving directory `/home/fingaz001/trunk/tools/ipkg-utils'
make[2]: * [tools/ipkg-utils/compile] Error 2
make[2]: Leaving directory `/home/fingaz001/trunk'
make[1]:
* /home/fingaz001/trunk/staging_dir/target-mips_uClibc-0.9.30.1/stamp/.tools_install_nnn Error 2
make[1]: Leaving directory `/home/fingaz001/trunk'
make: * [world] Error 2

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.