Modify

Opened 2 years ago

Closed 2 years ago

#21436 closed defect (not_a_bug)

Lantiq TP-Link TD-W8970 vdsl not connect anymore

Reported by: DuDu371 Owned by: developers
Priority: high Milestone: Designated Driver (Trunk)
Component: packages Version: Trunk
Keywords: vdsl, lantiq, W8970 Cc:

Description

Previously i was on the r47881 and everything was fine.
After some new patches for the lantiq platform i upgraded to the r48005.
When the router reboots the vdsl connection doesn't connect anymore and the dsl_control daemon loops between "init,silent,exception".
After some research i found that reverting the commit r47933, fixes this problem.

Attachments (1)

network (950 bytes) - added by anonymous 2 years ago.

Download all attachments as: .zip

Change History (3)

Changed 2 years ago by anonymous

comment:1 Changed 2 years ago by mkresin

The OpenWrt logic is weird and awful error prone here.

To signal openwrt that you want to establish a VDSL connection, you have to remove the annex option in your network configuration. As soon as you have an annex option in your network configuration, OpenWrt assumes it's an ADSL line.

It only worked all the time, due to a bug that was fixed with r47933.

TL/DR: Remove the annex option in your /etc/config/network.

comment:2 Changed 2 years ago by blogic

  • Resolution set to not_a_bug
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.