Modify

Opened 2 years ago

Closed 2 years ago

#21420 closed defect (fixed)

lantiq TP-LINK w8970

Reported by: anonymous Owned by: developers
Priority: high Milestone:
Component: packages Version: Trunk
Keywords: Cc:

Description

once you docked the carrier, configured, does not connect automatically with PPPoE. In my case I have to change the protocol PPoA save, reciprocate in PPoE enter data save, and the only way the modem connects.

Attachments (0)

Change History (14)

comment:1 follow-up: Changed 2 years ago by anonymous

what openwrt version are you using?

comment:2 in reply to: ↑ 1 Changed 2 years ago by anonymous

Replying to anonymous:

what openwrt version are you using?

r47953

comment:3 Changed 2 years ago by mkresin

What line type do you have? adsl or vdsl?

Please paste your /etc/config/network and the output of /etc/init.d/dsl_control status.

comment:4 Changed 2 years ago by anonymous

ok i have adsl

this is /etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdc2:7aa9:0541::/48'

config interface 'lan'
	option force_link '1'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ifname 'eth0.1'
	option macaddr 'c4:6e:1f:a2:03:0c'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 2 4 5 6t'

config atm-bridge 'atm'
	option vpi '8'
	option vci '35'
	option encaps 'llc'
	option payload 'bridged'

config interface 'wan'
	option _orig_ifname 'nas0'
	option _orig_bridge 'false'
	option ifname 'nas0'
	option proto 'pppoe'
	option username 'aliceadsl'
	option password 'aliceadsl'
	option service 'aliceadsl'
	option ipv6 'auto'

config interface 'wan6'
	option ifname '@wan'
	option proto 'dhcpv6'

config vdsl 'dsl'
	option annex 'a'
	option firmware '/lib/firmware/vdsl.bin'
	option tone 'av'
	option xfer_mode 'atm'

this is output /etc/init.d/dsl_control status

ATU-C Vendor ID:                          B5,00,49,46,54,4E,82,B3
ATU-C System Vendor ID:                   00,00,30,30,30,30,00,00
Chipset:                                  Lantiq-VRX200 Unknown
Firmware Version:                         5.7.1.8.0.1
API Version:                              4.16.6.3
XTSE Capabilities:                        0x0, 0x0, 0x0, 0x0, 0x0, 0x1, 0x0, 0x0
Annex:                                    A
Line Mode:                                G.992.5 (ADSL2+)
Line State:                               UP [0x801: showtime_tc_sync]
Forward Error Correction Seconds (FECS):  Near: 532 / Far: 0
Errored seconds (ES):                     Near: 2 / Far: 0
Severely Errored Seconds (SES):           Near: 0 / Far: 0
Loss of Signal Seconds (LOSS):            Near: 0 / Far: 6
Unavailable Seconds (UAS):                Near: 47 / Far: 47
Header Error Code Errors (HEC):           Near: 4 / Far: 0
Non Pre-emtive CRC errors (CRC_P):        Near: 0 / Far: 0
Pre-emtive CRC errors (CRCP_P):           Near: 0 / Far: 0
Power Management Mode:                    L0 - Synchronized
Latency / Interleave Delay:               Down: Interleave (16.0 ms) / Up: Interleave (9.25 ms)
Data Rate:                                Down: 5.763 Mb/s / Up: 478 Kb/s
Line Attenuation (LATN):                  Down: 50.1dB / Up: 30.6dB
Signal Attenuation (SATN):                Down: 48.0dB / Up: 30.6dB
Noise Margin (SNR):                       Down: 10.1dB / Up: 25.2dB
Aggregate Transmit Power(ACTATP):         Down: 19.8dB / Up: 12.4dB
Max. Attainable Data Rate (ATTNDR):       Down: 5.696 Mb/s / Up: 940 Kb/s
Line Uptime Seconds:                      645
Line Uptime:                              10m 45s

Also with r47961 the problem persist

comment:5 Changed 2 years ago by anonymous

The problem that has been entered from r47917 ?

comment:6 Changed 2 years ago by mkresin

Config looks fine to me. Would you please paste the output of logread after your adsl line is in sync for 1 or 2 minutes.

Would you please try the following:

  1. change option ipv6 'auto' to option ipv6 '0'
  2. boot with DSL cable detached; run /etc/init.d/br2684ctl restart; connect you DSL cable
  3. try with r47915

Please report back whether any of the points fixed your issue. If 1. works for you, there is no need to try 2. and 3.

Last edited 2 years ago by mkresin (previous) (diff)

comment:7 Changed 2 years ago by xsiriusx

OK then! after restart, after fastening the carrier, just enter ssh and give the command

/etc/init.d/br2684ctl restart

.

in this way we connect to the Internet immediately. I inserted the line in /etc/rc.local Sturtup that way even after a reboot remotely relates to the Internet without problems

comment:8 Changed 2 years ago by mkresin

Okay, in that case the problematic commit is r47891.

The developer is aware of the problem. For more details follow the chat between obstnerd and ndb: http://logs.nslu2-linux.org/livelogs/openwrt-devel/openwrt-devel.20151216.txt

comment:9 Changed 2 years ago by blogic

  • Resolution set to fixed
  • Status changed from new to closed

comment:10 Changed 2 years ago by mkresin

  • Resolution fixed deleted
  • Status changed from closed to reopened

This one is not yet fixed.

comment:11 Changed 2 years ago by anonymous

No fix yet?

comment:12 Changed 2 years ago by nbd

please try r48321

comment:13 Changed 2 years ago by xsiriusx85@…

with the ' latest release No way to get it to connect ! and the switches do not work more Ethernet ports can be accessed only via wifi

comment:14 Changed 2 years ago by nbd

  • Resolution set to fixed
  • Status changed from reopened to closed

ethernet issue fixed in r48546

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.